Welcome to the North American Subaru Impreza Owners Club Saturday August 29, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Southern California Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Southern California Impreza Club Forum -- SCIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-18-2015, 04:46 PM   #1
Josh909
Scooby Newbie
 
Member#: 167725
Join Date: Dec 2007
Location: 909 CA
Vehicle:
2004 WRX
Silver

Default Readiness monitors after reflash AP2

Long story short, my car was in the body shop when registration was due. I paid the fees but still needed a smog to get tags. I had a check engine light for tgv deletes and a bad O2. I fixed th O2, put on a new blouch 1.5xtr and took it to get tuned. Well I flashed for the tune of course and the 90 mile drive home wasn't enough to get the readiness monitors to reset. How long does this take, in everyone else's experience? Oh this is also an accessport reflash
* Registered users of the site do not see these ads.
Josh909 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 06-19-2015, 02:17 PM   #2
Josh909
Scooby Newbie
 
Member#: 167725
Join Date: Dec 2007
Location: 909 CA
Vehicle:
2004 WRX
Silver

Default

Anyone? Someone has to have some idea here
Josh909 is offline   Reply With Quote
Old 06-27-2015, 03:16 PM   #3
STidub
Scooby Newbie
 
Member#: 142031
Join Date: Feb 2007
Chapter/Region: SCIC
Location: Lake Forest
Vehicle:
2005 CGM STi

Default

I was in a similar situation with readiness monitors not set and the tech told me to try to drive at about 35 mph (can't remember if this is exactly the speed or if it was rpm's but I think the main idea is to keep the engine at a constant rpm/speed) for as long as possible without stopping and that they should reset after maybe 20 to 30 minutes. I found a street in an industrial neighborhood where I could drive that speed for maybe a mile without hitting any stoplights and just went back and forth on it. I did it for 30 minutes then went back to the shop and he hooked up my car and it was still no good. I did it again for maybe another 30 minutes and checked but still a no go. Then after the third time of driving for another 30 minutes everything had reset. Pain in the rear.
STidub is offline   Reply With Quote
Old 06-30-2015, 08:41 AM   #4
file_id
Scooby Specialist
 
Member#: 28197
Join Date: Oct 2002
Chapter/Region: SCIC
Vehicle:
2003 WRX w/ VF34
WRB

Default

here you go. http://techinfo.subaru.com/proxy/652...72-0458832.pdf If you need to specifically find out what is causing your car to not pass I have a bluedriver obd2 diagnostic tool which I used to tell me when the car was ok to be smogged in realtime. I'd be happy to read it for you if you're ever in the LAX area.
file_id is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 11:04 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.