Welcome to the North American Subaru Impreza Owners Club Tuesday October 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-24-2011, 11:34 PM   #1
.KR3W.
Scooby Newbie
 
Member#: 293951
Join Date: Sep 2011
Location: Miney Miney Tiny Tine Town
Vehicle:
2009 WRX
DGM

Default PLEASE HELP! 09 WRX Traction Control and Hill Assist Lights

Just picked up an 09 WRX today. Whilst driving, i noticed both the hill assist and traction control lights remained illuminated while driving. I asked the previous owner what was up and he told me that he broke a wire when he tried to replace the OEM steering wheel. He said he got everything fixed, but the head tech guy at the subaru dealership wanted $600 to do a reset to resume the functionality of hill assist and traction control.

So as you can assume, i don't want to pay $600 for somebody to press a few buttons. Anybody have any info on this?
* Registered users of the site do not see these ads.
.KR3W. is offline   Reply With Quote
Old 10-25-2011, 12:38 AM   #2
jay25RS
Scooby Specialist
 
Member#: 4273
Join Date: Feb 2001
Chapter/Region: NESIC
Location: CT
Vehicle:
2011 GR-STI
& 2015 Legacy Ltd.

Default

Try disconnecting the battery for a bit and then see if it goes away.
jay25RS is offline   Reply With Quote
Old 10-25-2011, 02:01 AM   #3
.KR3W.
Scooby Newbie
 
Member#: 293951
Join Date: Sep 2011
Location: Miney Miney Tiny Tine Town
Vehicle:
2009 WRX
DGM

Default

Quote:
Originally Posted by jay25RS View Post
Try disconnecting the battery for a bit and then see if it goes away.
I will try this. But the fact that they're on doesn't bother me, it's that i can't use either of the features (even though i'm not 100% sure what "traction control" does). Hill Assist, however, does seem pretty neat and i'd like to see how it works.
.KR3W. is offline   Reply With Quote
Old 10-26-2011, 07:39 PM   #4
cootch1083
Scooby Newbie
 
Member#: 247159
Join Date: May 2010
Location: Bergen County, NJ
Vehicle:
2010 WRX
Dark Gray Metallic

Default

its a brake switch or something like that. had the problem with my car, i would turn the car of and it would be gone for a few secs then come back on. it was fixed under warranty

just looked it up in my filing cabinet. tested and inspected, tech noted trouble code COO57/COO54- Brake switch open

they removed and replaced my brake switch. everything was fine after that

Last edited by cootch1083; 10-26-2011 at 07:46 PM. Reason: verified
cootch1083 is offline   Reply With Quote
Old 10-27-2011, 01:20 AM   #5
.KR3W.
Scooby Newbie
 
Member#: 293951
Join Date: Sep 2011
Location: Miney Miney Tiny Tine Town
Vehicle:
2009 WRX
DGM

Default

Quote:
Originally Posted by cootch1083 View Post
its a brake switch or something like that. had the problem with my car, i would turn the car of and it would be gone for a few secs then come back on. it was fixed under warranty

just looked it up in my filing cabinet. tested and inspected, tech noted trouble code COO57/COO54- Brake switch open

they removed and replaced my brake switch. everything was fine after that
hmm, interesting. This probably won't be covered by warranty since the damage was caused by the previous owner. Do you have any more info on this, such as the part number?
.KR3W. is offline   Reply With Quote
Old 10-27-2011, 01:38 PM   #6
cootch1083
Scooby Newbie
 
Member#: 247159
Join Date: May 2010
Location: Bergen County, NJ
Vehicle:
2010 WRX
Dark Gray Metallic

Default

What yr is your car?? It should be covered regardless. And if it's not, I can't see it being too expensive. Not a big job.

I'll have to check once a get home again to see if there was a part number on it.
cootch1083 is offline   Reply With Quote
Old 10-28-2011, 12:36 AM   #7
.KR3W.
Scooby Newbie
 
Member#: 293951
Join Date: Sep 2011
Location: Miney Miney Tiny Tine Town
Vehicle:
2009 WRX
DGM

Default

Quote:
Originally Posted by cootch1083 View Post
What yr is your car?? It should be covered regardless. And if it's not, I can't see it being too expensive. Not a big job.

I'll have to check once a get home again to see if there was a part number on it.
It's an 09. I was told that the tech guy at subaru "hates people who modify their cars", so i think the warranty claim was denied for that reason. Alright thanks mate!
.KR3W. is offline   Reply With Quote
Old 10-28-2011, 10:00 PM   #8
.KR3W.
Scooby Newbie
 
Member#: 293951
Join Date: Sep 2011
Location: Miney Miney Tiny Tine Town
Vehicle:
2009 WRX
DGM

Default

bump for some more ideas of what this could be
.KR3W. is offline   Reply With Quote
Old 10-29-2011, 12:47 AM   #9
.KR3W.
Scooby Newbie
 
Member#: 293951
Join Date: Sep 2011
Location: Miney Miney Tiny Tine Town
Vehicle:
2009 WRX
DGM

Default

Note: The lights i am talking about are the warning lights that have the slashes through them
.KR3W. is offline   Reply With Quote
Old 10-29-2011, 01:11 AM   #10
jlemond
Scooby Newbie
 
Member#: 206968
Join Date: Mar 2009
Chapter/Region: SCIC
Location: So-Cal
Vehicle:
2009 WRX Hatch
OBP

Default

I fubared a wire not 3k miles into my car. It cost me just shy of $300 for the dealer to track, repair the wire and reset the code.

Whatever wire I fubared turned off traction control, hill assist, as well as cruise control.
jlemond is offline   Reply With Quote
Old 10-29-2011, 01:32 AM   #11
.KR3W.
Scooby Newbie
 
Member#: 293951
Join Date: Sep 2011
Location: Miney Miney Tiny Tine Town
Vehicle:
2009 WRX
DGM

Default

was there a light that came up to show your cruise control wasn't working? Cause it's just the Traction Control and Hill Assist lights for me. I'm going into subaru for an oil change this thursday so i will inquire on it then

Last edited by .KR3W.; 10-29-2011 at 01:39 AM.
.KR3W. is offline   Reply With Quote
Old 10-29-2011, 01:46 AM   #12
jlemond
Scooby Newbie
 
Member#: 206968
Join Date: Mar 2009
Chapter/Region: SCIC
Location: So-Cal
Vehicle:
2009 WRX Hatch
OBP

Default

No light for the cruise control. If your hill assist dosnt work cruise shouldn't work. At least that's how the dealer explained it to me. I did however try cruise multiple times with the same effect of failure time after time.
jlemond is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
09 WRX-VDC, ABS, and Hill Assist Warning Lights Subirex09 Warranty Issues & SOA Problems 44 06-19-2013 03:53 PM
Please Help New WRX Owner Rust and Ticking, PICS MixTracks Newbies & FAQs 80 02-15-2013 09:24 PM
09-10 wrx abs,traction,hill assist lights felya589 Newbies & FAQs 3 03-26-2010 05:53 PM
Traction Control Light and Hil Assist Light On kwanjie Brakes, Steering & Suspension 2 05-26-2009 09:56 AM
Traction Control/ABS/Hill hold system shutting off Studebaker83 Warranty Issues & SOA Problems 8 01-24-2008 12:48 AM


All times are GMT -4. The time now is 11:53 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.