Welcome to the North American Subaru Impreza Owners Club Wednesday September 17, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Rocky Mountains Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Rocky Mountains Impreza Club Forum -- RMIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-06-2011, 01:43 AM   #1
Mush04
Scooby Specialist
 
Member#: 191705
Join Date: Oct 2008
Chapter/Region: RMIC
Location: Nowhere of importance
Vehicle:
2007 Limited STi
Swp

Default Mush's Car Thread.

So I have never really made a thread about my car, mainly cause it's not a crazy build like some of yours, all of you know which ones I'm talking about.

Also seems as though the RMIC has been a little on the slow side lately as well.

So I bought the car June of 2008 and it had the following modifications;

Cobb lowering sprins
Cobb catted downpipe w/custom built 3" exhaust

and looked like this minus the black wheels and blacked out headlights


I had Lance black out my headlights did a great job!

I have been slowly......really slowly haha building it for the track, coming along slowly but I am loving the car none the less!

I wont make this too long so I'll just list what I've done and post some pictures then just update when there's something to update

Suspension/Braking
Cobb Springs
Cobb adjustable sway w/mounts and helix HD endlinks
Whiteline front 22mm sway no endlinks yet
Godspeed rear lateral links
Front Powerslots w/Hawk hps pads
Strut tower bar (ebay)

Engine/Performance
Cobb SF
Large Top Mount (ebay)
800cc modded injectors
255 Walbro
Cobb heatshield
Cobb catted DP 3" exhaust
Sti up-pipe ceramic coated
Td05 20G P&P'd ceramic coated
Perrin turbo inlet
Samco after maf
HAO 3 Port BCS

Exterior/Misc
Front and rear tow hooks (rear from 801sti, front from NotEwrx)
Seibon CF Hood
06/07 WRX wheels painted vintage metallic copper
Sti spoiler
Blue headlight tint
Yellow fog light covers
Anti bumper sag clips
Prosport boost and volt gauges


Parts that are waiting in the garage to be installed

UTEC

Should be in the mid 300's maybe higher.

Anyway some will hate some will have constructive criticism and some will just not even care oh well




more pics to come after it's finally detailed! Enjoy
* Registered users of the site do not see these ads.

Last edited by Mush04; 03-28-2012 at 07:16 PM. Reason: Parts installed
Mush04 is offline   Reply With Quote
Old 11-06-2011, 01:46 AM   #2
axleon2
Scooby Guru
 
Member#: 154117
Join Date: Jul 2007
Chapter/Region: RMIC
Location: Midvale, Utah
Vehicle:
2004 WRX
JBP

Default

Make it as long as you want who gives a **** what anyone else thinks...
axleon2 is offline   Reply With Quote
Old 11-06-2011, 01:49 AM   #3
Mush04
Scooby Specialist
 
Member#: 191705
Join Date: Oct 2008
Chapter/Region: RMIC
Location: Nowhere of importance
Vehicle:
2007 Limited STi
Swp

Default

this is true plenty of others have done the same I guess

but this way I can just update it when something else is done instead of having to search through the got bored and did blah blah blah thread haha
Mush04 is offline   Reply With Quote
Old 11-06-2011, 01:43 AM   #4
slowbugeye02
Scooby Newbie
 
Member#: 284111
Join Date: May 2011
Chapter/Region: RMIC
Location: SL,UT
Vehicle:
2004 FXT

Default

Looks sick!! Who did you have pnp your turbo and coat it?
slowbugeye02 is offline   Reply With Quote
Old 11-06-2011, 09:28 AM   #5
car_cursed
Scooby Guru
 
Member#: 85327
Join Date: Apr 2005
Chapter/Region: RMIC
Location: West Jordan, UT
Vehicle:
More projects than
you can shake a stick at.

Default

looks good, sticking with the tmic or will you go front mount too? And anymore plans for the suspension and brakes? Going fast is fun, but stopping would be good too.
car_cursed is online now   Reply With Quote
Old 11-06-2011, 12:15 PM   #6
Mush04
Scooby Specialist
 
Member#: 191705
Join Date: Oct 2008
Chapter/Region: RMIC
Location: Nowhere of importance
Vehicle:
2007 Limited STi
Swp

Default

Quote:
Originally Posted by slowbugeye02 View Post
Looks sick!! Who did you have pnp your turbo and coat it?
His name is Richard and he has an add on ksl and he's been rebuilding turbos for about 10 years or so, he has really good pricing!

Here's his link if anyone is interested

http://www.ksl.com/index.php?nid=218...urbo%20rebuild

As far as suspension I have been wanting coil overs for awhile just need some more monies, brakes I will eventually get at least front brembos or something similar depending on what I find or what's out at the time. I will probably get some SS lines and good brake fluid before the BBK though I've heard that is fairly similar to brembos and will replace the hawk hps with the hps+.

I will most likely stick with the large top mount at least for now.

Thanks for the kind words!!!!
Mush04 is offline   Reply With Quote
Old 11-06-2011, 01:20 PM   #7
rolzrex
Scooby Specialist
 
Member#: 85790
Join Date: Apr 2005
Chapter/Region: RMIC
Location: Fairfield, Pa.
Vehicle:
11 STi
pbp

Default

carbon trunk and blk vinyl wrap the roof to complete the blk/white theme!
rolzrex is offline   Reply With Quote
Old 11-06-2011, 01:42 PM   #8
axleon2
Scooby Guru
 
Member#: 154117
Join Date: Jul 2007
Chapter/Region: RMIC
Location: Midvale, Utah
Vehicle:
2004 WRX
JBP

Default

I agree with Nate^
axleon2 is offline   Reply With Quote
Old 11-06-2011, 02:07 PM   #9
Mush04
Scooby Specialist
 
Member#: 191705
Join Date: Oct 2008
Chapter/Region: RMIC
Location: Nowhere of importance
Vehicle:
2007 Limited STi
Swp

Default

Yeah I was looking for a cf trunk awhile ago never pulled the trigger though, I may have my brother in law help me with the vinyl wrap though.
Mush04 is offline   Reply With Quote
Old 11-06-2011, 05:32 PM   #10
Henriksen
Scooby Newbie
 
Member#: 290178
Join Date: Aug 2011
Chapter/Region: RMIC
Location: Utah, Utah E85 County
Vehicle:
2008 DGM STi-Ituned
2008 R6

Default

Looks good!
Henriksen is offline   Reply With Quote
Old 11-06-2011, 05:51 PM   #11
Mush04
Scooby Specialist
 
Member#: 191705
Join Date: Oct 2008
Chapter/Region: RMIC
Location: Nowhere of importance
Vehicle:
2007 Limited STi
Swp

Default

Thank you sir!
Mush04 is offline   Reply With Quote
Old 11-06-2011, 10:00 PM   #12
jackiechan78
Scooby Newbie
 
Member#: 26463
Join Date: Oct 2002
Chapter/Region: RMIC
Location: Utah
Vehicle:
2002 WRX
WRB

Default

Looks good Mush. We should do another In-N-Out run, we've both been updating our suby's. Yours looks good, love the power upgrades.
jackiechan78 is offline   Reply With Quote
Old 11-06-2011, 10:52 PM   #13
907Bum
Scooby Specialist
 
Member#: 183634
Join Date: Jul 2008
Chapter/Region: RMIC
Location: At the "B"
Vehicle:
02 wrx/ 92 ss
Booze fueled :)

Default

Fwiw my car made 301whp on e with a similar turbo and supporting bolt ons. Just remember its only a number, when I ran my car there was no fan over my tmic or air really moving through the engine bay, this hurt my output for sure. A big fmic would help, or just mess with correction factors till you get the numbers you want
907Bum is offline   Reply With Quote
Old 11-06-2011, 11:38 PM   #14
Not-EWRX
Scooby Specialist
 
Member#: 158043
Join Date: Aug 2007
Chapter/Region: RMIC
Location: SLC
Vehicle:
2013 Wrx Hatch
SWP

Default

Ha nice to see my hook on there.
Not-EWRX is offline   Reply With Quote
Old 11-07-2011, 01:14 PM   #15
Mush04
Scooby Specialist
 
Member#: 191705
Join Date: Oct 2008
Chapter/Region: RMIC
Location: Nowhere of importance
Vehicle:
2007 Limited STi
Swp

Default

Quote:
Originally Posted by jackiechan78 View Post
Looks good Mush. We should do another In-N-Out run, we've both been updating our suby's. Yours looks good, love the power upgrades.
Thanks man, yeah another In-N-Out run would be awesome, the only down side is I don't work at the credit union anymore, I work overnights so during the day I have both my little kids haha but we should still figure something out sometime!

Quote:
Originally Posted by 907Bum View Post
Fwiw my car made 301whp on e with a similar turbo and supporting bolt ons. Just remember its only a number, when I ran my car there was no fan over my tmic or air really moving through the engine bay, this hurt my output for sure. A big fmic would help, or just mess with correction factors till you get the numbers you want
Yeah thy are just numbers but makes me feel better the higher those numbers are . When we tune the car it's not on a dyno either, road tune, fingers crossed I can make it through another tune without any cop issues

Quote:
Originally Posted by Not-EWRX View Post
Ha nice to see my hook on there.
Yeah for sure! I love it, I do need to repaint it but I have had several compliments on it as well!
Mush04 is offline   Reply With Quote
Old 11-09-2011, 12:28 PM   #16
LKY13
Scooby Newbie
 
Member#: 136609
Join Date: Jan 2007
Chapter/Region: RMIC
Location: Saratoga
Vehicle:
'99 GF8-OBS
Silver/Graphite

Default

Good to see you're still rockin' it M. I don't see you parked at the bank anymore, but I did see you at Bangerter and 114s a few days ago. I should have hit you up over the summer for wow. Thought I'd probably see you, but didn't recognize anyone. Cool thread though. I wish my car was that nice.
LKY13 is offline   Reply With Quote
Old 11-09-2011, 05:11 PM   #17
Mush04
Scooby Specialist
 
Member#: 191705
Join Date: Oct 2008
Chapter/Region: RMIC
Location: Nowhere of importance
Vehicle:
2007 Limited STi
Swp

Default

thanks man!! It really really.........really needs a good wash and wax, but I actually didn't even get out to wow this summer too much going on with our newest addition, and work and crap. and yeah I actually left the credit union shortly after my daughter was born, I work overnights now. next summer for sure we'll have to get out to MMP a couple times.

saturday is almost here!! hopefully I'll have enough time to wash it after the install so I can get a few new pictures up!
Mush04 is offline   Reply With Quote
Old 11-13-2011, 12:25 AM   #18
Mush04
Scooby Specialist
 
Member#: 191705
Join Date: Oct 2008
Chapter/Region: RMIC
Location: Nowhere of importance
Vehicle:
2007 Limited STi
Swp

Default

Ok so I didn't get everything finished today, but I ran into a snag, I didn't notice that with the turbo inlet it only has 3 spigots. my main question is on the very rear one, from some searching looks like people are just blocking off the hose with that sensor. sounds like it wont harm anything or throw any cels, just wanted to see if some of you that have installed did the same thing? also what you used to block the hose off with/where you got it from? thanks in advance for any help!
Mush04 is offline   Reply With Quote
Old 11-27-2011, 02:00 PM   #19
Mush04
Scooby Specialist
 
Member#: 191705
Join Date: Oct 2008
Chapter/Region: RMIC
Location: Nowhere of importance
Vehicle:
2007 Limited STi
Swp

Default

Ok so quick update on everything since it's been awhile since I did haha

I installed the turbo and inlet and all, then had to run up to get it tuned, the second I was giving it any kind of gas (not boosting really) just enough gas to drive normally it was making a whinning sound, pulled over to check if I had a hose that I forgot to connect or one that popped off or just leaking maybe.....well couldn't see anything so I talked to jason on my way up to his place and we couldn't think of anything so we figured just air flow noise.

Got it all hooked up and went on with tuning, after a few pulls it was starting to show it's potential and was feeling great! a little laggy (need more torque haha) but overall it felt great and ended up about 330 whp and I think it was 240 ish wtq

Well 2 days later I was on my way home from work and was just barely getting into any boost and the car started screaming!!! pulled over looked for any hoses or anything not connected couldn't find anything I gimped it home and talked with the guy I got the turbo from and he said he would look at it and fix if need be.

Had an issue with the nut right under the DP so I had to cut it out which took forever (till I got the right tools haha) anyway finally got it out and took it to the guy and turns out the shaft had bent itself not sure how that happened or could have happend, but he said he would fix it and about an 1 and a half hours later he said it was all finished!

rebuilt the internals with some other new parts from a different turbo he had lyin around, only thing that made me nervous was it had a little bit of shaft play and if it technically could touch the side with the compressor blade, probably should have taken it back to him at that point, but I didn't notice till I got home and was putting it back in.

Well put it back in and it feels good, just need to recheck the tune, seems like I'm guzzling gas at this point for some reason, and even on the same map where I was hitting 20 psi I'm only at 15-17 or so somewhere in there. Heading back to Jason's tomorrow so we'll see how it does, if it doesn't perform then that means the turbo will be coming back out.......again

The other good news is the guy said if he can't fix it he will just buy me a new turbo! we will see how it goes tomorrow!
Mush04 is offline   Reply With Quote
Old 03-28-2012, 07:12 PM   #20
Mush04
Scooby Specialist
 
Member#: 191705
Join Date: Oct 2008
Chapter/Region: RMIC
Location: Nowhere of importance
Vehicle:
2007 Limited STi
Swp

Default

Ok so I was out messin around in the garage for a bit today and got a couple things done, need to do a couple more but I'll post what I got done today anyway.

I finally painted the silver mesh that the CF hoods come with to black. they are a pain in the ass haha



I also repainted my alternator cover, same color and I should've taken the extra time and sanded it all the way down first but I figured it'll start peeling before any of the summer meets come up, this time I added the clear to it.


I installed my wideband a few months ago now but never took any pictures, in fact I don't think I ever took any of my other gauges, but here they are. I have a 2 pod A pilar and a single MB pod.


Any for the O2 sensor I told Greg (rallyon I believe his screen name it) that I would take a picture of the weld job he did for me. Unfortunately I haven't been able to get back under the car for a better picture but you can more or less see it in this one. The welds were perfect!! Thanks again man!


The last thing I need to do at this point is make my wire for my WB so I can logg it along with the UTEC. I think I have everything I just don't have time to put it all together since I'll have to get back under the dash and crap haha

On top of everything else my radiator has started to leak in the top corner (typical from what I've read and seen) so now I'll have to get another. Car is running strong, although I do have some white smoke for the first couple mins or so after start up, but it's random not every time.

Last edited by Mush04; 03-28-2012 at 07:18 PM.
Mush04 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Another Help Me Choose A Car Thread (Classic Muscle Car Edition) teamjordan23 Off-Topic 68 04-10-2011 07:46 AM
OH wise OT- Outback w/CVT & 3 car seats, pick my car thread 600million hedwagon Off-Topic 6 08-08-2010 11:59 PM
another friggin car thread... what car do you like but cant own cause iz a nightmare? shipjumper Off-Topic 49 09-04-2007 08:56 PM
There is an emblems thread, how about a pink STi logo on your car thread? JDM addict Member's Car Gallery 29 04-20-2006 06:44 PM
Random Hot Car thread...cars that make you go "ohhhhh" Remy E. LeBeau Off-Topic 13 09-30-2003 05:04 PM


All times are GMT -4. The time now is 12:46 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.