Welcome to the North American Subaru Impreza Owners Club Monday September 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Subaru Conversions

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-06-2011, 12:46 PM   #1
Subachouli
Scooby Specialist
 
Member#: 98777
Join Date: Oct 2005
Chapter/Region: NESIC
Location: MA
Vehicle:
A yard full
of Subarus

Default 98 Legacy EJ205 - engine tilted back?

I'm in the process of swapping the EJ205 into my 98 Legacy. I'm using the first generation Legacy turbo crossmember, and the stock WRX engine mounts.

I've dropped the engine in, and it appears that the engine is tilted back. The dogbone transmission mount is about an inch off. I can get the hood closed, but the engine position looks very awkward and the top of the intake manifold is very close to making contact with the underhood shield.

Any thoughts?
* Registered users of the site do not see these ads.
Subachouli is offline   Reply With Quote
Old 11-06-2011, 08:46 PM   #2
speedyHAM
Scooby Specialist
 
Member#: 48377
Join Date: Nov 2003
Chapter/Region: MWSOC
Location: "They eat fish soaked in lye"
Vehicle:
1996 Gutted, built
XP class Impreza L

Default

Are you sure you have the engine bolted into the mounts correctly and the mounts fully engaged in the crossmember?

Are all the tranny bolts on tight?
speedyHAM is offline   Reply With Quote
Old 11-09-2011, 03:13 PM   #3
AREA1320
Former Vendor
 
Member#: 112508
Join Date: Apr 2006
Location: Easton, PA
Default

ummmmm put the engine mount studs into the slots on the crossmember.. or are you sure you have the mounts on correctly?
AREA1320 is offline   Reply With Quote
Old 11-09-2011, 03:19 PM   #4
Subachouli
Scooby Specialist
 
Member#: 98777
Join Date: Oct 2005
Chapter/Region: NESIC
Location: MA
Vehicle:
A yard full
of Subarus

Default

Thanks guys. Had a brainfart. The lower transmission bolts were not fully tightened. Once they snugged up, the engine sat a little more level. I was expecting the engine to sit low in the bay like it does in my WRX, but everything fits and looks fine now.
Subachouli is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
98 legacy outback - engine options Box This Subaru Conversions 11 08-30-2011 12:39 AM
FS : 98 Legacy 2.2L Engine SubaruJawn Engine/Power/Exhaust 8 09-22-2010 06:43 AM
98 legacy l - radio install tothaneck Legacy Forum 3 10-12-2007 05:52 PM
Should a 98 Legacy have an engine undertray? Snowphun Legacy Forum 3 03-21-2004 06:21 PM
('93-'01) Is a 98 legacy 2.5 engine same as a 99 RS Jimmy Impreza Forum 4 05-21-2001 11:10 AM


All times are GMT -4. The time now is 07:07 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.