Welcome to the North American Subaru Impreza Owners Club Saturday July 12, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Rocky Mountains Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Rocky Mountains Impreza Club Forum -- RMIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-10-2011, 12:52 AM   #1
TiM801
Scooby Specialist
 
Member#: 289115
Join Date: Jul 2011
Chapter/Region: RMIC
Location: SLC
Vehicle:
2002 WRX
WRB

Default front defrost issue

hey anyone pretty knowledgeable with the heat / AC system just noticed my front defrost doesn't work, need it fixed for winter ! doesn't blow any air at all...
* Registered users of the site do not see these ads.
TiM801 is offline   Reply With Quote
Old 11-10-2011, 11:32 AM   #2
phattydrummer
Scooby Newbie
 
Member#: 183070
Join Date: Jun 2008
Chapter/Region: RMIC
Location: TrueTune
Vehicle:
2003 WRX
True Blue

Default

There are flaps that control air flow for all the vent settings. for your WRX, they are all manually controlled with the selector knobs. It could be that you lost a cable mount or something. Hondas have this problem, but I haven't sen any newer Suabrus with this issue.

Take the cover off of the stereo/hvac controls and pull your stereo our. There are cables that run from the hvac controls to the flaps I was talking about. Check to make sure with each vent setting that the cables/rods are moving.

Or, just turn the A/C on and that will defrost your windshield. Eventually.
phattydrummer is offline   Reply With Quote
Old 11-10-2011, 01:11 PM   #3
TiM801
Scooby Specialist
 
Member#: 289115
Join Date: Jul 2011
Chapter/Region: RMIC
Location: SLC
Vehicle:
2002 WRX
WRB

Default

alright cool thx bro!
TiM801 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Remote Starter and Defrost issue Blamecanada999 Electrical & Lighting 3 01-23-2011 08:23 PM
Rear Wiper not working and Rear Defrost issue taylorjonesphoto Electrical & Lighting 4 07-30-2010 06:54 PM
Minimal airflow out of front defrost vent fugglybubbler General Community 6 12-29-2009 06:55 AM
front defroster thingy removal... Onederer Southern California Impreza Club Forum -- SCIC 8 05-23-2003 03:56 PM
removal of front defroster vent Onederer Interior & Exterior Modification 2 05-23-2003 02:22 PM


All times are GMT -4. The time now is 05:03 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.