Welcome to the North American Subaru Impreza Owners Club Tuesday September 2, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-11-2011, 09:55 PM   #1
aTriz
Scooby Newbie
 
Member#: 95202
Join Date: Sep 2005
Chapter/Region: South East
Location: South FL
Vehicle:
2011 WRX
PhatBotti e85 Tuned

Default 2011 WRX Fuel Pump Problem? HELP PLEASE

I was driving down the road today driving very soft, shifted to 2nd gear and all of a sudden my car died and my traction control light came on first then all of my other lights came on for a second (CEL, TPMS, battery etc) I then coasted to a stop and had my car towed to my house. When I try to start the car I don't hear my walbro 255 fuel pump priming, all my electrical seems ok. The only thing I'm worried about is my OBD2 won't read my accessport or my ecu scanner. I replaced the Fuel pump fuse the first time and it acutally started up for a second and then turned off. I tried to replace it again and I can't get it to turn on again or prime. I checked the fuses and they all have power.

Where is our fuel relay? Think it is a dead fuel pump? How can I check if the pump is getting power or not? Anything will help!

Mods- 1000cc injectors, walbro 255 fp, invidia downpipe, IPR tmic, forge bpv. accessport
* Registered users of the site do not see these ads.
aTriz is offline   Reply With Quote
Old 11-11-2011, 10:10 PM   #2
xluben
Scooby Guru
 
Member#: 261612
Join Date: Oct 2010
Location: Minneapolis, MN
Vehicle:
2012 Forester 2.5X
2002 WRX Sedan

Default

Use a multimeter to check the fuel pump connector for voltage.
xluben is offline   Reply With Quote
Old 11-11-2011, 10:11 PM   #3
aTriz
Scooby Newbie
 
Member#: 95202
Join Date: Sep 2005
Chapter/Region: South East
Location: South FL
Vehicle:
2011 WRX
PhatBotti e85 Tuned

Default

what leads do i check? which color for the FP?
aTriz is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2011 WRX fuel pick up problem? dcb504 Motorsports 5 03-28-2011 08:59 PM
Fuel pump problems? Help please! big_dog Factory 2.0L Turbo Powertrain 4 08-09-2008 07:20 PM
fuel pump problem or relay? please help tanyasauction Newbies & FAQs 4 08-04-2007 10:05 PM
Need WRX fuel pump controller help bryan_johnson Subaru Conversions 15 06-13-2005 11:06 AM
PLS help with a fuel pump problem (long) Sparks Factory 2.0L Turbo Powertrain 16 11-02-2003 06:02 PM


All times are GMT -4. The time now is 01:28 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.