Welcome to the North American Subaru Impreza Owners Club Friday October 28, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Thread Tools Display Modes
Old 11-13-2011, 10:53 PM   #1
Scooby Specialist
Member#: 253560
Join Date: Jul 2010
Chapter/Region: South East
Location: Redneck Riviera, SC
'83 Subaru GL Wagon

Angry Windshield Wiper wont work

So after this past snow storm my passenger side windshield wiper stopped working :/

It will twitch like it wants go go but won't, and you can pick it up and move it freely, there isn't any resistance like with the working one. Any idea what the problem could be?
* Registered users of the site do not see these ads.
HoboBob is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 11-13-2011, 10:58 PM   #2
Scooby Guru
Member#: 1847
Join Date: Jul 2000
Chapter/Region: Tri-State
Location: brokenmotorsports.com
Team Broken: V6 GF


tighten the wiper arm nut that came loose
munkis is offline   Reply With Quote
Old 08-09-2012, 09:15 PM   #3
Guy Hollywood
Scooby Newbie
Member#: 307227
Join Date: Jan 2012
Chapter/Region: NESIC
Location: Massachusetts
2013 STi 4d


Ohhh how I love forums. Was having this exact problem. My passenger side seemed to be hitting the cowl and making a loud noise, then it just stopped working all together. The blade got a little bent, so I bent it pack and tightened the nut on the arm, and I was good to go. Probably will replace the blades, but my problem is fixed. Thanks munkis.
Guy Hollywood is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Windshield wiper spray not working DJS1 Service & Maintenance 6 12-24-2009 07:15 PM
rear windshield wiper WONT STOP!?! GullyWagon07 Service & Maintenance 0 11-25-2008 07:25 PM
Turn Signal, Windshield Wipers won't work - Advice Please t3hWIT Interior & Exterior Modification 4 03-16-2006 01:05 PM
1994 legacy wiper wont work chexmix78 Service & Maintenance 5 01-10-2005 02:52 PM
My windshield wipers just don't work over 85 Sordid Philosopher General Community 18 11-20-2002 09:45 PM

All times are GMT -4. The time now is 08:44 AM.

Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.