Welcome to the North American Subaru Impreza Owners Club Thursday April 17, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Subaru Conversions

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-14-2011, 03:44 AM   #1
jareds
Scooby Newbie
 
Member#: 249729
Join Date: Jun 2010
Vehicle:
2005 ADM WRX
Black

Default '05 WRX (ADM) with GT3071R under performing...

Hi all.

My motor is still stock (EJ20), but I have just finished off with a Rotate Mount GT3071R and EWG install (Also gone Speed Density tune).

I went this route after not having much joy with a chinese 20G that I was running.

I didnt get nice results from the 20G and, at the time, I was under the impression that it was because of the poor copy/design of the turbo.

Now, since fitting the GT3071R, I am getting the same results - THE CAR SIMPLY UNDER-PERFORMS! I get 1bar at 4000rpm, but from around 3500rpm - 5500rpm the car feels really really FLAT! Like there is no torque. But from 5500rpm - redline, it pulls nicely!

My tuner has done 250+ vehicles from OEM cars to big high-powered Subarus, and he has not felt one under perform like mine.

Normally, one fits a BIG turbo, and the car HAULS! Not in my case.

So, assuming that there are no boost leaks, and that the tune is 100%, is there any other reason why a stock wrx wont perform with a big turbo?

I hope someone can assist to get this car running like it should!
Thanks,
Jared
* Registered users of the site do not see these ads.

Last edited by jareds; 11-15-2011 at 02:18 AM.
jareds is offline   Reply With Quote
Old 11-14-2011, 09:52 PM   #2
speedyHAM
Scooby Specialist
 
Member#: 48377
Join Date: Nov 2003
Chapter/Region: MWSOC
Location: "They eat fish soaked in lye"
Vehicle:
1996 Gutted, built
XP class Impreza L

Default

Have you checked the condition of your engine and heads?

Compression and leakdown tests are where I would start.

What boost are you tuning to? Wrong forum too, this should be in the 2.0L section.
speedyHAM is offline   Reply With Quote
Old 11-15-2011, 02:20 AM   #3
jareds
Scooby Newbie
 
Member#: 249729
Join Date: Jun 2010
Vehicle:
2005 ADM WRX
Black

Default

@ Speedyham:

I am going to be performing a leak down test through the course of this week.
I am hoping that that doesnt have a negative outcome.

Well I want to run 1bar (14.7psi) daily, but then looking at around 1.4bar for track / dyno days etc.


(How do I move the thread?)

Last edited by jareds; 11-15-2011 at 03:00 AM.
jareds is offline   Reply With Quote
Old 11-17-2011, 12:52 AM   #4
jareds
Scooby Newbie
 
Member#: 249729
Join Date: Jun 2010
Vehicle:
2005 ADM WRX
Black

Default

Ok, so I did a compression test the other night and the results were as follows:
Cyl1: 8.2bar
Cyl2: 9.2bar
Cyl3: 8.3bar
Cyl4: 8.3bar

Bearing in mind that the compression of these motors is only 8.5:1, can we say that my motor is still healthy?

Is it possible that my cambelt timing is out by 1 tooth somewhere causing horrible performance?

Thanks,
Jared
jareds is offline   Reply With Quote
Old 11-17-2011, 11:22 PM   #5
speedyHAM
Scooby Specialist
 
Member#: 48377
Join Date: Nov 2003
Chapter/Region: MWSOC
Location: "They eat fish soaked in lye"
Vehicle:
1996 Gutted, built
XP class Impreza L

Default

Looks to me like you have low compression in all cylinders. It should be at least 9.7 bar for each cylinder and should be within .5 bar for all cylinders. Looks like time for a motor rebuild.
speedyHAM is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS : (CA) 2002 wrx wagon with mods. PRICE DROP!!! 6900 OBO Awd.Son Private Vehicle 'For Sale' Classifieds 69 01-29-2012 10:22 PM
FS: NC: '05 WRX wheels with newer tires mwhawn Wheels/Tires 1 04-30-2008 07:57 AM
SoCal - '05 STi carpet, door panels, rear seats swap with '05 WRX NskGenakuDuckie Private 'For Sale' Classifieds 13 07-07-2005 06:32 PM
'05 STi interior for trade with '05 WRX interior NskGenakuDuckie Private 'For Sale' Classifieds 26 02-17-2005 07:03 PM
Any '05 WRX owners want to do an interior swap with my '05 STi? NskGenakuDuckie Private 'For Sale' Classifieds 5 11-23-2004 04:38 PM


All times are GMT -4. The time now is 04:00 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.