Welcome to the North American Subaru Impreza Owners Club Friday August 29, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Pre-2002 Factory Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-25-2011, 07:58 AM   #1
Flavah
Scooby Newbie
 
Member#: 220801
Join Date: Aug 2009
Chapter/Region: International
Location: Japan
Vehicle:
1994 WRX RA
White

Default Turbo going bad?

When I am under the hood, rev the engine and let go, I get a very fast tatatatattatat sound for half a second as the engine starts to wind down. It is not loud enough to hear it when the hood is closed. Is this a sign the turbo is on is last leg? The car is a 94 RA with 130,000km (80,779 miles) on it. It has a KMAX ECU tuned for 1.0bar, APEXi Power Intake filter, APEXi resonator delete (in the intake track), a STi TMIC, and HKS Silent Power exhaust for engine mods.
* Registered users of the site do not see these ads.
Flavah is offline   Reply With Quote
Old 11-25-2011, 01:07 PM   #2
Xenonic
Scooby Newbie
 
Member#: 263681
Join Date: Nov 2010
Chapter/Region: VIC
Location: Langley, B.C.
Vehicle:
1995 STI RA
Feather white

Default

Might not want to drive it anymore until you find out what that is. I had that same sound as you, turned out it was a spun bearing.
Xenonic is offline   Reply With Quote
Old 11-25-2011, 06:36 PM   #3
Flavah
Scooby Newbie
 
Member#: 220801
Join Date: Aug 2009
Chapter/Region: International
Location: Japan
Vehicle:
1994 WRX RA
White

Default

The sound is coming from the turbo area which is why I did not even consider a bearing. If this is the case, I am done with Subaru's!
Flavah is offline   Reply With Quote
Old 11-26-2011, 10:38 PM   #4
dangerousatom
Scooby Specialist
 
Member#: 70710
Join Date: Sep 2004
Chapter/Region: Tri-State
Location: Quakertown/AREA1320 391whp
Vehicle:
2002 04STi Swaped RS
w/PPGS & 02 Wagon w/PPGs

Default

Get a long screwdriver or something long that you can put on the turbo and different parts of the motor/head. While touching the motor with "long thing" put the other end to your ear and listen. Move to a few different spots and try and isolate where the sound is coming from........then get back to us.
dangerousatom is offline   Reply With Quote
Old 11-26-2011, 10:49 PM   #5
Xenonic
Scooby Newbie
 
Member#: 263681
Join Date: Nov 2010
Chapter/Region: VIC
Location: Langley, B.C.
Vehicle:
1995 STI RA
Feather white

Default

To do a quick check if you have a bearing failure you can do an oil change and cut open you old oil filter and hope you dont see metal sparkles in the filter. It's a good check to do to take a load off your mind that your motor will not need some serious repairs. Here's a picture of what my oil pan looked like after a really badly spun rod bearing.
Xenonic is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
turbo going bad?? shootsbrah Factory 2.0L Turbo Powertrain 5 03-28-2008 09:17 PM
Boost Leak or Turbo Going Bad? Help! Drav Factory 2.0L Turbo Powertrain 0 05-30-2007 09:09 PM
Turbo going bad? wrxugly Factory 2.0L Turbo Powertrain 2 12-28-2006 11:57 PM
Turbo going bad? mcu81 Factory 2.0L Turbo Powertrain 1 11-02-2004 03:41 PM
Stock Turbo Going Bad? Lowball Factory 2.0L Turbo Powertrain 15 11-16-2003 01:32 PM


All times are GMT -4. The time now is 02:02 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.