Welcome to the North American Subaru Impreza Owners Club Friday April 18, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Pre-2002 Factory Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-28-2011, 11:03 AM   #1
gtu89rx7
Scooby Newbie
 
Member#: 108029
Join Date: Feb 2006
Chapter/Region: South East
Location: Charleston, SC
Vehicle:
95 Impreza Outback
EJ20G swapped

Default weird metallic rattle noise from engine under load

1995 impreza with EJ20G swap.. so ive been getting this weird noise under load.. starts happening just before getting into boost. it sounds like a metallic rattling/flapping sound, kind of like an exhaust leak would sound. at first i thought it was just that, so i changed out all the exhast gaskets. I thought maybe the uppipe was cracked, cause it seemed to move a little. so i sent off the manifold to grimmspeed to pnp and ordered their uppipe as well. so even after all that the noise is still there. I checked the intake piping, and its all good, no cracks or leaks. its got me stumped
* Registered users of the site do not see these ads.
gtu89rx7 is offline   Reply With Quote
Old 11-28-2011, 01:42 PM   #2
wrxstijdm
Scooby Newbie
 
Member#: 254590
Join Date: Aug 2010
Location: Costa Rica
Vehicle:
1998 V4 Impreza STI
EJ20K engine

Default

Engine knock?
wrxstijdm is offline   Reply With Quote
Old 11-28-2011, 02:40 PM   #3
EdHilario
Scooby Specialist
 
Member#: 137398
Join Date: Jan 2007
Chapter/Region: E. Canada
Location: Toronto
Vehicle:
2004 Impreza 2.5RS
Platinum Silver Metallic

Default

Heat shield?
EdHilario is offline   Reply With Quote
Old 11-28-2011, 08:49 PM   #4
gtu89rx7
Scooby Newbie
 
Member#: 108029
Join Date: Feb 2006
Chapter/Region: South East
Location: Charleston, SC
Vehicle:
95 Impreza Outback
EJ20G swapped

Default

i removed all the heat shields when i replaced the gaskets. every exhaust gasket has been replaced with new. im running a full 3" exhaust, nothing that can rattle that i know of?
gtu89rx7 is offline   Reply With Quote
Old 11-30-2011, 04:49 PM   #5
TommyAtomic
Scooby Newbie
 
Member#: 257043
Join Date: Sep 2010
Chapter/Region: VIC
Location: Vancouver BC
Vehicle:
1993 JDM WRX Wagon
Black

Default

Quote:
Originally Posted by gtu89rx7 View Post
i removed all the heat shields when i replaced the gaskets. every exhaust gasket has been replaced with new. im running a full 3" exhaust, nothing that can rattle that i know of?
Except things rattling from the vibration from the exhaust. Also there sometimes a rattle if your not using all of your exhaust hangers.

There is rattle from things not entirely bolted down during the engine swap such as the metal tube running along the firewall on some early ej20g's used to supply vacuum to the brake booster.

Check for loose anything. Rattle means somethings loose. comming into contact allowed to vibrate.
TommyAtomic is offline   Reply With Quote
Old 12-01-2011, 08:19 AM   #6
njtank
Scooby Specialist
 
Member#: 271657
Join Date: Jan 2011
Chapter/Region: Tri-State
Location: Dirty Jersey
Vehicle:
2007 WRX Limited
SGM

Default

I have the same issue only mines an 05 WRX so no swaps. Has me going crazy.
njtank is offline   Reply With Quote
Old 12-01-2011, 06:19 PM   #7
gtu89rx7
Scooby Newbie
 
Member#: 108029
Join Date: Feb 2006
Chapter/Region: South East
Location: Charleston, SC
Vehicle:
95 Impreza Outback
EJ20G swapped

Default

what have you tried so far? i think it may be a blown intake to engine gasket.. going to change that next and look for anything else while its apart. also getting a code 42 idle switch, so maybe it is a vacuum/boost leak

Last edited by gtu89rx7; 12-01-2011 at 06:27 PM.
gtu89rx7 is offline   Reply With Quote
Old 12-01-2011, 09:07 PM   #8
njtank
Scooby Specialist
 
Member#: 271657
Join Date: Jan 2011
Chapter/Region: Tri-State
Location: Dirty Jersey
Vehicle:
2007 WRX Limited
SGM

Default

I'm pretty sure mine is a bad gasket between the downpipe and catback.
njtank is offline   Reply With Quote
Old 12-05-2011, 02:19 AM   #9
njtank
Scooby Specialist
 
Member#: 271657
Join Date: Jan 2011
Chapter/Region: Tri-State
Location: Dirty Jersey
Vehicle:
2007 WRX Limited
SGM

Default

Have you lost any boost or have you had to much vacuum through this whole rattle crap ?
njtank is offline   Reply With Quote
Old 12-05-2011, 09:14 AM   #10
gtu89rx7
Scooby Newbie
 
Member#: 108029
Join Date: Feb 2006
Chapter/Region: South East
Location: Charleston, SC
Vehicle:
95 Impreza Outback
EJ20G swapped

Default

its about -20 in at idle, and boosts up to about 13 psi no problems. i have not changed the intake manifold gasket yet
gtu89rx7 is offline   Reply With Quote
Old 12-05-2011, 09:55 AM   #11
njtank
Scooby Specialist
 
Member#: 271657
Join Date: Jan 2011
Chapter/Region: Tri-State
Location: Dirty Jersey
Vehicle:
2007 WRX Limited
SGM

Default

Haven't even thought of that. I'm gonna have a leak test done later this week ill keep you informed.
njtank is offline   Reply With Quote
Old 12-05-2011, 03:31 PM   #12
elislider
Scooby Specialist
 
Member#: 133923
Join Date: Dec 2006
Chapter/Region: NWIC
Location: Portland, OR
Vehicle:
03 Legacy GT wagon
I love goooollllllllddddd

Default

you can test for leaks by letting the car idle and squirting bits of carb/brake cleaner around in the engine bay at hoses and gaskets and mating points, and if the car changes idle or stumbles at all, you know you have a leak there
elislider is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
rattling noise from engine RR Normally Aspirated Powertrain 12 01-12-2010 02:16 AM
Strange metalic rattle sound from engine ronan1975 Factory 2.5L Turbo Powertrain 8 07-28-2008 11:33 PM
rattling noise from engine bay 06subieWRX Factory 2.5L Turbo Powertrain 10 08-29-2007 06:37 PM
help. rattleing noise from engine bay. sammyswrxsti Factory 2.0L Turbo Powertrain 2 07-20-2007 11:18 PM
clicking rattling noise from engine VideoGameWrx Factory 2.0L Turbo Powertrain 6 12-06-2006 12:27 PM


All times are GMT -4. The time now is 03:30 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.