Welcome to the North American Subaru Impreza Owners Club Tuesday September 30, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Subaru Conversions

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-08-2011, 05:01 PM   #1
extremeSTI
Scooby Newbie
 
Member#: 301521
Join Date: Nov 2011
Chapter/Region: Tri-State
Location: Garden state
Vehicle:
2003 2003
black

Default 03 bug eye with 05 sti swap

Im doing my swap and about 80% done so I turned on the ignition switch and the rear lights stay on could that be because the computer isnt plugged up or is there something wrong? my computer wont be in till tomorrow but it just got me curious.
* Registered users of the site do not see these ads.
extremeSTI is offline   Reply With Quote
Old 12-08-2011, 05:08 PM   #2
02 Scoob-TN
Scooby Newbie
 
Member#: 176010
Join Date: Mar 2008
Chapter/Region: South East
Location: Nash, TN
Vehicle:
2005 WRX sdn ver8'ed
Phat-Tuned RIP Bugeye

Lightbulb Stop!!

The last thing you want to do is power your electrical system up without having all connections made,checked and verify all grounds are good. you need to have patience or you'll toast something before you know what you've done and have to track down a problem that you could of avoided.

On every swap Ive done, the last step was powering up and checking for fuel pump activity and pressure. Without the ECU in your just wasting time and possibly causing a big problem. Get it 100%, check it all over again, then turn the key.
02 Scoob-TN is offline   Reply With Quote
Old 12-08-2011, 10:40 PM   #3
extremeSTI
Scooby Newbie
 
Member#: 301521
Join Date: Nov 2011
Chapter/Region: Tri-State
Location: Garden state
Vehicle:
2003 2003
black

Default

I feel you, just can't wait but the ecu should be in tomorrow and everything should be complete.
extremeSTI is offline   Reply With Quote
Old 12-08-2011, 11:13 PM   #4
dangerousatom
Scooby Specialist
 
Member#: 70710
Join Date: Sep 2004
Chapter/Region: Tri-State
Location: Quakertown/AREA1320 391whp
Vehicle:
2002 04STi Swaped RS
w/PPGS & 02 Wagon w/PPGs

Default

Is your dash all together?
Are your headlights turned on 1/2way?
Column control not plugged in?
dangerousatom is offline   Reply With Quote
Old 12-10-2011, 09:20 PM   #5
extremeSTI
Scooby Newbie
 
Member#: 301521
Join Date: Nov 2011
Chapter/Region: Tri-State
Location: Garden state
Vehicle:
2003 2003
black

Default

Quote:
Originally Posted by dangerousatom View Post
Is your dash all together?
Are your headlights turned on 1/2way?
Column control not plugged in?
dash is all together computer plugged up and shes cranking but no start, I noticed where the fuse panel is theres an plug that looks like some kind of modual or box goes there but wont know till my friend comes thru with his STI


extremeSTI is offline   Reply With Quote
Old 12-10-2011, 10:52 PM   #6
extremeSTI
Scooby Newbie
 
Member#: 301521
Join Date: Nov 2011
Chapter/Region: Tri-State
Location: Garden state
Vehicle:
2003 2003
black

Default

I figured out what it is, its the keyless entry modual plug, but i still can't figure out why the rear tail lights stay on and now the windshield wipers just come on by their self. anyone have these problems with an swap?
extremeSTI is offline   Reply With Quote
Old 12-11-2011, 03:44 PM   #7
extremeSTI
Scooby Newbie
 
Member#: 301521
Join Date: Nov 2011
Chapter/Region: Tri-State
Location: Garden state
Vehicle:
2003 2003
black

Default

ok I figured out the no start problem, to much time on this car and needed to clear my head so I waited till today and went back in and noticed one of the ECU plugs was'nt all the way in so now the next issue is that she will start but quickly die out and the check engine light is flashing also if you leave the ignition switch on you hear a relay clicking and the fuel pump is cycling off and on, Im thinking it could be I may have crossed the fuel lines? and is that possible?
extremeSTI is offline   Reply With Quote
Old 12-11-2011, 03:52 PM   #8
Kris.is.awesome
Scooby Newbie
 
Member#: 256840
Join Date: Sep 2010
Chapter/Region: MAIC
Location: Virginia Beach, VA
Vehicle:
2000 BMW ///Mcoupe
Silverrrrrrr

Default

Quote:
Originally Posted by extremeSTI View Post
ok I figured out the no start problem, to much time on this car and needed to clear my head so I waited till today and went back in and noticed one of the ECU plugs was'nt all the way in so now the next issue is that she will start but quickly die out and the check engine light is flashing also if you leave the ignition switch on you hear a relay clicking and the fuel pump is cycling off and on, Im thinking it could be I may have crossed the fuel lines? and is that possible?
Period. Find out where it is.

Sounds like the car is in test mode.

Un-plug the green connectors.
What ecu is in the car?

Also for your tails- the switch on top of the steering column.
Kris.is.awesome is offline   Reply With Quote
Old 12-11-2011, 04:27 PM   #9
extremeSTI
Scooby Newbie
 
Member#: 301521
Join Date: Nov 2011
Chapter/Region: Tri-State
Location: Garden state
Vehicle:
2003 2003
black

Default

Quote:
Originally Posted by Kris.is.awesome View Post
Period. Find out where it is.

Sounds like the car is in test mode.

Un-plug the green connectors.
What ecu is in the car?

Also for your tails- the switch on top of the steering column.
feel real stupid about the tail lights
and the ecu thats in the car is the one that came with the car and its a B9 if that helps also what green connectors are you refering to
extremeSTI is offline   Reply With Quote
Old 12-11-2011, 06:38 PM   #10
extremeSTI
Scooby Newbie
 
Member#: 301521
Join Date: Nov 2011
Chapter/Region: Tri-State
Location: Garden state
Vehicle:
2003 2003
black

Default

how do you tell which one is the supply and return fuel lines from the car side and the engine side. and why are there 3 lines for the fuel system? I know the bottom from the car side is the supply line but I lost on which is the return of the other 2

extremeSTI is offline   Reply With Quote
Old 12-11-2011, 07:07 PM   #11
extremeSTI
Scooby Newbie
 
Member#: 301521
Join Date: Nov 2011
Chapter/Region: Tri-State
Location: Garden state
Vehicle:
2003 2003
black

Default

Any Help
extremeSTI is offline   Reply With Quote
Old 12-11-2011, 07:29 PM   #12
Kris.is.awesome
Scooby Newbie
 
Member#: 256840
Join Date: Sep 2010
Chapter/Region: MAIC
Location: Virginia Beach, VA
Vehicle:
2000 BMW ///Mcoupe
Silverrrrrrr

Default

Quote:
Originally Posted by extremeSTI View Post
feel real stupid about the tail lights
and the ecu thats in the car is the one that came with the car and its a B9 if that helps also what green connectors are you refering to
Haha, was the switch on the column keeping the lights on?

Under the dash there are two green plugs, you only connect them to put the car in test mode.

You will need an sti ecu at some point.
Kris.is.awesome is offline   Reply With Quote
Old 12-11-2011, 07:47 PM   #13
extremeSTI
Scooby Newbie
 
Member#: 301521
Join Date: Nov 2011
Chapter/Region: Tri-State
Location: Garden state
Vehicle:
2003 2003
black

Default

I do have an STI ecu, at least i think I do
extremeSTI is offline   Reply With Quote
Old 12-11-2011, 07:55 PM   #14
extremeSTI
Scooby Newbie
 
Member#: 301521
Join Date: Nov 2011
Chapter/Region: Tri-State
Location: Garden state
Vehicle:
2003 2003
black

Default

Quote:
Originally Posted by Kris.is.awesome View Post
Haha, was the switch on the column keeping the lights on?

Under the dash there are two green plugs, you only connect them to put the car in test mode.

You will need an sti ecu at some point.
I dont know where your at but if I ever see you I owe you big time, its running
extremeSTI is offline   Reply With Quote
Old 12-11-2011, 10:15 PM   #15
dangerousatom
Scooby Specialist
 
Member#: 70710
Join Date: Sep 2004
Chapter/Region: Tri-State
Location: Quakertown/AREA1320 391whp
Vehicle:
2002 04STi Swaped RS
w/PPGS & 02 Wagon w/PPGs

Default

Is your Fuel filter in tank???

The green plugs are under the dash near the clutch peddle

The wipers...you will most likely have to repin the plug going into the wiper motor. In my swap 02 rs with04 STi the STi ECU tells the stock RS and I believe WRX to run high and only high only due to 2 wires being indifferent positions.......its fairly obvious when looking at the wiring diagrams STi vs WRX.

Flashing ECU is engine problems happening actively AKA right then and there. This could be the ECU or something sensor to ECU not being normal for the ECU your currently running.

Fuel lines are:
TOP = RETURN
MIDDLE = VAC
BOTTOM = FEED
dangerousatom is offline   Reply With Quote
Old 12-12-2011, 01:26 PM   #16
Kris.is.awesome
Scooby Newbie
 
Member#: 256840
Join Date: Sep 2010
Chapter/Region: MAIC
Location: Virginia Beach, VA
Vehicle:
2000 BMW ///Mcoupe
Silverrrrrrr

Default

Quote:
Originally Posted by extremeSTI View Post
I dont know where your at but if I ever see you I owe you big time, its running


Glad I could help!
Kris.is.awesome is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS/FT : CA: Socal, 03 wrx to complete 05 sti swap project b3nj4m1n SCIC Private Classifieds 18 11-27-2010 09:24 PM
FS/FT : CA: Socal, 03 wrx to complete 05 sti swap project b3nj4m1n Private Vehicle 'For Sale' Classifieds 11 11-15-2010 03:25 AM
02 bug eye with 2.5l hybrid swap quarter mile flon3y Proven Power Bragging 11 01-03-2007 05:13 PM
bug eye with 04 sti wheels. anyone???? TurboInside Interior & Exterior Modification 9 05-11-2006 12:09 AM
what to do with DBW with 05 sti swap into 02 wrx? bustaman Subaru Conversions 7 11-16-2005 02:11 AM


All times are GMT -4. The time now is 11:41 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.