Welcome to the North American Subaru Impreza Owners Club Saturday April 19, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-10-2011, 12:44 PM   #1
ShaneInHisRoom
Scooby Specialist
 
Member#: 148737
Join Date: May 2007
Chapter/Region: TXIC
Location: Dallas TX
Default 04 Rotated STi idle fluttering/stalls

Was driving back today with the climate control on, pushed in the clutch to a red light around 25mph, and I stalled. Twice. Turned climate control off, and I didn't stall (only stopped twice though). Idle flutters when moving from 700-1100rpm, but settles down after a few seconds when I'm at a stop. Is this normal? Is it a dirty MAF or do all cars exhibit this?

My corolla actually does this when I press in the clutch, idle jumps a little bit when car is still moving.
* Registered users of the site do not see these ads.
ShaneInHisRoom is offline   Reply With Quote
Old 12-11-2011, 10:58 AM   #2
ShaneInHisRoom
Scooby Specialist
 
Member#: 148737
Join Date: May 2007
Chapter/Region: TXIC
Location: Dallas TX
Default

Guess no one here has a clue. I have stumped NASIOC.
ShaneInHisRoom is offline   Reply With Quote
Old 12-11-2011, 11:46 AM   #3
alottaboost
Scooby Specialist
 
Member#: 158029
Join Date: Aug 2007
Chapter/Region: MAIC
Location: Shippensburg, PA
Vehicle:
2005 STi
OBP

Default

Using large side feeds? Sometimes they're difficult to tune. How long since they were cleaned?
alottaboost is offline   Reply With Quote
Old 12-11-2011, 12:14 PM   #4
ShaneInHisRoom
Scooby Specialist
 
Member#: 148737
Join Date: May 2007
Chapter/Region: TXIC
Location: Dallas TX
Default

850 DW. The setup is less than 8000 miles old. Shouldn't have to be cleaned for a while....tuned at EFI Logics, very well tuned according to the log.
ShaneInHisRoom is offline   Reply With Quote
Old 12-11-2011, 01:49 PM   #5
STIBungy
Scooby Specialist
 
Member#: 51684
Join Date: Jan 2004
Location: CO
Default

What's your af correction at idle?
STIBungy is online now   Reply With Quote
Old 12-11-2011, 02:34 PM   #6
ShaneInHisRoom
Scooby Specialist
 
Member#: 148737
Join Date: May 2007
Chapter/Region: TXIC
Location: Dallas TX
Default

Not sure, wasn't stated in the log.
ShaneInHisRoom is offline   Reply With Quote
Old 12-11-2011, 03:31 PM   #7
alottaboost
Scooby Specialist
 
Member#: 158029
Join Date: Aug 2007
Chapter/Region: MAIC
Location: Shippensburg, PA
Vehicle:
2005 STi
OBP

Default

You have the ability to pull a screen shot of Learning View?
alottaboost is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help me! V6 STi crazy idle & stalling. MAF problem? cheeksdeniro Factory 2.0L Turbo Powertrain 1 03-29-2011 02:52 PM
A/C off = Idle flutter & crappy starts WRX357 Factory 2.0L Turbo Powertrain 2 07-30-2010 08:38 PM
Stock 05 STi Sutters and stalls at idle SubaruSVXCrazy Factory 2.5L Turbo Powertrain 17 09-28-2009 01:59 AM
Idle Fluttering after installing the Fp Green???? jUstSTi808 Factory 2.5L Turbo Powertrain 6 05-16-2006 06:32 PM
Low Idle, Fluttering Lights....whats my problem?!?! btn_turtle Alaskan Impreza Club Forum -- AKIC 14 11-05-2004 12:22 AM


All times are GMT -4. The time now is 07:38 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.