Welcome to the North American Subaru Impreza Owners Club Saturday July 26, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning > Open Source Reflashes

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-10-2011, 05:50 PM   #1
criscross79
Scooby Specialist
 
Member#: 12263
Join Date: Nov 2001
Chapter/Region: TXIC
Location: San Antonio, Tx
Vehicle:
'02 WRX SRP 4EAT
XPT Stg II

Default Would a boost leak cause knock correction?

I recently changed out my uppipe with an identical uppipe (welds broke) and since then the car has been running a little funny .. I logged it today and I'm getting some knock correction. I haven't messed with the map in about 5 years and nothing else has changed either. I'm not sure how to check for boost leaks though besides listening for them and I don't hear anything

Here is the run

https://docs.google.com/spreadsheet/...hl=en_US#gid=0

Thanks for any help

Chris
* Registered users of the site do not see these ads.
criscross79 is offline   Reply With Quote
Old 12-28-2011, 09:53 PM   #2
criscross79
Scooby Specialist
 
Member#: 12263
Join Date: Nov 2001
Chapter/Region: TXIC
Location: San Antonio, Tx
Vehicle:
'02 WRX SRP 4EAT
XPT Stg II

Default

So, I checked the vacume hoses and lo and behold, I found one that was completely disconnected!! I hooked it back up and took the car out again to do some more logs. Unfortunately the car still has a lot of knock correction. At one point (Run 2) it hit -12 although it happened right after I let off. It looks like the timing is ok right up to about 5100 rpm. After that, it starts dipping down into the negatives. Any new ideas? On a good note, I didn't notice any stuttering on mid-throttle acceleration, so I think fixing the vacume hose helped something :-)

Chris

Run 1 - https://docs.google.com/spreadsheet/...1pIWmJoem1HbEE

Run 2 - https://docs.google.com/spreadsheet/...mxWTGFJVlFERHc

Run 3 - https://docs.google.com/spreadsheet/...nBYRjZEZEVvMlE

Run 4 - https://docs.google.com/spreadsheet/...HBrZkUxSkloc2c

Run 5 - (Long) https://docs.google.com/spreadsheet/...lIwdnFKSzNOUXc
criscross79 is offline   Reply With Quote
Old 12-28-2011, 11:07 PM   #3
Airboy
Scooby Specialist
 
Member#: 72829
Join Date: Oct 2004
Chapter/Region: W. Canada
Location: Calgary, Canada
Vehicle:
2006 WRX
MHI-TF06-18K

Default

Check for leak after MAF and before turbo.
Check/clean MAF.
What are your fuel trims?
Use LearningView to get a snapshot of the learned data.
http://www.romraider.com/forum/viewt...hp?f=32&t=7397

I suspect you are running lean in boost. Do not do full throttle runs anymore until you get it sorted out.
Airboy is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Leak causing knock? dlh1999 Open Source Reflashes 2 11-16-2009 07:20 PM
Can a boost leak cause a knock? Deserted1 Engine Management & Tuning 2 04-18-2009 01:02 PM
would a uppipe leak cause a performace loss tsubaru02 Factory 2.0L Turbo Powertrain 6 04-18-2005 12:41 PM
boost leak causing lag? HubbieScooby Normally Aspirated with bolt-on Forced Induction Powertrain 2 04-15-2004 03:23 PM
can a boost leak cause high egts? WRxednEffect Factory 2.0L Turbo Powertrain 3 03-06-2002 11:22 AM


All times are GMT -4. The time now is 08:12 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.