Welcome to the North American Subaru Impreza Owners Club Tuesday September 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Built Motor Discussion

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-23-2012, 06:44 AM   #126
manitou
Scooby Specialist
 
Member#: 193757
Join Date: Nov 2008
Chapter/Region: MWSOC
Location: Cedar, MI HP Techs MPS-SSLR2.5
Vehicle:
2006 XTI Limited
OBP, Junior tuned 573WHP

Default

Quote:
Originally Posted by kellygnsd View Post
IT'S ALIVE... ALIVE. I did the initial start today and cam re-break-in on the Link. Everything went pretty well and I got it to start and idle somewhat well but since I'm not really a tuner I'll leave the rest to the professionals. I found two coolant leaks that I need to fix but other than that everything was pretty much on point. FSR won't be able to get me in until after the new year so I'm going to set my new target date to have my car on the street to February 1st. It definitely sounds different with the Full-Race equal length headers. Still mean as **** with the cam lope at idle but different and not as mean an unequal length. I'll try and get some video once I get the leaks fixed.

No I haven't relocated my fuse box. Hadn't even considered it actually but if you have I done I'd like to see it. Is it done mostly to clean things up in the engine bay or did you need to make space for something else?

I hacked up my engine harness a little bit wiring in most of my external sensors through it but I haven't completely dissected it.

Post away man, I'd love to see your graphs. I'm interested in all setups.
Congrats Kelly! This is great news! Can't wait to hear her growl and see the power she puts down!!

I do love the sound of my XTI with the Killer B Holy headers and my EWG exhaust! Here are a couple graphs from my tuning session with Junior at PnL! Junior held back on some timing because of balance issues with my current 1100cc injectors. My fueling system is working well with the Walbro 400, hi amp direct wired and Perrin rails. We were at 80% IDC on E85 and my Blouch 3.5XTR. I am rectifying the injector problem now and we will tweak the tune some soon!

Regardless my XTI made very good power even with conservative timing! I plan to put up a thread in PPB I just don't have the time right now with the holidays, work and the new snow that I've been skiing

* Registered users of the site do not see these ads.

Last edited by manitou; 12-23-2012 at 06:50 AM.
manitou is offline   Reply With Quote
Old 12-23-2012, 06:55 AM   #127
manitou
Scooby Specialist
 
Member#: 193757
Join Date: Nov 2008
Chapter/Region: MWSOC
Location: Cedar, MI HP Techs MPS-SSLR2.5
Vehicle:
2006 XTI Limited
OBP, Junior tuned 573WHP

Default

Quote:
Originally Posted by Layvon View Post
Congrats man! That is awesome news. Worth having my phone wake me up to tell me
You're next Layvon! Lets get the kinks out of your beast and bring it to life! What's up on the o2 sensor front?
manitou is offline   Reply With Quote
Old 12-23-2012, 12:01 PM   #128
Layvon
NASIOC Supporter
 
Member#: 195711
Join Date: Nov 2008
Chapter/Region: MWSOC
Location: Cadillac MI
Vehicle:
STi 04/05/06/07
JBP / OBP for now

Default

Quote:
Originally Posted by manitou View Post

You're next Layvon! Lets get the kinks out of your beast and bring it to life! What's up on the o2 sensor front?
Its sitting at home I hope. the snow delayed the shipment from Thursday and I never went home Friday so I'm hoping it is there.

I'm hoping for a merry Christmas and fire it back up.

How much snow did you get up there?? I know my company went up to northport to help turn the lights back on for cherryland
Layvon is offline   Reply With Quote
Old 12-23-2012, 01:00 PM   #129
maxpowr
Scooby Guru
 
Member#: 159243
Join Date: Sep 2007
Chapter/Region: Tri-State
Location: medford nj 08055
Vehicle:
sg3 Turbo Tek Tuned
Hakt Ecu e85 30r 6spd

Default

High five Kelly!
maxpowr is offline   Reply With Quote
Old 12-23-2012, 01:23 PM   #130
kellygnsd
Scooby Guru
 
Member#: 32669
Join Date: Feb 2003
Chapter/Region: SCIC
Location: Rancho C
Vehicle:
2007 2.34LR, EFR7670
LINK G4 hybrid STi

Default

Hey Manitou, what injector issues where you having and with what inectors? I'm running the FIC 1100cc EV14's.

What's your guys opinion on old gas? I started this motor up on year old gas that's been in the tank. I was planning on draining it out but I guess I forgot until now. With only about two gallons in the tank can I get away with just diluting it with good gas or would you pump the old gas out first? The car didn't seen to run to bad on the old gas though.


Quote:
Originally Posted by maxpowr View Post
High five Kelly!
Sup Jake
kellygnsd is online now   Reply With Quote
Old 12-23-2012, 01:41 PM   #131
wrxsubiemod
Scooby Specialist
 
Member#: 165104
Join Date: Nov 2007
Chapter/Region: SCIC
Location: name where you like it
Vehicle:
E85 SoCalPorting
Phatron tuned

Default

Sweet
wrxsubiemod is online now   Reply With Quote
Old 12-23-2012, 02:09 PM   #132
manitou
Scooby Specialist
 
Member#: 193757
Join Date: Nov 2008
Chapter/Region: MWSOC
Location: Cedar, MI HP Techs MPS-SSLR2.5
Vehicle:
2006 XTI Limited
OBP, Junior tuned 573WHP

Default

Quote:
Originally Posted by Layvon View Post
Its sitting at home I hope. the snow delayed the shipment from Thursday and I never went home Friday so I'm hoping it is there.

I'm hoping for a merry Christmas and fire it back up.

How much snow did you get up there?? I know my company went up to northport to help turn the lights back on for cherryland
Good stuff, let's hope that's it! HOHOHO!!

We got about 10", super wet heavy then it dried out overnight. it was heavy and took a bunch of trees and branches down, blocking roads and knocking out power. On the way skiing Saturday we had to clear a path through 3 trees that fell together across a road What'd you guys get?

Have a buddy that's director of skiing at Schuss, so my brewer buddy Bert and I went and made a bunch of high speed tele runs, after all it was free, that's the least we could do

Then we skiied the old Sugar Loaf on our light weight backcountry boards did a bunch of laps!

Get that F'ing car running well enough to put some break in miles on it!!

Merry Christmas!!

Last edited by manitou; 12-23-2012 at 02:19 PM.
manitou is offline   Reply With Quote
Old 12-23-2012, 02:18 PM   #133
manitou
Scooby Specialist
 
Member#: 193757
Join Date: Nov 2008
Chapter/Region: MWSOC
Location: Cedar, MI HP Techs MPS-SSLR2.5
Vehicle:
2006 XTI Limited
OBP, Junior tuned 573WHP

Default

Quote:
Originally Posted by kellygnsd View Post
Hey Manitou, what injector issues where you having and with what inectors? I'm running the FIC 1100cc EV14's.

What's your guys opinion on old gas? I started this motor up on year old gas that's been in the tank. I was planning on draining it out but I guess I forgot until now. With only about two gallons in the tank can I get away with just diluting it with good gas or would you pump the old gas out first? The car didn't seen to run to bad on the old gas though.

Sup Jake
DW 1100's older style but they were new. I've got one that's 12% off at 20 % IDC and it is causing fits at mosty lower rpm's but it's where you cruise and the hesitation stutter stuff 1500-3000 sucks big time on E85. It was not as bad on the PG but still there! DW is making good on them and giving me some new EV14 1000's so that's good but a hassle!!! Junior did not want to push it any harder with the timing as he nor do I trust the injectors. Junior's going to revise the map for the new injectors and I'll have to run a couple logs for him. I think he liked my car!

I don't know on the old gas, I wouldn't with my new motor especially if it's a few gallons. I'd drain it and use it in my chain saw or my generator. Give'r er new stuff

Last edited by manitou; 12-23-2012 at 08:47 PM.
manitou is offline   Reply With Quote
Old 12-23-2012, 02:55 PM   #134
maxpowr
Scooby Guru
 
Member#: 159243
Join Date: Sep 2007
Chapter/Region: Tri-State
Location: medford nj 08055
Vehicle:
sg3 Turbo Tek Tuned
Hakt Ecu e85 30r 6spd

Default

i started 2 new on 3-6 month old gas by topping it off without issue. but i have heard gas begins to lose its potency after 45 days.

not worth the risk but i did it.

all is well in NEW JERSEY. e85 tested at e90 last week. 3.49$ a gallon. car starts up on one turn no problem at 30*. changed my oil again at 3500 miles with pennsoil 5w30 full synthetic, and used a quart of lucas stabilizer. i dont even get piston slap. i am very happy and confident in my d&f machined shortblock and built heads.

the other day on the way to the e85 pump, i layed into her and the car broke all 4 tires loose and was the fuk out. i was like dayum!!! looked up at my afr briefly and saw 12.7.
i was like ut-oh. punched it again just to see what i could hear/feel/see. well pegged the boost gauge, and was funkin out. had to be over 30#...again 12.7 range. got to the pump and checked my boost controller lines. the banjo on my ewg was very loose. dont know how that happens aside from drive train on group n mounts moving around during operation, but tightened it up. back to 22#s no problems.

im just glad it didnt pop! i think e90 may have saved my build. not sure if ray did something to my ROM, to prevent over boosting or not, but the car moved hard without boost control!
maxpowr is offline   Reply With Quote
Old 01-03-2013, 07:39 PM   #135
kellygnsd
Scooby Guru
 
Member#: 32669
Join Date: Feb 2003
Chapter/Region: SCIC
Location: Rancho C
Vehicle:
2007 2.34LR, EFR7670
LINK G4 hybrid STi

Default

Update:

Car goes to FSR Motorsports on Wednesday to get my FMIC piping fabbed up and my preliminary tune. Depending on how the elbow surgery goes, I plan on having this thing on the road by my birthday on the 19th.

Standby for preliminary results.
kellygnsd is online now   Reply With Quote
Old 01-03-2013, 11:00 PM   #136
...CHUCKLES...
Scooby Specialist
 
Member#: 149674
Join Date: May 2007
Chapter/Region: SCIC
Location: at your moms
Vehicle:
2006 LimitLess STI
SGM

Default

Nice.
...CHUCKLES... is offline   Reply With Quote
Old 01-04-2013, 12:06 AM   #137
Bariga
Scooby Specialist
 
Member#: 179846
Join Date: May 2008
Chapter/Region: NWIC
Location: Renton, WA
Vehicle:
07 STi Limited
EFR 7670 TS

Default

Quote:
Originally Posted by Flat 4 Motorsport View Post
That sucks you had so many fitment issues, but glad to see it all come to fruition finally!

Cant wait to see some numbers from this beast!
welcome to my world, lets see boost control issues next
Bariga is offline   Reply With Quote
Old 01-04-2013, 07:07 PM   #138
manitou
Scooby Specialist
 
Member#: 193757
Join Date: Nov 2008
Chapter/Region: MWSOC
Location: Cedar, MI HP Techs MPS-SSLR2.5
Vehicle:
2006 XTI Limited
OBP, Junior tuned 573WHP

Default

Quote:
Originally Posted by Bariga View Post

welcome to my world, lets see boost control issues next
Why Anton, do you like to have boost control issues :LOL:! I couldn't help myself!
manitou is offline   Reply With Quote
Old 01-04-2013, 08:20 PM   #139
kellygnsd
Scooby Guru
 
Member#: 32669
Join Date: Feb 2003
Chapter/Region: SCIC
Location: Rancho C
Vehicle:
2007 2.34LR, EFR7670
LINK G4 hybrid STi

Default

Quote:
Originally Posted by Bariga View Post
welcome to my world, lets see boost control issues next
I sure hope not but if I do oh well, I'll follow your lead and get what you got. Monkiboy didn't mention any problems with his setup so we'll see. The initial tune will only be a 15 psi break-in tune anyway or whatever the WG gives me.
kellygnsd is online now   Reply With Quote
Old 01-08-2013, 10:43 PM   #140
Layvon
NASIOC Supporter
 
Member#: 195711
Join Date: Nov 2008
Chapter/Region: MWSOC
Location: Cadillac MI
Vehicle:
STi 04/05/06/07
JBP / OBP for now

Default

Good luck with surgery n recovery!
Layvon is offline   Reply With Quote
Old 01-08-2013, 11:09 PM   #141
CatfaceType-R
Scooby Guru
 
Member#: 81102
Join Date: Feb 2005
Chapter/Region: MWSOC
Location: I sell platinum cat jewelry.co
Default

Quote:
Originally Posted by Layvon View Post
Good luck with surgery n recovery!
This.
CatfaceType-R is offline   Reply With Quote
Old 01-08-2013, 11:36 PM   #142
manitou
Scooby Specialist
 
Member#: 193757
Join Date: Nov 2008
Chapter/Region: MWSOC
Location: Cedar, MI HP Techs MPS-SSLR2.5
Vehicle:
2006 XTI Limited
OBP, Junior tuned 573WHP

Default

Yes, Good luck and fast healing from the elbow surgery!
manitou is offline   Reply With Quote
Old 01-11-2013, 02:22 AM   #143
Tyrial
Scooby Newbie
 
Member#: 284392
Join Date: May 2011
Chapter/Region: South East
Location: North Charleston, SC
Vehicle:
2011 STI Limited
Plasma Blue Pearl

Default

Need results already! lol, sub'd for updates as I want to see how this ends.
Tyrial is offline   Reply With Quote
Old 01-23-2013, 12:22 AM   #144
kellygnsd
Scooby Guru
 
Member#: 32669
Join Date: Feb 2003
Chapter/Region: SCIC
Location: Rancho C
Vehicle:
2007 2.34LR, EFR7670
LINK G4 hybrid STi

Default

Maybe me trying to get my car in the shop two days after elbow surgery was a little optimistic but when you throw in the bubonic plague flu I had on top of that any chance of me getting my car in the shop went out the window.

Tomorrow is now the day the car gets dropped off and hopefully, if all goes well, I'll have it back in a week or two. FSR Motorsports is going to fab me up some intercooler piping for the core I got from Full Race and give me a preliminary tune. I never knew Dynojet made load control dynos but they have one with a load control module that can hold constant rpm like a mustang.

I ran the car again to make sure the coolant leaks I fixed where good to go and I took a video of a warm restart after I had gotten the car up to temp. Idle is 1500 rpm and car is running N/A with the hot side intercooler piping disconnected. Not overly exciting but a preview of things to come.


Those Mishimoto radiator fan shroud and fans are loud as hell. They sound like they move a lot of air and they drop temps pretty fast but they sound like freaking tornadoes when they kit on.
kellygnsd is online now   Reply With Quote
Old 01-23-2013, 08:28 AM   #145
manitou
Scooby Specialist
 
Member#: 193757
Join Date: Nov 2008
Chapter/Region: MWSOC
Location: Cedar, MI HP Techs MPS-SSLR2.5
Vehicle:
2006 XTI Limited
OBP, Junior tuned 573WHP

Default

Good stuff!! Looking forward to results!
manitou is offline   Reply With Quote
Old 01-23-2013, 08:58 PM   #146
kellygnsd
Scooby Guru
 
Member#: 32669
Join Date: Feb 2003
Chapter/Region: SCIC
Location: Rancho C
Vehicle:
2007 2.34LR, EFR7670
LINK G4 hybrid STi

Default

Dropped the car off today. The shop thinks they can get the IC piping fabbed up this week and get to tuning by next. We're gonna break it in on the dyno then put an 18 psi pump gas tune on it. I can't wait to get this bad boy back on the road.
kellygnsd is online now   Reply With Quote
Old 01-23-2013, 09:30 PM   #147
...CHUCKLES...
Scooby Specialist
 
Member#: 149674
Join Date: May 2007
Chapter/Region: SCIC
Location: at your moms
Vehicle:
2006 LimitLess STI
SGM

Default

Awesome cant wait to meet up and see it in person.

God when I will get mine done.
...CHUCKLES... is offline   Reply With Quote
Old 01-23-2013, 09:57 PM   #148
kellygnsd
Scooby Guru
 
Member#: 32669
Join Date: Feb 2003
Chapter/Region: SCIC
Location: Rancho C
Vehicle:
2007 2.34LR, EFR7670
LINK G4 hybrid STi

Default

Tuning party at FSR next week. You're in Corona right?

Last edited by kellygnsd; 01-24-2013 at 08:58 PM.
kellygnsd is online now   Reply With Quote
Old 01-23-2013, 10:16 PM   #149
...CHUCKLES...
Scooby Specialist
 
Member#: 149674
Join Date: May 2007
Chapter/Region: SCIC
Location: at your moms
Vehicle:
2006 LimitLess STI
SGM

Default

^^^Yea well technically eastvale, but a lot of people still consider it corona still.

Ian at FSR knows me pretty well. Just ask him about a 700hp 1991 white Mitsu GVR4 that was me.
...CHUCKLES... is offline   Reply With Quote
Old 01-24-2013, 08:31 PM   #150
kellygnsd
Scooby Guru
 
Member#: 32669
Join Date: Feb 2003
Chapter/Region: SCIC
Location: Rancho C
Vehicle:
2007 2.34LR, EFR7670
LINK G4 hybrid STi

Default

I can't begin to say how impressed I am with the guys at FSR Motorsports already and my car has only been there just a little bit over 24 hours.

I popped in today to drop of a case of Brad Penn break-in oil and find out that in the past 24 hour they had already fabbed up my intercooler piping, made me an intake and added all kinds of support brackets. It looks like my car may be on the dyno by this weekend or next week at a minimum.

The hot side piping and intake they fabbed up are absolutely perfect. They added a bung for my temp probe so I can log compressor discharge temp and they welded an elbow on the compressor cover of my 7670 so I didn't have to use a 90 degree silicone coupler. The intake is a full 3" cold air intake with the filter mounted in the fender area. They added bungs for my Crawford AOS and a purge return/BCS return fitting.






They also made me bracket to mount my relocated coolant overflow tank which looks pretty clean right here.


Last edited by kellygnsd; 01-26-2013 at 12:38 PM.
kellygnsd is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Maxwell Power EFR 7670 Bariga Proven Power Bragging 2037 Today 02:14 PM
2004 STi EFR 7670 Build Layvon Proven Power Bragging 869 02-10-2014 04:45 PM
The Foos's BW EFR 7064 build thefoos Custom Fabrication, Welding & Tools 158 02-26-2013 01:15 PM
EFR 7064/7670 and 8374 picture previews armyssoldierboy General Community 2 12-29-2010 10:38 AM
EFR 7064/7670 and 8374 picture previews armyssoldierboy News & Rumors 2 12-29-2010 09:08 AM


All times are GMT -4. The time now is 10:37 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.