Welcome to the North American Subaru Impreza Owners Club Monday April 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-31-2011, 11:24 AM   #1
sc00ter
Scooby Specialist
 
Member#: 117767
Join Date: Jun 2006
Chapter/Region: RMIC
Location: Denver, CO
Vehicle:
2011 DGM STI Sedan
Torqued Performance Tuned

Default 2007 WRX hood keeps popping open on highway. Please help.

During my drive from Denver to Steamboat my hood popped open on the highway 4 times. Luckily the safety latch catches it before it smashes the windshield. It would happen when driving between 55 and 65mph.

This happened to me once before as well. It seems to happen when there are high headwinds. It's just the stock hood and I am 100% sure it's shutting all the way.

Has this happened to anyone else? Is there any way for me to fix this?
* Registered users of the site do not see these ads.
sc00ter is offline   Reply With Quote
Old 12-31-2011, 11:28 AM   #2
HoboBob
Scooby Specialist
 
Member#: 253560
Join Date: Jul 2010
Chapter/Region: South East
Location: Redneck Riviera, SC
Vehicle:
'05 FXT
Asspen White

Default

I've noticed my hood shaking at speed but never opening. Is the latch broken or worn down?
HoboBob is online now   Reply With Quote
Old 12-31-2011, 11:29 AM   #3
sc00ter
Scooby Specialist
 
Member#: 117767
Join Date: Jun 2006
Chapter/Region: RMIC
Location: Denver, CO
Vehicle:
2011 DGM STI Sedan
Torqued Performance Tuned

Default

It looks fine to me but I'm definitely no expert. Is there a way for me to tighten the latch?
sc00ter is offline   Reply With Quote
Old 12-31-2011, 11:33 AM   #4
silver03bugeye
Scooby Newbie
 
Member#: 225570
Join Date: Oct 2009
Chapter/Region: MWSOC
Location: Minot ND
Vehicle:
03 wrx
79 trans am 462stroker

Default

How cold is it there? When it gets realy cold here in wisconsin my hood latch wont lock all the way and it will pop. If i can i pull it in the garage or else just spray it with some wd-40 and work the latch and it works. try that
silver03bugeye is offline   Reply With Quote
Old 12-31-2011, 11:36 AM   #5
sc00ter
Scooby Specialist
 
Member#: 117767
Join Date: Jun 2006
Chapter/Region: RMIC
Location: Denver, CO
Vehicle:
2011 DGM STI Sedan
Torqued Performance Tuned

Default

It was about 45-50 degrees during the drive up yesterday so it wasn't that cold. I'll try to take some wd-40 to it I suppose.
sc00ter is offline   Reply With Quote
Old 12-31-2011, 11:46 AM   #6
Psychoreo
Scooby Guru
 
Member#: 79643
Join Date: Jan 2005
Chapter/Region: NESIC
Location: New Britain
Vehicle:
04 EJ207 Swapped
Mikey tuned 271whp/287wtq

Default

Clean it out really well, grease it up when your done.
Psychoreo is offline   Reply With Quote
Old 12-31-2011, 11:49 AM   #7
sc00ter
Scooby Specialist
 
Member#: 117767
Join Date: Jun 2006
Chapter/Region: RMIC
Location: Denver, CO
Vehicle:
2011 DGM STI Sedan
Torqued Performance Tuned

Default

Will do. Thanks!
sc00ter is offline   Reply With Quote
Old 12-31-2011, 12:48 PM   #8
rick-l
Scooby Specialist
 
Member#: 33868
Join Date: Mar 2003
Location: Chesterfield, MO
Vehicle:
2003 wrx
srp

Default

Is there any accident history on this car? Look in the manual for the datums on the firewall and the front fenders.
rick-l is offline   Reply With Quote
Old 12-31-2011, 12:52 PM   #9
burton8913
Scooby Newbie
 
Member#: 275056
Join Date: Feb 2011
Chapter/Region: NESIC
Location: mass
Vehicle:
07 civic
ugm

Default

mine wouldn't close all the way one day so I sprayed some sea foam in the components and it worked out
burton8913 is offline   Reply With Quote
Old 12-31-2011, 12:55 PM   #10
highjumpharry
Scooby Newbie
 
Member#: 166834
Join Date: Dec 2007
Chapter/Region: Tri-State
Location: Jersey City
Vehicle:
02 WRX
WRB

Default

white lithium grease on the locking mechanism. done
highjumpharry is offline   Reply With Quote
Old 12-31-2011, 01:04 PM   #11
woodys77
Scooby Specialist
 
Member#: 192147
Join Date: Oct 2008
Chapter/Region: NESIC
Location: Maine
Vehicle:
2007 STI EfiLogics
422whp 421wtq fpgreen

Default

mine does this in the cold also.
woodys77 is offline   Reply With Quote
Old 12-31-2011, 04:36 PM   #12
yarrgh
Scooby Specialist
 
Member#: 80465
Join Date: Jan 2005
Chapter/Region: RMIC
Location: Aurora, CO
Vehicle:
2001 2.5RS
Black Diamond Pearl

Default

Do you have adjustable rubber cushions? You could try turning those down. Also, test it after you close.
yarrgh is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Car died on highway...need help autocannon05 Service & Maintenance 6 07-23-2007 11:24 PM
keep having this code P0457...PLEASE HELP ON HOW TO FIX IT baon_27 General Community 1 02-14-2007 11:53 PM
My hood keeps popping up, why? kellie00 Interior & Exterior Modification 17 01-17-2006 01:05 AM
Warning, Hood popped open on freeway. Alfaneggio Factory 2.5L Turbo Powertrain 6 04-30-2004 07:31 AM
Help please, a pr0n ad keeps popping up on my work computer out of nowhere.. STR8OUT Off-Topic 20 12-15-2003 04:30 PM


All times are GMT -4. The time now is 09:47 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.