Welcome to the North American Subaru Impreza Owners Club Wednesday August 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Rocky Mountains Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Rocky Mountains Impreza Club Forum -- RMIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-04-2012, 04:24 PM   #1
Jncominco2
Scooby Specialist
 
Member#: 170212
Join Date: Jan 2008
Chapter/Region: RMIC
Location: West Point, Utah
Vehicle:
02 WRX Sedan
MBP

Default Smelling Coolant and Burning Oil

i have a 02 wrx with around 130k on it. it seems to run perfectly fine, i hear a little tick when its cold outside and i first start it up but ive always heard that. goes away once the engine warms up. anyways, when i have my heater on i can smell coolant pretty bad and it gives me a headache sometimes. cant even drive with the wife haha. but im not dripping coolant, no coolant is leaking or spilling and i haven't had to fill it up or anything. its always topped off when i check it. what could that be?

also, this oil change ive had to dump in a quart and a half to keep it up to a good level. its not smoking from the exhaust or anything, doesnt seem like it runs funny. any idea what that is?

i would love to do a compression test but i dont know anyone with a tester. im starting to get worried my cars gonna take a crap on me sometime in the near future and want to know what i can do to figure out whats wrong. i was gone from april to november so i cant really say how it was running then. any input would be great.
* Registered users of the site do not see these ads.
Jncominco2 is offline   Reply With Quote
Old 01-04-2012, 06:29 PM   #2
SUBYS R US
Scooby Specialist
 
Member#: 99591
Join Date: Oct 2005
Chapter/Region: RMIC
Location: Layton,UT
Vehicle:
2003 18g w/38EWG
PSM(siver)

Default

I have a thread almost like this one.

Also, welcome back!! How was Basic and Sheppard?
SUBYS R US is offline   Reply With Quote
Old 01-05-2012, 01:49 AM   #3
Momosaurus WRX
Scooby Specialist
 
Member#: 214737
Join Date: Jun 2009
Location: South Ogden
Default

Sounds like your heater core could have a small leak in it.
Momosaurus WRX is offline   Reply With Quote
Old 01-05-2012, 02:55 AM   #4
scoobydorift
Scooby Specialist
 
Member#: 43128
Join Date: Sep 2003
Location: SLC
Vehicle:
92 RWD, 96 FWD
05 AWD

Default

Quote:
Originally Posted by Momosaurus WRX View Post
Sounds like your heater core could have a small leak in it.
I thought the same thing...

You could possibly see this if you pull back you passenger carpet and feel along the floor and up to the dash for any wet spots. It may also be in the engine bay, the radiators on the WRX are known for leaking at higher mileage, they usually leak where the plastic top is clamped to the aluminum body. I would check the radiator as well as all the hoses, and the exhaust manifold for any signs of coolant.

Also assuming you go 3K between oil changes, burning 1.5 quarts does not seem out of the ordinary for a WRX with 130K on it.

Last edited by scoobydorift; 01-05-2012 at 03:15 AM.
scoobydorift is offline   Reply With Quote
Old 01-05-2012, 09:27 AM   #5
Jncominco2
Scooby Specialist
 
Member#: 170212
Join Date: Jan 2008
Chapter/Region: RMIC
Location: West Point, Utah
Vehicle:
02 WRX Sedan
MBP

Default

Quote:
Originally Posted by SUBYS R US View Post
I have a thread almost like this one.

Also, welcome back!! How was Basic and Sheppard?
Thanks. It was good, just long as hell. That 7 months dragged on forever. What do you do again? Where are you at on base?

Quote:
Originally Posted by scoobydorift View Post
I thought the same thing...

You could possibly see this if you pull back you passenger carpet and feel along the floor and up to the dash for any wet spots. It may also be in the engine bay, the radiators on the WRX are known for leaking at higher mileage, they usually leak where the plastic top is clamped to the aluminum body. I would check the radiator as well as all the hoses, and the exhaust manifold for any signs of coolant.

Also assuming you go 3K between oil changes, burning 1.5 quarts does not seem out of the ordinary for a WRX with 130K on it.
ill have to look and see what is there. i would hope that would be it if anything, easy and cheap fix.
you dont think thats high? considering the car only holds 4.8 quarts? i understand everything has some mileage on it and is worn down, but that just seems a bit high. but i could be wrong, just worrysome i guess
Jncominco2 is offline   Reply With Quote
Old 01-05-2012, 09:34 AM   #6
MY EJ20TTTTTT
Scooby Specialist
 
Member#: 275239
Join Date: Feb 2011
Chapter/Region: MAIC
Location: Northern Neck, VA
Vehicle:
2002 Rallying WRX
Rock chipped MBP

Default

My 02 MBP WRX drinks a quart of oil between changes (front cam gear seals are dripping) but doesnt have any sort of coolant leak / smell to it.
MY EJ20TTTTTT is offline   Reply With Quote
Old 01-05-2012, 10:40 AM   #7
SUBYS R US
Scooby Specialist
 
Member#: 99591
Join Date: Oct 2005
Chapter/Region: RMIC
Location: Layton,UT
Vehicle:
2003 18g w/38EWG
PSM(siver)

Default

[quote="Jncominco2"]

Thanks. It was good, just long as hell. That 7 months dragged on forever. What do you do again? Where are you at on base?

Im on the flight line, crew chief. I actually was hired as a art. What is it that you do again?
SUBYS R US is offline   Reply With Quote
Old 01-05-2012, 11:15 AM   #8
Jncominco2
Scooby Specialist
 
Member#: 170212
Join Date: Jan 2008
Chapter/Region: RMIC
Location: West Point, Utah
Vehicle:
02 WRX Sedan
MBP

Default

Quote:
Originally Posted by MY EJ20TTTTTT View Post
My 02 MBP WRX drinks a quart of oil between changes (front cam gear seals are dripping) but doesnt have any sort of coolant leak / smell to it.
yea before i left it was usually a half to almost a quart, not quite. but now it drinks it up it seems like. and i dont notice any leaking or anything

Quote:
Originally Posted by SUBYS R US View Post
Im on the flight line, crew chief. I actually was hired as a art. What is it that you do again?
oh nice, they are trying to open up a few art positions over here sometime in the future, no idea when. but i hope when i get my CDC's done i can snag one up if they are there. im E&E Backshop over in hangar 25. im 419 but i work with the 388 over here. what squadron are you in?
Jncominco2 is offline   Reply With Quote
Old 01-05-2012, 02:19 PM   #9
SUBYS R US
Scooby Specialist
 
Member#: 99591
Join Date: Oct 2005
Chapter/Region: RMIC
Location: Layton,UT
Vehicle:
2003 18g w/38EWG
PSM(siver)

Default

Quote:
Originally Posted by Jncominco2

oh nice, they are trying to open up a few art positions over here sometime in the future, no idea when. but i hope when i get my CDC's done i can snag one up if they are there. im E&E Backshop over in hangar 25. im 419 but i work with the 388 over here. what squadron are you in?
Im in the 419th also, and work in the 421st and the 4th which follows under the 388th. Are you in seasonal training? I start working next week.
SUBYS R US is offline   Reply With Quote
Old 01-05-2012, 09:04 PM   #10
WRB19
Scooby Specialist
 
Member#: 302898
Join Date: Dec 2011
Location: Wyoming/Arizona
Vehicle:
2014 Focus ST
Race Red

Default

I have a 2011 and it has always smelled like coolant since the day I got it, my friends 2010 is the same way. Dont know why but I assume its fine.
WRB19 is offline   Reply With Quote
Old 01-06-2012, 11:17 AM   #11
Jncominco2
Scooby Specialist
 
Member#: 170212
Join Date: Jan 2008
Chapter/Region: RMIC
Location: West Point, Utah
Vehicle:
02 WRX Sedan
MBP

Default

Quote:
Originally Posted by SUBYS R US View Post
Im in the 419th also, and work in the 421st and the 4th which follows under the 388th. Are you in seasonal training? I start working next week.
yea i am, im supposed to be on orders till september but my current ones end this month cause when i started they didnt have the "funding" hopefully they amend them

Quote:
Originally Posted by WRB19 View Post
I have a 2011 and it has always smelled like coolant since the day I got it, my friends 2010 is the same way. Dont know why but I assume its fine.
really? mine has had a very faint smell of running warm and coolant, but nothing to this extent before
Jncominco2 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
white smoke and burning oil question .. joe_black Normally Aspirated Powertrain 7 12-15-2006 09:20 AM
White smoke and burning oil? JayD707 Service & Maintenance 12 07-16-2005 11:47 AM
18g install, smoke and burning oil smell 15secWRX Factory 2.0L Turbo Powertrain 0 06-22-2005 09:54 PM
Synthetics and burning oil STi/AE86 Service & Maintenance 18 01-19-2005 12:43 PM
Dripping and Burning oil sub25rs General Community 8 01-24-2003 11:36 PM


All times are GMT -4. The time now is 04:50 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.