Welcome to the North American Subaru Impreza Owners Club Wednesday August 5, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Pre-2002 Factory Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-04-2012, 09:47 PM   #1
olivertwisto
Scooby Newbie
 
Member#: 224318
Join Date: Sep 2009
Chapter/Region: International
Location: 八戸市
Vehicle:
1998 WRX
snow white

Default constant RPM ticking noise madness

Hi folks,
My 98 WRX has a ticking noise that is driving me nuts. Only comes when I'm on the throttle, but the speed of the ticking does not increase with engine RPM. It's coming from the drivers side (my car is RHD) of the engine. Not really loud, and performance does not appear to be affected by it. Fuel burn and oil consumption are normal. Any ideas? It's much appreciated!
* Registered users of the site do not see these ads.
olivertwisto is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 01-08-2012, 01:54 AM   #2
blessthekellen
Scooby Specialist
 
Member#: 273859
Join Date: Feb 2011
Chapter/Region: W. Canada
Location: Alberta.
Vehicle:
MY98
WRX

Default

heat shield rattle? My best guess.
blessthekellen is offline   Reply With Quote
Old 01-16-2012, 10:06 PM   #3
olivertwisto
Scooby Newbie
 
Member#: 224318
Join Date: Sep 2009
Chapter/Region: International
Location: 八戸市
Vehicle:
1998 WRX
snow white

Default

Checked out the heat shields, no dice. Man, this noise is making me nuts.
olivertwisto is offline   Reply With Quote
Old 01-17-2012, 02:28 AM   #4
ciper
Scooby Guru
 
Member#: 15543
Join Date: Feb 2002
Location: san francisco, ca
Vehicle:
90BJ Legacy LS ABS
AWD 946 Rio Red Jpn built

Default

Constant speed of ticking like a metronome or variable
ciper is offline   Reply With Quote
Old 01-17-2012, 01:07 PM   #5
TommyAtomic
Scooby Newbie
 
Member#: 257043
Join Date: Sep 2010
Chapter/Region: VIC
Location: Vancouver BC
Vehicle:
1993 JDM WRX Wagon
Black

Default

Does it sound like the ticking noise you get when you put the car in diagnostic mode and it cycles the fans and all of the solenoids?

If its RHD drivers side you have the factory boost controller solenoid located where you are talking about.

I read a howto on cleaning the factory 3 port boost controller that talks about putting the car into daig mode and cleaning the solenoid while its doing its ticking thing. Perhaps its stuck which is causing the ebc solenoid to repeatedly cycle.
TommyAtomic is offline   Reply With Quote
Old 01-19-2012, 07:57 PM   #6
olivertwisto
Scooby Newbie
 
Member#: 224318
Join Date: Sep 2009
Chapter/Region: International
Location: 八戸市
Vehicle:
1998 WRX
snow white

Default

Cheers, that's a good suggestion. I'll try putting it in diagnostic mode and see if i can hear it. It is a constant tick, like a metronome, and doesn't increase with speed or RPM, but it is only present when accelerating and the car has to be moving. Otherwise, the car runs like a champ. I'll post results if I find anything. Thanks again!
olivertwisto is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
EJ207 won't hold constant rpm Faster_Gun Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 5 10-16-2010 12:28 PM
Ticking noise from Trans/driveline at low RPM under light acceleration, deceleration CIATexan Transmission (AT/MT) & Driveline 26 10-14-2010 09:18 AM
Constant loud ticking...help Hoffman Service & Maintenance 4 09-29-2004 07:37 AM
Car won't hold constant RPM - Bad O2 Sensor? jetskizero Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 4 11-21-2003 01:22 PM


All times are GMT -4. The time now is 02:58 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.