Welcome to the North American Subaru Impreza Owners Club Friday October 31, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-05-2012, 10:08 PM   #1
HERSHEY
Scooby Specialist
 
Member#: 148549
Join Date: May 2007
Chapter/Region: NESIC
Location: RI
Vehicle:
95 RHD GC V7 STi
04 WRX, Sold the BlackSTi

Default HELP: When below ~35*F my heat just decides to turn cold whenever it feels like it.

Vehicle is a 2004 WRX Wagon

Conditions...

-The heat will not blow hot air until the car has been driving for more than 10 minutes, EVEN if the engine's temp is at the normal temp.

-Sometimes while driving the heat will randomly just start blowing colder air, in order to get it hot again I have to "play" with all of the switches again (turn temp from cold to hot and back a few times, turn fan on and off a few times, etc.).

-Sometimes it'll be blowing hot air and when I come to a stop light the rpm's will drop just a little, enough to notice it, and then the cold air comes.

-When it seems to be above 35*F-40*F it works fine, which is mostly during the day, then at night when it's really cold... it randomly decides to blow cold.

I have no idea what would cause this or how to troubleshoot the issue. I would greatly appreciate any info since it's very annoying problem to have. If anyone has any info that helps me figure it out than I'll send them a little something!

Thanks in advance.
* Registered users of the site do not see these ads.

Last edited by HERSHEY; 01-05-2012 at 10:16 PM.
HERSHEY is offline   Reply With Quote
Old 01-05-2012, 11:03 PM   #2
dangerousatom
Scooby Specialist
 
Member#: 70710
Join Date: Sep 2004
Chapter/Region: Tri-State
Location: Quakertown/AREA1320 391whp
Vehicle:
2002 04STi Swaped RS
w/PPGS & 02 Wagon w/PPGs

Default

Sounds like your coolant is low or you have a air pocket in the system.

Keep a jug of coolant in the car for a week and before you start the car when its cold top off the water box that feed the turbo. It will work the air out if any and fill the system up if low. Monitor the over flow tank and keep topping it off until its 1/2 full.
dangerousatom is offline   Reply With Quote
Old 01-06-2012, 12:51 AM   #3
z
Scooby Specialist
 
Member#: 41762
Join Date: Aug 2003
Chapter/Region: International
Location: House of Pancakes
Vehicle:
04 STi
CT-DE-FL rinse+repeat

Default

I noticed something similar when my water pump was first going out. I think the impeller was sometimes spinning (and circulating coolant to the heater core) but sometimes not.

I'm wondering if a malfunctioning thermostat (meaning it's staying closed) would block the flow to the heater core also. (not sure of the exact path of flow through the system without looking it up though)
z is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
09 wrx... just doesn't feel like it used to Nimbus09 Newbies & FAQs 33 06-11-2010 05:27 PM
PC just randomly gives up and shuts down whenever it feels like it. SQ3.0dotJP Off-Topic 32 02-22-2010 11:49 AM
HELP: i can boost but it doesnt feel like it soon2bsoobie Newbies & FAQs 6 08-30-2009 10:09 PM
They decide to turn off the A/C, and turn on the heat 24 Off-Topic 8 11-06-2006 01:00 PM
Car starts when it feels like it ???? wrongturninwv Impreza Forum 1 10-20-2006 02:45 PM


All times are GMT -4. The time now is 04:20 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.