Welcome to the North American Subaru Impreza Owners Club Friday February 27, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning > Open Source Reflashes

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-12-2012, 07:17 PM   #1
freddy121389
Scooby Newbie
 
Member#: 294644
Join Date: Sep 2011
Chapter/Region: MAIC
Location: Washington DC
Vehicle:
2011 WRX Agile Auto
DGM 480whp 468wtq

Default Read from ECU with beta version on accident

So Im really new to this and I tried out my tactrix cable today for the first time was only going to read from the ecu. Well after I read from the ecu it worked but ecuflash couldnt read it. So i said ill go inside and check it out after I restart the car and make sure it works. Well it took like 10 seconds for the car to turn over and finally start and then it ran different. I runs fine but its more torque is how ill describe it. So i drove it for like 3 miles to make sure it was good and it was ok but just seemed to be a little more jerky. After going inside i realized i was using the beta version of the ecuflash so i got that fixed. But i was just wondering do you think i did something to the car? Sorry for the long thread just kind worried.
* Registered users of the site do not see these ads.
freddy121389 is offline   Reply With Quote
Old 01-13-2012, 05:31 AM   #2
NSFW
Scooby Guru
 
Member#: 140444
Join Date: Feb 2007
Chapter/Region: NWIC
Location: Near Seattle, WA
Vehicle:
05 Stage Free LGT
ATP 3076, 6MT, AVO FMIC

Default

Quote:
Originally Posted by freddy121389 View Post
So Im really new to this and I tried out my tactrix cable today for the first time was only going to read from the ecu. Well after I read from the ecu it worked but ecuflash couldnt read it.
After you what, you couldn't what? Did you mean that you did a write, but then could not read?

After a write, the ECU needs a few seconds to 'boot up' before the motor can start. It sounds like you ran into that, but it's no big deal.

9 out of 10 new tuners spend a few seconds thinking they've bricked their ECU after that first flash. Myself included.
NSFW is offline   Reply With Quote
Old 01-13-2012, 08:46 AM   #3
freddy121389
Scooby Newbie
 
Member#: 294644
Join Date: Sep 2011
Chapter/Region: MAIC
Location: Washington DC
Vehicle:
2011 WRX Agile Auto
DGM 480whp 468wtq

Default

no i read the stock image, then ecuflash couldnt read it. I tried reopening it after i read the stock image to make sure it worked. i think i just reset the ecu
freddy121389 is offline   Reply With Quote
Old 01-13-2012, 06:47 PM   #4
Paidfor
Scooby Specialist
 
Member#: 267815
Join Date: Dec 2010
Location: Workn on my LSX swap
Vehicle:
Be in awe
dont hate .)

Default

The ecuflash Beta version is the shizzle!!! I can actually read the bottom of the MAF table now lol Its a little improved as far as displaying tables. I didnt notice a whole lot of difference overall.
Paidfor is offline   Reply With Quote
Old 01-13-2012, 07:26 PM   #5
Phatron
Scooby Guru
 
Member#: 36033
Join Date: Apr 2003
Chapter/Region: SCIC
Location: Tuning Lab
Vehicle:
CEO PhatBottiTuning
2006 STi GTX3582 + Meth

Default

the difference you're feeling is because you reset all of the AF trims and the fine learning knock correction table and the IAM.

The only reason ecuflash wont open a file is if you dont have the proper definition for it.....since you have a 2011 WRX you have to go to romraider and download your definition separately and add it to the rommetadata/subaru/impreza wrx folder manually.

http://www.romraider.com/forum/viewt...hp?f=34&t=6639
Phatron is offline   Reply With Quote
Old 01-13-2012, 09:32 PM   #6
TheGremlyn
Scooby Newbie
 
Member#: 287161
Join Date: Jun 2011
Chapter/Region: MWSOC
Location: Ann Arbor, MI
Vehicle:
2011 WRX 5dr
Black

Default

The last batch of 2011 WRXs apparently have a slightly different definition file, which is probably why ECUFlash can't read it. Unless you didn't add in the definitions to begin with. Did you get a window that gave three options (something like Cancel, Save anyway, or Create definition)? Same happened to me. I was instructed to just save the file, and there will be an updated definition for the new ECU version soon. All it means is I can't flash back to stock without it.
TheGremlyn is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ecuflash - stuck at read from ecu black thunder Open Source Reflashes 1 04-22-2010 05:16 PM
Cant Read from ECU Jakkim Engine Management & Tuning 6 03-08-2010 04:42 PM
2003 wrx cant read from ecu matthewhiggins118 Open Source Reflashes 16 05-15-2009 11:08 PM
Voltage readings from ecu? Onederer Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 1 06-25-2002 07:12 PM


All times are GMT -4. The time now is 02:41 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.