Welcome to the North American Subaru Impreza Owners Club Thursday September 3, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Mid West Subaru Owners Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Mid West Subaru Owners Club Forum -- MWSOC > MWSOC Private Classifieds

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-29-2011, 12:10 AM   #1
srt41320
Scooby Newbie
Member Sales Rating: (1)
 
Member#: 244784
Join Date: Apr 2010
Location: illinois
Vehicle:
2003 WRX
WRB

Default IL - 1999 Subaru Forester S $3,500

sold - please delete! thanks nasioc!
* Registered users of the site do not see these ads.

Last edited by srt41320; 11-05-2011 at 02:23 PM. Reason: car was sold
srt41320 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 10-29-2011, 12:49 PM   #2
stevepius
Scooby Specialist
Member Sales Rating: (10)
 
Member#: 75378
Join Date: Nov 2004
Chapter/Region: MWSOC
Location: Frankiln, WI
Vehicle:
1999 Forester
Silver

Default

Do you know why it's burning oil?
stevepius is offline   Reply With Quote
Old 10-29-2011, 01:07 PM   #3
bluE-d1ff
Scooby Specialist
Member Sales Rating: (4)
 
Member#: 285136
Join Date: Jun 2011
Chapter/Region: MWSOC
Location: Missmywagon Town
Vehicle:
1997 Ford Ranger
Scratchy Denty Red

Default

Probably Cuz its a subaru
bluE-d1ff is offline   Reply With Quote
Old 10-29-2011, 07:37 PM   #4
srt41320
Scooby Newbie
Member Sales Rating: (1)
 
Member#: 244784
Join Date: Apr 2010
Location: illinois
Vehicle:
2003 WRX
WRB

Default

That's one of the reasons... Haha! I've heard it's kinda common in higher mileage subbies.. Also maybe due to the valvetrain issues these motors sometimes have - buy honestly it doesn't burn any more now then when I bought it 25k miles ago and basically I top it off every 3 weeks (about 1/2 - 3/4 of a quart), just keep a jug in the back.

Plus it probably doesn't help that this car pretty much just sees 80mph up/down the highway everyday...
srt41320 is offline   Reply With Quote
Old 10-30-2011, 03:42 PM   #5
srt41320
Scooby Newbie
Member Sales Rating: (1)
 
Member#: 244784
Join Date: Apr 2010
Location: illinois
Vehicle:
2003 WRX
WRB

Default

Up top
srt41320 is offline   Reply With Quote
Old 11-01-2011, 01:52 PM   #6
srt41320
Scooby Newbie
Member Sales Rating: (1)
 
Member#: 244784
Join Date: Apr 2010
Location: illinois
Vehicle:
2003 WRX
WRB

Default

PMs replied to!
srt41320 is offline   Reply With Quote
Old 11-03-2011, 08:26 AM   #7
srt41320
Scooby Newbie
Member Sales Rating: (1)
 
Member#: 244784
Join Date: Apr 2010
Location: illinois
Vehicle:
2003 WRX
WRB

Default

Morning bump!!
srt41320 is offline   Reply With Quote
Old 11-05-2011, 02:23 PM   #8
srt41320
Scooby Newbie
Member Sales Rating: (1)
 
Member#: 244784
Join Date: Apr 2010
Location: illinois
Vehicle:
2003 WRX
WRB

Default

Sold!!!!
srt41320 is offline   Reply With Quote
Old 01-21-2012, 09:43 AM   #9
stevepius
Scooby Specialist
Member Sales Rating: (10)
 
Member#: 75378
Join Date: Nov 2004
Chapter/Region: MWSOC
Location: Frankiln, WI
Vehicle:
1999 Forester
Silver

Default

Car wasn't burning oil, was leaking from both the oil separator plate and the valve cover gaskets. Also it wasn't lifter tick, it's knock (i.e. block is ticking timebomb). Looks like the oil level got too low at one point and destroyed a bearing. Was also leaking rear diff fluid.

Please research your cars issues further before dumping them.
stevepius is offline   Reply With Quote
Old 01-21-2012, 10:15 AM   #10
Sword_of_the_Spirit
Scooby Specialist
Member Sales Rating: (11)
 
Member#: 201462
Join Date: Jan 2009
Chapter/Region: MWSOC
Location: Northeast IL; Southeast AL
Vehicle:
~ Daihatsu
Charade-Recaro Spec. ED ~

Default

Buyer beware never rang more true. Always ask to have a mate tag along for that extra eye.

Sounds like you got duped with your vehicle I.D. If you need any help, I'm not that far away.


MvP
Sword_of_the_Spirit is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS: 1999 Subaru Forester L - 30,500 miles (Irving, Dallas, Texas) nitgupta Texas Impreza Club Forum -- TXIC 4 10-07-2003 02:01 AM
FS: 1999 Subaru Forester L - 30,500 miles (Irving, Dallas, Texas) nitgupta Private Vehicle 'For Sale' Classifieds 0 09-29-2003 12:32 PM
FS: 1999 Subaru Forester L - 30,500 miles nitgupta Private 'For Sale' Classifieds 0 09-29-2003 12:30 PM
FS: 1999 Subaru Forester L - 30,500 miles nitgupta Texas Impreza Club Forum -- TXIC 0 09-29-2003 12:15 PM


All times are GMT -4. The time now is 08:57 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.