Welcome to the North American Subaru Impreza Owners Club Tuesday December 1, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Thread Tools Display Modes
Old 01-13-2012, 07:30 PM   #1
Scooby Newbie
Member#: 281725
Join Date: May 2011
Chapter/Region: Tri-State
Location: NJ
2006 STI
Aspen White

Default Hood released unexpectedly

Has this ever happened to anyone?

Was driving in Manhattan today, and if you're anywhere in the Northeast you know the kind of winds that are out there right now. Was driving along at about 40-45, and noticed my hood start to vibrate. Then all of a sudden, my hood latch opened and my hood opened that to that first stop as if you had pulled the handle under the dash. I cut the wheel and blinker on the shoulder, hop out, and as I look at the hood, the latch was about to let go completely and let my hood raise up.

I swear I did not hit the release latch. Anyone have ANY idea what the hell happened?
* Registered users of the site do not see these ads.
GFB is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 01-13-2012, 07:55 PM   #2
Scooby Guru
Member#: 139955
Join Date: Feb 2007
Chapter/Region: NESIC
Location: Boston
2015 Subaru STI
Stage e


Latch is probably dirty and stuck and didnt actually "latch" last time you were in the engine bay.
vision.dynamix is offline   Reply With Quote
Old 01-16-2012, 09:54 PM   #3
Scooby Newbie
Member#: 216474
Join Date: Jul 2009
Chapter/Region: Tri-State
Location: Tri State
2004 WRX


happened to me once
envymysubie is offline   Reply With Quote
Old 01-16-2012, 10:32 PM   #4
Jackie leggs
Scooby Specialist
Member#: 249794
Join Date: Jun 2010
Chapter/Region: MAIC
Location: Huntington, WV
02 WRX wagon
atomic orange pearl


same here happened in one of my old cars, but the hood actually came all the way back. for some reason the safety latch didn't catch and up it went. So now I make sure to clean and oil them whenever I can.
Jackie leggs is online now   Reply With Quote
Old 01-16-2012, 10:55 PM   #5
Scooby Specialist
Member#: 271928
Join Date: Jan 2011
Chapter/Region: Tri-State
Location: Gettysburg PA
2014 WRX Limited
Crystal Black Silica


This past Saturday I was writing down some wiring information and when I thought the hood had completely shut it wasn't and i didn't notice till I was driving down the road and saw the hood lifting up, maybe you had it open earlier and thought it was shut the whole way?
alt14 is offline   Reply With Quote
Old 01-20-2012, 12:55 PM   #6
Scooby Newbie
Member#: 222577
Join Date: Sep 2009
Location: Ottawa, Great White North
2002 16g tuned 4.11
WRX wagon on coilovers


Happened to me earlier this winter...all the gunk applied by the previous owner to keep the mechanism lubricated had gunked up into a thick paste...especially in -35C weather!!!!

I sprayed it with penetrating oil, let it sit for a couple hours, then cleaned it up with a small screwdriver before re-greasing it with lithium. It works tip top now.
WRX'n'effect is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Broken hood release cable lmted Newbies & FAQs 3 04-14-2004 10:25 AM
BMW hood release Colonel Lingus Off-Topic 11 03-30-2004 05:56 PM
Hood release broke!!!! Tim-E Tri-State Area Forum 7 02-09-2004 07:09 PM
hood release broken saar Service & Maintenance 0 09-21-2003 09:45 AM
Hood Release Problems God Spd 6 Service & Maintenance 2 03-11-2002 01:50 AM

All times are GMT -4. The time now is 12:37 PM.

Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.