Welcome to the North American Subaru Impreza Owners Club Thursday December 18, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Member's Car Gallery

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-20-2013, 06:12 PM   #20451
yenny
Scooby Newbie
 
Member#: 143116
Join Date: Mar 2007
Location: FL
Default

Quote:
Originally Posted by CASHxMONEYxMIKE View Post
So anyone else had or know how to adjust this issue without resetting anything? As i was driving to work, i made a left turn, didn't go over any bumbs/ glass/ obstructions, etc. I was in second gear at like 15mph and as soon as I came out of the turn my tire pressure sensor light came on. All 4's look fine, couldn't hear or see any leaks. Drove to work another 5 miles or so, checked them again and still fine. Just wondering if our model years have super sensitive or super sh***y sensors in them. Thanks guys
TPMS lights up also when pressure is too high. As tires warm up pressure increases and may light it up
* Registered users of the site do not see these ads.
yenny is offline   Reply With Quote
Old 06-20-2013, 07:04 PM   #20452
CASHxMONEYxMIKE
Scooby Specialist
 
Member#: 228719
Join Date: Nov 2009
Chapter/Region: NWIC
Location: Chicago NW Suburbs
Vehicle:
2013 STi
Satin White Pearl

Default

Problem after problem with me, now my car is making a loud rattle after install of the KB SS w/ F+R bushings.. Any ideas?
CASHxMONEYxMIKE is offline   Reply With Quote
Old 06-20-2013, 07:12 PM   #20453
sdirep
Scooby Newbie
 
Member#: 359672
Join Date: Jun 2013
Vehicle:
2013 STi
SWP

Default

What size wheels and tires you running on those? Perfect Fit FilipinoGuy
sdirep is offline   Reply With Quote
Old 06-20-2013, 07:13 PM   #20454
Aarron_M
Scooby Specialist
 
Member#: 68210
Join Date: Aug 2004
Chapter/Region: RMIC
Location: Colorado Springs, CO
Vehicle:
2013 STI
SWP

Default

Quote:
Originally Posted by CASHxMONEYxMIKE View Post
Problem after problem with me, now my car is making a loud rattle after install of the KB SS w/ F+R bushings.. Any ideas?
Maybe it's the KB SS w/ F+R bushings...
Aarron_M is offline   Reply With Quote
Old 06-20-2013, 07:18 PM   #20455
CASHxMONEYxMIKE
Scooby Specialist
 
Member#: 228719
Join Date: Nov 2009
Chapter/Region: NWIC
Location: Chicago NW Suburbs
Vehicle:
2013 STi
Satin White Pearl

Default

Quote:
Originally Posted by Aarron_M View Post

Maybe it's the KB SS w/ F+R bushings...
One could assume.........
CASHxMONEYxMIKE is offline   Reply With Quote
Old 06-20-2013, 08:11 PM   #20456
Improbus
Scooby Newbie
 
Member#: 278439
Join Date: Mar 2011
Chapter/Region: MAIC
Location: Pa, USA
Vehicle:
2011 WRX 4dr Stage2+
OBP

Default

Quote:
Originally Posted by CASHxMONEYxMIKE View Post
One could assume.........
Welcome to the world of Subaru's. With every bushing upgrade, suspension stiffening, and time your Subaru will make more noise than a 2 year old teething. Unless its repeatable under a set condition I would stack it up to the persona of a Subaru.

Check and make sure everything is torqued properly to the specs, make sure the linkage for the short shifter isn't loose, if everything checks out I wouldn't worry. Just my opinion, I'm sure others here will also have some advice for you.
Improbus is offline   Reply With Quote
Old 06-20-2013, 08:15 PM   #20457
JSchell1309
Scooby Specialist
 
Member#: 321321
Join Date: May 2012
Chapter/Region: MWSOC
Location: KC,MO
Vehicle:
'11 STI Hatchback
Dom 1.5XTR, E85

Default

Quote:
Originally Posted by CASHxMONEYxMIKE View Post
Problem after problem with me, now my car is making a loud rattle after install of the KB SS w/ F+R bushings.. Any ideas?
Did you put that worthless heat shield back on? Get down there and tighten that all down and shake on it like a drunken ape.
JSchell1309 is offline   Reply With Quote
Old 06-20-2013, 08:34 PM   #20458
garudatwo
Scooby Specialist
 
Member#: 322385
Join Date: Jun 2012
Chapter/Region: Tri-State
Default

+1 for heatshield. Double check that you haven't bent it as well.
garudatwo is offline   Reply With Quote
Old 06-20-2013, 09:00 PM   #20459
IBLinKYI
Scooby Newbie
 
Member#: 172067
Join Date: Feb 2008
Chapter/Region: South East
Location: ATL, GA
Vehicle:
2011 Subaru WRX
Drunkmann Tuned LRP

Default

Came across this from the weekend.

IBLinKYI is offline   Reply With Quote
Old 06-20-2013, 09:24 PM   #20460
JSchell1309
Scooby Specialist
 
Member#: 321321
Join Date: May 2012
Chapter/Region: MWSOC
Location: KC,MO
Vehicle:
'11 STI Hatchback
Dom 1.5XTR, E85

Default

Quote:
Originally Posted by IBLinKYI View Post
Came across this from the weekend.
Mmmmm,

Lightning Red - Check
Hatch - Check
BBS LM (reps ) - Check

Very clean, I do have a chub.
JSchell1309 is offline   Reply With Quote
Old 06-20-2013, 09:34 PM   #20461
durtydurt
Scooby Newbie
 
Member#: 235745
Join Date: Jan 2010
Chapter/Region: E. Canada
Vehicle:
2011 WRX 5dr
WRB

Default





durtydurt is offline   Reply With Quote
Old 06-20-2013, 11:29 PM   #20462
CASHxMONEYxMIKE
Scooby Specialist
 
Member#: 228719
Join Date: Nov 2009
Chapter/Region: NWIC
Location: Chicago NW Suburbs
Vehicle:
2013 STi
Satin White Pearl

Default

Quote:
Originally Posted by garudatwo View Post
+1 for heatshield. Double check that you haven't bent it as well.
It was the heat shield!!!! Just needed to be moved over a tad and it went away. Thanks guys. Also today was seriously the shi**iest day I've had in awhile. Look out for a new random thread ill be starting. I basically might have a law suit pending -_______- (sigh) I just wish things went my way for once.
CASHxMONEYxMIKE is offline   Reply With Quote
Old 06-20-2013, 11:34 PM   #20463
Overland04
Scooby Specialist
 
Member#: 293311
Join Date: Sep 2011
Chapter/Region: NESIC
Location: Coast of Maine
Vehicle:
2011 WRX Limited
Satin White Pearl

Default

Quote:
Originally Posted by durtydurt View Post
.
Nice car man. Simple, clean, functional, I dig it!
Overland04 is offline   Reply With Quote
Old 06-20-2013, 11:37 PM   #20464
garudatwo
Scooby Specialist
 
Member#: 322385
Join Date: Jun 2012
Chapter/Region: Tri-State
Default

Quote:
Originally Posted by CASHxMONEYxMIKE View Post
It was the heat shield!!!! Just needed to be moved over a tad and it went away. Thanks guys. Also today was seriously the shi**iest day I've had in awhile. Look out for a new random thread ill be starting. I basically might have a law suit pending -_______- (sigh) I just wish things went my way for once.
You're driving a '13 STi. That's a sign that a LOT of things are going your way.
garudatwo is offline   Reply With Quote
Old 06-20-2013, 11:39 PM   #20465
JSchell1309
Scooby Specialist
 
Member#: 321321
Join Date: May 2012
Chapter/Region: MWSOC
Location: KC,MO
Vehicle:
'11 STI Hatchback
Dom 1.5XTR, E85

Default






What a damn good event. All credit to David Mullis for his awesome work behind the lens that day. Check out the rest of them here:
http://www.flickr.com/photos/scoobapalooza/
JSchell1309 is offline   Reply With Quote
Old 06-20-2013, 11:44 PM   #20466
garudatwo
Scooby Specialist
 
Member#: 322385
Join Date: Jun 2012
Chapter/Region: Tri-State
Default

Love your plate delete. Trying to work with another member here to see if he can make me one that says USMC.
garudatwo is offline   Reply With Quote
Old 06-20-2013, 11:46 PM   #20467
PearlRex11
Scooby Specialist
 
Member#: 284420
Join Date: Jun 2011
Chapter/Region: SWIC
Location: Lakewood, Ca
Vehicle:
2011 WRX Sedan
SWP

Default

Quote:
Originally Posted by Improbus View Post

Turn Signal Bulbs are Dual Filament. If one of the filaments comes loose the light will still work but will blink quickly. The dealer replaced mine under warranty. If not a new turn signal bulb and you'll be good to go.
Mine had a pinched wire due to a factory installed zip tie. Acted exactly like that, I thought it was a bulb it because it is the same symptom but it wasn't the bulb.
PearlRex11 is offline   Reply With Quote
Old 06-20-2013, 11:54 PM   #20468
JSchell1309
Scooby Specialist
 
Member#: 321321
Join Date: May 2012
Chapter/Region: MWSOC
Location: KC,MO
Vehicle:
'11 STI Hatchback
Dom 1.5XTR, E85

Default

Quote:
Originally Posted by garudatwo View Post
Love your plate delete. Trying to work with another member here to see if he can make me one that says USMC.
Thanks man. I'm working on a few new things for the hatch.
JSchell1309 is offline   Reply With Quote
Old 06-20-2013, 11:55 PM   #20469
Turtlefart
Scooby Newbie
 
Member#: 320054
Join Date: May 2012
Chapter/Region: NWIC
Location: Tacoma, Wa
Vehicle:
2011 WRX
WRB

Default

More from David Mullis of my car.




Turtlefart is offline   Reply With Quote
Old 06-20-2013, 11:58 PM   #20470
JSchell1309
Scooby Specialist
 
Member#: 321321
Join Date: May 2012
Chapter/Region: MWSOC
Location: KC,MO
Vehicle:
'11 STI Hatchback
Dom 1.5XTR, E85

Default

Quote:
Originally Posted by Turtlefart View Post
More from David Mullis of my car.
What did you think of the event over all, Turtlefart?



JSchell1309 is offline   Reply With Quote
Old 06-21-2013, 12:53 AM   #20471
_davin
Scooby Specialist
 
Member#: 260501
Join Date: Oct 2010
Chapter/Region: AKIC
Location: Anchorage, Alaska
Vehicle:
2011 WRX 5dr SWP Ltd

Default


Right side.
_davin is online now   Reply With Quote
Old 06-21-2013, 01:01 AM   #20472
mtl_sti
Scooby Newbie
 
Member#: 351705
Join Date: Mar 2013
Chapter/Region: E. Canada
Location: Montreal
Vehicle:
2012 STI Sedan
Obsidian Black Pearl

Default

mtl_sti is offline   Reply With Quote
Old 06-21-2013, 02:33 AM   #20473
paterick
Scooby Newbie
 
Member#: 305207
Join Date: Dec 2011
Chapter/Region: BAIC
Location: SJ / Bay Area / CA
Vehicle:
2012 WRX Sedan
WRB

Default

Quote:
Originally Posted by NWsoobie View Post
Japanparts.com has them. I think it's $400 for the entire kit. Surrounds, fogs, and switch.
damn I like dems but 400 dolla I cannot holla.
paterick is offline   Reply With Quote
Old 06-21-2013, 04:20 AM   #20474
jbgta007
Scooby Newbie
 
Member#: 326113
Join Date: Jul 2012
Chapter/Region: MWSOC
Location: Soviet kompton, Russia
Vehicle:
2012 WRX
WRB

Default

Quote:
Originally Posted by paterick View Post
damn I like dems but 400 dolla I cannot holla.
If you really think about it the U.S. fog light kit cost $350 from the dealer with no discounts or taxes... so $400 for the good looking hid jdm ones shipped is pretty do-able haha.

since we're on that topic: So If you buy the kit off japanparts how do you select what color garnishes for the lights? or do they just come unpainted? also is it totally plug and play or do they need modification?
jbgta007 is offline   Reply With Quote
Old 06-21-2013, 08:32 AM   #20475
Aarron_M
Scooby Specialist
 
Member#: 68210
Join Date: Aug 2004
Chapter/Region: RMIC
Location: Colorado Springs, CO
Vehicle:
2013 STI
SWP

Default

It's been over a week since I ordered the R205 rear diffuser from japanparts...still no tracking info or shipping email.
Aarron_M is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
('11-'14) 2011-2012 wrx/sti picture thread (for real this time) guamanian_powered Impreza Forum 151 04-29-2014 09:35 AM
01-07 wrx and sti drivetrain? xj bmx Newbies & FAQs 13 01-26-2012 04:30 PM
('11-'14) 2011 wrx/sti picture thread (for real this time) guamanian_powered Impreza Forum 1 11-17-2011 12:51 AM
Anyone have the 06-07 Impreza WRX and STI master part number and picture list STEALTH-WRX Interior & Exterior Modification 0 08-22-2008 03:12 PM
The Official World One STI and SEMA picture thread.. WorldOne Member's Car Gallery 25 11-29-2003 06:21 PM


All times are GMT -4. The time now is 11:42 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.