Welcome to the North American Subaru Impreza Owners Club Saturday December 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Member's Car Gallery

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-09-2013, 10:47 AM   #21351
rwfloberg
Scooby Newbie
 
Member#: 327538
Join Date: Jul 2012
Chapter/Region: MAIC
Location: La Plata MD
Vehicle:
2012 WRX (307/344)
SWP

Default

Quote:
Originally Posted by kyletakahero View Post
I loooooove the look. Shooting for it soon once I'm scoop less.
They make the Impreza in SWP? Or are you planning on getting this repainted?
* Registered users of the site do not see these ads.
rwfloberg is offline   Reply With Quote
Old 07-09-2013, 10:58 AM   #21352
Scnsaracer
Scooby Newbie
 
Member#: 319511
Join Date: May 2012
Chapter/Region: TXIC
Location: McKinney, TX
Vehicle:
2013 STI Sedan
Ice Silver Metallic

Default

Here is a quick iphone shot of my STI from this weekend's activities.



And a shot of our new project. My son is turning 13 in a couple weeks and we are rebuilding this little Bugeye for him:





BTW - were looking for a Stock or carbon hood and a driver side fender - 2002 WRX
Scnsaracer is offline   Reply With Quote
Old 07-09-2013, 11:04 AM   #21353
jjablo6
Scooby Specialist
 
Member#: 265697
Join Date: Dec 2010
Chapter/Region: MWSOC
Location: Chicago
Vehicle:
2015 STi
Ligtening Red

Default

Quote:
Originally Posted by Erittz View Post
Just a plain looking blue wrx, 2011. If you look in cldb's picture on the scooba page, I'm the blue car with the "vrm psh" liscense plate.
nicee! did you have to cut the bumper to fit the intercooler? i gotta install these

jjablo6 is offline   Reply With Quote
Old 07-09-2013, 11:31 AM   #21354
Erittz
Scooby Newbie
 
Member#: 282506
Join Date: May 2011
Location: Columbia, Missouri
Vehicle:
2011 WRX
WRB

Default

Quote:
Originally Posted by jjablo6 View Post
nicee! did you have to cut the bumper to fit the intercooler?

I did not, I can take pictures of it if you're looking into getting one here soon. I have the RacerX kit
Erittz is offline   Reply With Quote
Old 07-09-2013, 11:37 AM   #21355
jjablo6
Scooby Specialist
 
Member#: 265697
Join Date: Dec 2010
Chapter/Region: MWSOC
Location: Chicago
Vehicle:
2015 STi
Ligtening Red

Default

Quote:
Originally Posted by Erittz View Post
I did not, I can take pictures of it if you're looking into getting one here soon. I have the RacerX kit
yea take some pictures if you get a chance I'd like to see that
jjablo6 is offline   Reply With Quote
Old 07-09-2013, 12:02 PM   #21356
Relier1
Scooby Specialist
 
Member#: 350437
Join Date: Mar 2013
Default

Quote:
Originally Posted by Ruzty1311 View Post
I think you guys met at some point haha
[/quote]

I'll be sure to tell him tonight, he should be at our local meet (north L.A.)...
Relier1 is offline   Reply With Quote
Old 07-09-2013, 01:08 PM   #21357
BrendanTheGreat408
Scooby Specialist
 
Member#: 271207
Join Date: Jan 2011
Chapter/Region: BAIC
Location: Morgan Hill, CA
Vehicle:
2011 WRX
SWP

Default

Got the brembos on
BrendanTheGreat408 is offline   Reply With Quote
Old 07-09-2013, 01:21 PM   #21358
SkyeC
Scooby Newbie
 
Member#: 94323
Join Date: Aug 2005
Chapter/Region: BAIC
Location: Oakland
Vehicle:
2012 WRX
SWP

Default

Nice. Bagged I assume?
SkyeC is offline   Reply With Quote
Old 07-09-2013, 01:22 PM   #21359
DearDiaryJackpot
Scooby Specialist
 
Member#: 343041
Join Date: Jan 2013
Location: riverview
Vehicle:
2013 wrx limited
metallic silver

Default

Quote:
Originally Posted by BrendanTheGreat408 View Post
Got the brembos on
Speechless. Well other than awesome!!
DearDiaryJackpot is offline   Reply With Quote
Old 07-09-2013, 01:28 PM   #21360
BrendanTheGreat408
Scooby Specialist
 
Member#: 271207
Join Date: Jan 2011
Chapter/Region: BAIC
Location: Morgan Hill, CA
Vehicle:
2011 WRX
SWP

Default

Quote:
Originally Posted by SkyeC View Post
Nice. Bagged I assume?
yes on air lift

Quote:
Originally Posted by DearDiaryJackpot View Post
Speechless. Well other than awesome!!

thank ya thank ya!
BrendanTheGreat408 is offline   Reply With Quote
Old 07-09-2013, 01:52 PM   #21361
bnasty49
Scooby Newbie
 
Member#: 351310
Join Date: Mar 2013
Chapter/Region: SWIC
Location: Phoenix
Vehicle:
2013 WRX
Crystal B

Default

Quote:
Originally Posted by BrendanTheGreat408 View Post
Got the brembos on
Love the blue calipers!
bnasty49 is offline   Reply With Quote
Old 07-09-2013, 02:58 PM   #21362
mkvaron
Scooby Newbie
 
Member#: 326317
Join Date: Jul 2012
Chapter/Region: SCIC
Location: SoCal
Vehicle:
2011 WRX hatch
SSM

Default

Quote:
Originally Posted by amp2oo1 View Post
Love the PBP action shots!! Still jealous over the fact that color wasn't an option for the 11 WRX. And as always, the better car is in front...

Last edited by mkvaron; 07-09-2013 at 04:28 PM. Reason: 11 WRX (thanks Celery, wait, did i just say that?)
mkvaron is offline   Reply With Quote
Old 07-09-2013, 03:13 PM   #21363
Celery GT-5
Scooby Guru
 
Member#: 98210
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: Upstate NY
Vehicle:
2015 WRX Premium 6MT
WRB

Default

it was if you got an STI

blue calipers ftw
Celery GT-5 is offline   Reply With Quote
Old 07-09-2013, 05:59 PM   #21364
kyletakahero
Scooby Specialist
 
Member#: 185030
Join Date: Jul 2008
Chapter/Region: AKIC
Location: Anchorage, AK
Vehicle:
2003

Default

Quote:
Originally Posted by rwfloberg View Post

They make the Impreza in SWP? Or are you planning on getting this repainted?
They do make them in SWP.
kyletakahero is offline   Reply With Quote
Old 07-09-2013, 06:44 PM   #21365
SeattleDrive
Scooby Newbie
 
Member#: 313167
Join Date: Mar 2012
Location: Seattle
Vehicle:
2008 STi
SSM

Default

Quote:
Originally Posted by BrendanTheGreat408 View Post
Got the brembos on
[IMG ]https://sphotos-a.xx.fbcdn.net/hphotos-ash4/1052454_608368019197908_947926617_o.jpg[/IMG ]
Dude, your car is 4x4 status. Needs moar low man

Looks great! Is that a second lip or all one piece on the front?
SeattleDrive is offline   Reply With Quote
Old 07-09-2013, 07:28 PM   #21366
jjablo6
Scooby Specialist
 
Member#: 265697
Join Date: Dec 2010
Chapter/Region: MWSOC
Location: Chicago
Vehicle:
2015 STi
Ligtening Red

Default

Quote:
Originally Posted by SeattleDrive View Post
Dude, your car is 4x4 status. Needs moar low man

Looks great! Is that a second lip or all one piece on the front?
looks like a front splitter (possibly APR)
jjablo6 is offline   Reply With Quote
Old 07-09-2013, 09:00 PM   #21367
ScoobyFreak86
Scooby Specialist
 
Member#: 338329
Join Date: Nov 2012
Chapter/Region: Tri-State
Location: NJ
Vehicle:
2013 WRX Hatch
SWP

Default

Just installed a JNA CS style front lip

ScoobyFreak86 is offline   Reply With Quote
Old 07-09-2013, 09:10 PM   #21368
SLOW_motion
Scooby Newbie
 
Member#: 116625
Join Date: Jun 2006
Chapter/Region: E. Canada
Location: Hinterland...Nova Scotia.
Vehicle:
4513 04STi05LGT13STI
Silver-Garnet-White

Default

Our newest SUBARU (2013) sedan in pearl-white.

Front...


Left...


Far...Left

Last edited by SLOW_motion; 07-09-2013 at 09:29 PM. Reason: Needed to add some STI Pink!
SLOW_motion is offline   Reply With Quote
Old 07-09-2013, 09:15 PM   #21369
Laexreme5
Scooby Specialist
 
Member#: 315264
Join Date: Mar 2012
Location: Slidell, LA
Vehicle:
2012 WRX
SWP

Default

Quote:
Originally Posted by BrendanTheGreat408 View Post
Got the brembos on
anymore shots of the splitter?? very intersted in how it looks.
Laexreme5 is offline   Reply With Quote
Old 07-09-2013, 11:00 PM   #21370
JSchell1309
Scooby Specialist
 
Member#: 321321
Join Date: May 2012
Chapter/Region: MWSOC
Location: KC,MO
Vehicle:
'11 STI Hatchback
Dom 1.5XTR, E85

Default

This is going in here because I don't want to start a new thread and I need a quick answer. I installed a new radio (Pioneer AVIC-X9310BT) which is the Canadian option for a '12 and '13 STI. I ordered the Pioneer harness to plug and play with my 2011 STI harness. There were a few unused plugs, but I made sure to use the ground plug on the radio bracket. Now my dash lights up like this when I have the key in the accessory position. Once I start it everything goes away. Just wondering if this is a faulty ground, or one of the plugs I didn't use is causing this.

JSchell1309 is offline   Reply With Quote
Old 07-09-2013, 11:09 PM   #21371
thatsilverwrx
Scooby Newbie
 
Member#: 307725
Join Date: Jan 2012
Vehicle:
2012 WRX
ISM

Default

^ that's not normal? I'm pretty sure my car does that in ACC as well.
thatsilverwrx is offline   Reply With Quote
Old 07-09-2013, 11:17 PM   #21372
1an5anity
Scooby Newbie
 
Member#: 355385
Join Date: May 2013
Chapter/Region: South East
Location: Jacksonville NC
Vehicle:
13 STi
Black

Default



2013 blacked out headlights. Did some red trimming and on the grill too. I like how it turned out =]
1an5anity is offline   Reply With Quote
Old 07-09-2013, 11:24 PM   #21373
besthaticouldo
NASIOC Supporter
 
Member#: 279660
Join Date: Apr 2011
Chapter/Region: MWSOC
Location: STL
Default

Quote:
Originally Posted by JSchell1309 View Post
This is going in here because I don't want to start a new thread and I need a quick answer. I installed a new radio (Pioneer AVIC-X9310BT) which is the Canadian option for a '12 and '13 STI. I ordered the Pioneer harness to plug and play with my 2011 STI harness. There were a few unused plugs, but I made sure to use the ground plug on the radio bracket. Now my dash lights up like this when I have the key in the accessory position. Once I start it everything goes away. Just wondering if this is a faulty ground, or one of the plugs I didn't use is causing this.
Quote:
Originally Posted by thatsilverwrx View Post
^ that's not normal? I'm pretty sure my car does that in ACC as well.
i agree, i think thats what mine does.

i'll text you a pic if you want man.
besthaticouldo is online now   Reply With Quote
Old 07-09-2013, 11:37 PM   #21374
enmvaldez
Scooby Newbie
 
Member#: 315326
Join Date: Apr 2012
Chapter/Region: Tri-State
Location: long island ny
Vehicle:
2011 Impreza wrx
obp

Default

Quote:
Originally Posted by JSchell1309 View Post
This is going in here because I don't want to start a new thread and I need a quick answer. I installed a new radio (Pioneer AVIC-X9310BT) which is the Canadian option for a '12 and '13 STI. I ordered the Pioneer harness to plug and play with my 2011 STI harness. There were a few unused plugs, but I made sure to use the ground plug on the radio bracket. Now my dash lights up like this when I have the key in the accessory position. Once I start it everything goes away. Just wondering if this is a faulty ground, or one of the plugs I didn't use is causing this.

Thats normal its a way for you to make sure the light bulb on each light in operational.
enmvaldez is offline   Reply With Quote
Old 07-09-2013, 11:42 PM   #21375
Overland04
Scooby Specialist
 
Member#: 293311
Join Date: Sep 2011
Chapter/Region: NESIC
Location: Coast of Maine
Vehicle:
2011 WRX Limited
Satin White Pearl

Default

ACC should only turn the radio on NOT the ignition and dash lights. Your radio is back powering the ignition, not good.
PM me for details but for now, unplug the radio before you burn something out.
Overland04 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
('11-'14) 2011-2012 wrx/sti picture thread (for real this time) guamanian_powered Impreza Forum 151 04-29-2014 09:35 AM
01-07 wrx and sti drivetrain? xj bmx Newbies & FAQs 13 01-26-2012 04:30 PM
('11-'14) 2011 wrx/sti picture thread (for real this time) guamanian_powered Impreza Forum 1 11-17-2011 12:51 AM
Anyone have the 06-07 Impreza WRX and STI master part number and picture list STEALTH-WRX Interior & Exterior Modification 0 08-22-2008 03:12 PM
The Official World One STI and SEMA picture thread.. WorldOne Member's Car Gallery 25 11-29-2003 06:21 PM


All times are GMT -4. The time now is 02:52 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.