Welcome to the North American Subaru Impreza Owners Club Saturday October 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning > AccessPort

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-26-2012, 07:31 PM   #1
05wrx89
Scooby Newbie
 
Member#: 274159
Join Date: Feb 2011
Chapter/Region: MAIC
Location: manassas va
Vehicle:
06 sti
obp

Default Cobb ap ecu reset

Have a 06 sti
Mods are:
Turbo xs catted downpipe
Full turbo xs exhaust
Cobb sf intake
Aps 50/50 bov

Currently running Cobb stage 2 map

Problem:
One day I was checking to see if I had any codes just to make sure and accidentally hit reset ecu (just wasn't paying attention) and ever since that timing has been a issue such as....

Dynamic advance multiplier (.6)
And I believe it was knock feed back (-2.1)

Prior before resetting the ecu car was perfect

Dam (1.0)
Knock feedback (0)
No matter what gear it always read the same but I always focused on d.a.m

Could this just be the ecu relearning everything still or could I be having issues after the reset

All helpful input would be greatly appreciative
* Registered users of the site do not see these ads.
05wrx89 is offline   Reply With Quote
Old 01-26-2012, 10:17 PM   #2
Cobb Tuning
NASIOC Vendor
 
Member#: 4803
Join Date: Mar 2001
Location: Austin, DFW, Portland, SOCAL
Default

Quote:
Originally Posted by 05wrx89 View Post
Have a 06 sti
Mods are:
Turbo xs catted downpipe
Full turbo xs exhaust
Cobb sf intake
Aps 50/50 bov

Currently running Cobb stage 2 map

Problem:
One day I was checking to see if I had any codes just to make sure and accidentally hit reset ecu (just wasn't paying attention) and ever since that timing has been a issue such as....

Dynamic advance multiplier (.6)
And I believe it was knock feed back (-2.1)

Prior before resetting the ecu car was perfect

Dam (1.0)
Knock feedback (0)
No matter what gear it always read the same but I always focused on d.a.m

Could this just be the ecu relearning everything still or could I be having issues after the reset

All helpful input would be greatly appreciative
There may be one of two possibilities here:
1. You had a different real-time map flashed than the base map and resetting the ECU cleared the real-time map and therefore the base map tune is now the "complete" tune and that tune is not working as well as the base + real-time you had before. This is an easy check. If this is a v2 AP, then simply go to Tune -> Show current map and make sure it is the correct map for your mods and octane of gas.

2. Resetting the ECU cleared the learned parameters which were accounting for a mechanical issue that your car had. An example would be the long-term fuel trims accounting for a lean issue.

If you have a v2 AP, the best thing you can do is to get a data log:

Bill
Cobb Tuning is offline   Reply With Quote
Old 01-26-2012, 10:39 PM   #3
05wrx89
Scooby Newbie
 
Member#: 274159
Join Date: Feb 2011
Chapter/Region: MAIC
Location: manassas va
Vehicle:
06 sti
obp

Default

I checked current map and I'm running the stage 2 map 93 oct same map as I've been running prior before the reset

Is it possible that the ecu adapted to my slow driving or what should u reset it again and throw it in 4th gear at 2500rpm and see what happens
05wrx89 is offline   Reply With Quote
Old 01-26-2012, 10:54 PM   #4
Cobb Tuning
NASIOC Vendor
 
Member#: 4803
Join Date: Mar 2001
Location: Austin, DFW, Portland, SOCAL
Default

Quote:
Originally Posted by 05wrx89 View Post
I checked current map and I'm running the stage 2 map 93 oct same map as I've been running prior before the reset

Is it possible that the ecu adapted to my slow driving or what should u reset it again and throw it in 4th gear at 2500rpm and see what happens
No, the DAM should not drop regardless if you are driving like a grandma or going WOT every chance you get. The DAM will drop to an initial value after you reflash a map or reset the ECU. That initial value isn't an indication of knock, but for your car and that particular map, it should start out at 0.5 (same as the factory initial) and jump up in steps of 0.25 until it reaches 1.0 (assuming it doesn't see any knock when it is actively learning). So, a value of 0.6 indicates it dropped at some point.

A lot of the learning functions occur with moderate closed loop driving. This is the case with long term fuel trims and would be the most likely learning function that could cause problems if reset. For example, it may have learned to add 10% fuel due to a mechanical problem with your car that is causing a lean condition (intake leak, bad MAF, etc). So, when you reset the ECU, now your car is running lean again. Best way to check these is to drive for about a week (normal cruise-type driving) and then check your A/F Learning 1 A, B, C, D values via the AP live monitor function (or you can also log them). If any one is outside of +/- 5% you may have a problem and more likely if any one is outside of +/- 8%.

Bill
Cobb Tuning is offline   Reply With Quote
Old 01-27-2012, 12:11 AM   #5
05wrx89
Scooby Newbie
 
Member#: 274159
Join Date: Feb 2011
Chapter/Region: MAIC
Location: manassas va
Vehicle:
06 sti
obp

Default

https://docs.google.com/spreadsheet/...2tjc3UzemJ2c3c

heres my datalog i just did sorry for the long list didnt know how to chop it down but as you would notice the only change im getting is knock learn and a/f correction DAM is not changing what so ever
05wrx89 is offline   Reply With Quote
Old 01-27-2012, 08:26 AM   #6
Cobb Tuning
NASIOC Vendor
 
Member#: 4803
Join Date: Mar 2001
Location: Austin, DFW, Portland, SOCAL
Default

Quote:
Originally Posted by 05wrx89 View Post
https://docs.google.com/spreadsheet/...2tjc3UzemJ2c3c

heres my datalog i just did sorry for the long list didnt know how to chop it down but as you would notice the only change im getting is knock learn and a/f correction DAM is not changing what so ever
You'll want to reset your logging list to the default setting as just those 5 parameters aren't enough to determine anything. You also want to put the car under some heavy load (if you can do safely) while logging as per the logging video posted earlier. This will tell us how the car reacts under more extreme conditions.

Bill
Cobb Tuning is offline   Reply With Quote
Old 01-27-2012, 09:52 AM   #7
05wrx89
Scooby Newbie
 
Member#: 274159
Join Date: Feb 2011
Chapter/Region: MAIC
Location: manassas va
Vehicle:
06 sti
obp

Default

Well today I reflashed to stage 2 again and about a min of driving it went straight to 1 on dam a/f reading normal feedback knock reading 0 I am going to log it after work and pull it in my shop just to double check all vacuum hoses and soon to get rid of my bov ants buy the xle bpv from cobb
05wrx89 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cobb AP not resetting engine code 08 STI MagikMuzik AccessPort 9 04-02-2010 11:39 AM
Cobb AP ECU reset mostasz AccessPort 2 06-01-2008 09:45 PM
Bay Area: MY04 EcuTek WRX ECU trade for Cobb AP ECU mcdrama Private 'Wanted' Classifieds 1 11-21-2005 02:24 PM
FT: '04 STi Ecutek ECU for '04 STi Cobb AP + ECU ninjaboy76 Private 'For Sale' Classifieds 8 09-29-2005 12:25 AM
Question about Cobb Stage1 / ECU reset Triton05 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 2 05-01-2005 11:37 AM


All times are GMT -4. The time now is 04:43 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.