Welcome to the North American Subaru Impreza Owners Club Wednesday November 26, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Alaskan Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Alaskan Impreza Club Forum -- AKIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-29-2012, 12:52 PM   #1
Dreez
Scooby Newbie
 
Member#: 304052
Join Date: Dec 2011
Vehicle:
2010 WRX
Black

Default Car is Shaking BAD!

WHile driving down the Glen yesterday cruising about 60, my car was shaking really bad. Any thoughts to this? Only mods are turbo back exhaust and Cobb Ap.
* Registered users of the site do not see these ads.
Dreez is offline   Reply With Quote
Old 01-29-2012, 01:17 PM   #2
granny
Scooby Specialist
 
Member#: 283145
Join Date: May 2011
Chapter/Region: SWIC
Location: Avondale, Arizona
Vehicle:
1997 LEGASTi Wagon
PowerflexUSA-@grannywagon

Default

First thing you might want to check is your wheels. Make sure they're clean. If you have stuff built up in them it will do that.
granny is offline   Reply With Quote
Old 01-29-2012, 02:03 PM   #3
Nomadgene
Scooby Guru
 
Member#: 22923
Join Date: Aug 2002
Chapter/Region: International
Location: above 8000 rpm!
Vehicle:
2002 EJ207 V8 1.5xtr
TWIN-SCROLL Black Bugeye

Default

not nearly as severe.

Last edited by Nomadgene; 07-05-2012 at 01:36 PM.
Nomadgene is offline   Reply With Quote
Old 01-29-2012, 02:05 PM   #4
Wes_FSTGDB
Scooby Specialist
 
Member#: 59400
Join Date: Apr 2004
Chapter/Region: AKIC
Location: Anchorage, AK
Vehicle:
2013 335XI MSport
2008 BMW 335XI Space Grey

Default

Quote:
Originally Posted by Nomadgene View Post
Snow and ice buildup in your wheel wells is most likely the cause. If you were doing doughnuts in a parking lot or driving in deep snow and it freezes in there, it will cause that to happen.

A wheel weight getting thrown off can cause a shudder too but not nearly as severe.
Plus 100, even after spraying off the bimmer I still had this issue. It's a hit in miss, especially when it's this cold. But I'm sure snow and ice in your wheels is the issue. Doesn't take much to throw it off.
Wes_FSTGDB is offline   Reply With Quote
Old 01-29-2012, 03:31 PM   #5
AKRS
Scooby Newbie
 
Member#: 153687
Join Date: Jul 2007
Chapter/Region: AKIC
Location: Anchorage, Alaska
Vehicle:
2002 Black RS

Default

Best thing to do is park it in a garage to melt down.
AKRS is offline   Reply With Quote
Old 01-29-2012, 06:20 PM   #6
Rookie J
Scooby Specialist
 
Member#: 281747
Join Date: May 2011
Chapter/Region: AKIC
Location: Anchorage
Vehicle:
2005 Legacy GT Wagon
Element Sponsored

Default

Quote:
Originally Posted by AKRS
Best thing to do is park it in a garage to melt down.
Second this. I'm doing this as we speak
Rookie J is offline   Reply With Quote
Old 01-29-2012, 07:23 PM   #7
Dreez
Scooby Newbie
 
Member#: 304052
Join Date: Dec 2011
Vehicle:
2010 WRX
Black

Default

Thanks guys. When I pulled in the garage to Defrost, there was a
lot of let over water. Most likely the issue.
Dreez is offline   Reply With Quote
Old 01-29-2012, 11:11 PM   #8
JCharron2005
Scooby Specialist
 
Member#: 180365
Join Date: May 2008
Chapter/Region: AKIC
Location: Anchorage, Alaska
Vehicle:
2015 STI Limited
Darkness

Default

must be nice to have a garage
JCharron2005 is offline   Reply With Quote
Old 01-29-2012, 11:36 PM   #9
tribalwrx
Scooby Specialist
 
Member#: 32993
Join Date: Feb 2003
Chapter/Region: AKIC
Location: anchorage,alaska
Vehicle:
vf39 Best trap 110
Best ET 12.51 Dale tuned

Default

I usually just take it to the do it yourself car wash and blast the wheels and wheel wells out seems to work for me everytime
tribalwrx is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
I need help, car is shaking above like 75mph, prodrive springs installed StealthfishWRX Brakes, Steering & Suspension 6 07-05-2005 02:40 AM
why waxing your car is a bad idea gotwrx General Community 8 11-12-2002 06:31 PM
car is smoking bad :( DarthChicken Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 22 07-10-2002 05:55 PM
Car is shaking like a leaf! Yebisu69 Normally Aspirated Powertrain 3 05-31-2002 03:49 AM
Help, my car is shaking! suby2002 Newbies & FAQs 10 04-26-2002 01:59 AM


All times are GMT -4. The time now is 10:33 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.