Welcome to the North American Subaru Impreza Owners Club Monday July 14, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-10-2012, 01:18 PM   #1
CDub0917
Scooby Newbie
 
Member#: 271410
Join Date: Jan 2011
Chapter/Region: NESIC
Location: Mid/Central CT
Vehicle:
2005 LGT Limited
OBP

Default Semi rough idle issue

I just picked up a 2005 LGT Limited, 5 speed manual on monday from a very reputable local used car dealership. ON tuesday i threw a P0302 Code for misfire in cylinder 2, had it fixed on thursday under the dealerships waranty and they replaced the spark plug and coilpack for that cylinder. I picked the car up that night and now (friday) i still feel a random rough idle. It seems to feel like a miss fire because idle will be fine then give a small harder hit and repeat every minute or so, I do not feel any hesitation in the throttle when driving and it feels perfectly fine, only when im at a dead stop it get that random higher hit. Also the car is bone stock. I was thinking about replaceing the other 3 coils and sparkplugs, but looking to see if anyone else has an idea of what it could be.
* Registered users of the site do not see these ads.
CDub0917 is offline   Reply With Quote
Old 02-13-2012, 09:31 AM   #2
CDub0917
Scooby Newbie
 
Member#: 271410
Join Date: Jan 2011
Chapter/Region: NESIC
Location: Mid/Central CT
Vehicle:
2005 LGT Limited
OBP

Default

no other ideas??
CDub0917 is offline   Reply With Quote
Old 02-13-2012, 10:23 AM   #3
integra_drk
Scooby Newbie
 
Member#: 117907
Join Date: Jun 2006
Location: Colorado Springs
Vehicle:
95 Legacy Wago

Default

No codes now though? How many miles are on the car/the spark plugs that are in there? Spark plugs would be an easy and cheap thing to try, and if they are bad, it would make sense if it isn't throwing a CEL anymore.
integra_drk is offline   Reply With Quote
Old 02-13-2012, 04:39 PM   #4
CDub0917
Scooby Newbie
 
Member#: 271410
Join Date: Jan 2011
Chapter/Region: NESIC
Location: Mid/Central CT
Vehicle:
2005 LGT Limited
OBP

Default

code is still being thrown right now, the spark plug and coil pack for cylinder 2 are brand new, others im not so sure about, most likely original im guessing
CDub0917 is offline   Reply With Quote
Old 02-14-2012, 11:20 AM   #5
integra_drk
Scooby Newbie
 
Member#: 117907
Join Date: Jun 2006
Location: Colorado Springs
Vehicle:
95 Legacy Wago

Default

Well if the code is still being thrown, why did they give you the car back? Or did it come on after you got it back? If it is under warranty and the code is still on, I wouldn't waste any of your own time trying to diagnose it. Take it back and have them fix it right, that's what the warranty is for.
integra_drk is offline   Reply With Quote
Old 02-15-2012, 09:29 AM   #6
CDub0917
Scooby Newbie
 
Member#: 271410
Join Date: Jan 2011
Chapter/Region: NESIC
Location: Mid/Central CT
Vehicle:
2005 LGT Limited
OBP

Default

Code came on after i got it back, and its one of those 30 day warranty things from a used car dealership and the dont seem to do the best work just throw something in hope it fixes it and call it day, so i want to know for my own satisfaction
CDub0917 is offline   Reply With Quote
Old 02-15-2012, 11:20 AM   #7
Pastor_JW
Scooby Newbie
 
Member#: 296966
Join Date: Oct 2011
Location: Washington
Vehicle:
2010 LGT Limited
Silver

Default

Sounds like a head gasket to me. A compression test would be in order.
Pastor_JW is offline   Reply With Quote
Old 02-15-2012, 11:00 PM   #8
Mezkin83@gmail.com
Scooby Newbie
 
Member#: 258944
Join Date: Sep 2010
Default

Had an 05 legacy gt automatic had same problem as u. took it to the dealer changed the spark plugs little after got it back did the same thing took it back n they had to change the whole fuel injecter system lucky had the factory warr
Mezkin83@gmail.com is offline   Reply With Quote
Old 02-17-2012, 04:17 PM   #9
CDub0917
Scooby Newbie
 
Member#: 271410
Join Date: Jan 2011
Chapter/Region: NESIC
Location: Mid/Central CT
Vehicle:
2005 LGT Limited
OBP

Default

Well compression test done and all 4 cylinders read 120Psi. Swapped out a new injector into cylinder 2 and bam, problem solved. =) Glad to have gotten the car back last night with no issues, running much better than before, good thing they did all the work under waranty. Almost a grand after parts and labor!! (They charge $99/hour labor...)
CDub0917 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting/stalling and rough idle issues Samirr76 Normally Aspirated Powertrain 9 02-11-2011 10:38 AM
2006 Impreza 2.5i Power/rough idle issue subarumafia700 Normally Aspirated Powertrain 3 02-22-2010 07:46 PM
stalling and rough idling issue nJDMmaster Factory 2.0L Turbo Powertrain 9 08-20-2008 11:46 AM
Rough idle issue solved via TSB sticky!!! Gregmatic Baja Forum 0 03-07-2006 11:49 PM
help/comments w/rough idle issues? Benjamin Tang Legacy Forum 14 10-01-2003 05:55 AM


All times are GMT -4. The time now is 12:49 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.