Welcome to the North American Subaru Impreza Owners Club Sunday May 24, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Alaskan Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Alaskan Impreza Club Forum -- AKIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-12-2012, 02:18 AM   #1
fightnhawaiian
Scooby Newbie
 
Member#: 299648
Join Date: Nov 2011
Location: Alaska
Vehicle:
05 Sti
Cgm

Default Fuse box location

Can anybody tell me where the fuse for the o2 sensor is. There is a hidden box under the glove box somewhere but I cant find it
* Registered users of the site do not see these ads.
fightnhawaiian is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 02-12-2012, 02:26 AM   #2
Ethan_Drift
Scooby Specialist
 
Member#: 264930
Join Date: Nov 2010
Chapter/Region: AKIC
Location: South Anchorage
Vehicle:
2011 GT, Evo 8
White

Default

I don't think the O2 sensor has a specific fuse. What makes you think that it's blown, if it does? Also, what type of car?
Ethan_Drift is offline   Reply With Quote
Old 02-12-2012, 02:56 AM   #3
fightnhawaiian
Scooby Newbie
 
Member#: 299648
Join Date: Nov 2011
Location: Alaska
Vehicle:
05 Sti
Cgm

Default

I've checked the sensor and wires, but I've read to also check the fuse...I keep throwing a code and I wanted to try that before buying a new sensor...car is a 05 sti
fightnhawaiian is offline   Reply With Quote
Old 02-12-2012, 03:06 AM   #4
Ethan_Drift
Scooby Specialist
 
Member#: 264930
Join Date: Nov 2010
Chapter/Region: AKIC
Location: South Anchorage
Vehicle:
2011 GT, Evo 8
White

Default

I don't think there is a fuse seeing how both O2 sensors are controlled by the ECM.
Ethan_Drift is offline   Reply With Quote
Old 02-12-2012, 03:33 AM   #5
fightnhawaiian
Scooby Newbie
 
Member#: 299648
Join Date: Nov 2011
Location: Alaska
Vehicle:
05 Sti
Cgm

Default

http://www.iwsti.com/forums/2-5-lite...g-fuses-3.html

Here is a link from what I was reading
fightnhawaiian is offline   Reply With Quote
Old 02-12-2012, 03:36 AM   #6
coldfiremx
Scooby Specialist
 
Member#: 285848
Join Date: Jun 2011
Chapter/Region: AKIC
Location: Butte/Palmer
Vehicle:
2002 WRX
Black

Default

Quote:
Originally Posted by fightnhawaiian
Can anybody tell me where the fuse for the o2 sensor is. There is a hidden box under the glove box somewhere but I cant find it
I don't know for sure if the HO2 has its own fuse on your car but the only reason would be for the heater. Some cars have a seperate fuse for the heater, some use the ECM fuse. More than likely if your complaint is an HO2 heater code, the sensor will need to be replaced.
coldfiremx is offline   Reply With Quote
Old 02-12-2012, 03:45 AM   #7
fightnhawaiian
Scooby Newbie
 
Member#: 299648
Join Date: Nov 2011
Location: Alaska
Vehicle:
05 Sti
Cgm

Default

I figured I would try and check everything before buying a new one
fightnhawaiian is offline   Reply With Quote
Old 02-14-2012, 02:57 PM   #8
P3Auto
Former Vendor
 
Member#: 241881
Join Date: Mar 2010
Chapter/Region: AKIC
Location: 907-355-6655 text or phone
Vehicle:
2014 P3 Import Auto
AWD Dyno, Mods, etc

Default

It has a fuse for the heater. If the heater fuse blew then it is probably shorted.

Check bus fuse #5 "under the hood fuse box"
P3Auto is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
building a fuse box, what fuses for what?? traction issuez Electrical & Lighting 3 05-27-2009 11:42 PM
98 impreza fuse panel location XLR8_HFX Electrical & Lighting 3 01-11-2007 06:23 PM
Fuse Box Pocket mhanch Newbies & FAQs 4 12-17-2001 11:31 PM
Fuse Box Wiring - MY01 Impreza Safir General Forum Archive 0 04-02-2001 07:34 PM


All times are GMT -4. The time now is 06:36 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.