Welcome to the North American Subaru Impreza Owners Club Friday August 29, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Pre-2002 Factory Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-12-2012, 04:08 AM   #1
ncarn8
Scooby Specialist
 
Member#: 71419
Join Date: Sep 2004
Default Misfire at WOT under 4500 rpm?

I can floor it in 1st gear and all is well. But whn i shift to second, and wide open throttle, it will misfire. At any revs, in 2nd gear.
If i ease in the throttle as revs rise i can go floor it again over 5k rpm and its fine.
Have changed plugs, coilpack.
Car is EJ205 with JDM STI computer conversion, VF28, FMIC, Silicon intakes, Walbro.
I cant for the life of me figure out why it will misfire, usually in second, if you go to wot under 4500rpm.
Any help please!!
edit - boost gauge connected to turbo outlet, shows 10-11 psi.
Doesnt really go as well as it should.
* Registered users of the site do not see these ads.

Last edited by ncarn8; 02-12-2012 at 04:15 AM.
ncarn8 is offline   Reply With Quote
Old 02-12-2012, 11:54 AM   #2
pmugabi
Scooby Newbie
 
Member#: 280926
Join Date: Apr 2011
Default

If you're running an EJ205 with it's correct ECU, then this should have been posted under the Factory 2.0L Turbo powertrain forum.

Since you've changed plugs and coilpacks, another possibility is that the car might be running lean under 4500rpm and hence misfiring. Have you ever logged AFRs on it? The 2002+ ECUs have fairly good diagnosis capabilities, try pulling the codes and see if any error codes have been stored.
pmugabi is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hesitation at wot from 4000+ rpm MTL_SLVR_WRX Factory 2.0L Turbo Powertrain 22 11-21-2013 09:30 AM
Boost bounce at WOT under load ZekeTheSneak Factory 2.5L Turbo Powertrain 26 10-27-2011 04:47 PM
02 wrx hybrid bogging/hesitation at wot around 4400 rpms help!! STiGuy23 Built Motor Discussion 50 10-31-2009 11:41 AM
bogging/hesitation at wot around 4400 rpms help STiGuy23 Factory 2.0L Turbo Powertrain 0 09-20-2009 08:52 PM
Car is making screetching noise at WOT around 4k rpms... All4bSpinnin Factory 2.5L Turbo Powertrain 42 10-23-2007 09:05 PM


All times are GMT -4. The time now is 02:45 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.