Welcome to the North American Subaru Impreza Owners Club Tuesday September 16, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Pre-2002 Factory Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-13-2012, 02:58 AM   #1
eg33GC
Scooby Specialist
 
Member#: 206851
Join Date: Mar 2009
Chapter/Region: MWSOC
Vehicle:
99 V4
EJ20K RS

Default 30+ psi on a td05 16g ej20g

And it survived.
Thought I'd share with you my not so cool story,bro, of hitting 30 something tonight with my G.

I fabricated an external wastegate setup for my G, and in haste did not correctly plumb the pressure source line. The unit was an MVS, with a new diaphragm design, compared to familiar older gates. This was completely my impatience and lack of concern.

Did a 2nd gear pull, and about 3500, I was hitting my autometer's peg at 30. The car accelerated roughly from 25-60mph before I glanced at it.
Freaked, and replumbed the gate.

Engine runs great, no adverse affects. I have not inspected the oil, but I put about 10mi on it afterwards, all in vacuum.

I suspect the car had spark blowout before anything detrimental happened. I am running roughly 10.9:1 at the last cells of the map at 18.2psi, with 29* of available timing, on pump gas. I wonder what the afr looked like past 20.
Oh, the turbo decided that it didn't want the intercooler to stay on, so it blew the ic off the tb!
Boost gauge is near new, so this is not a fluke.
* Registered users of the site do not see these ads.
eg33GC is offline   Reply With Quote
Old 02-13-2012, 09:22 AM   #2
suberdave
NASIOC Supporter
 
Member#: 101865
Join Date: Nov 2005
Chapter/Region: NWIC
Location: Covington, WA
Vehicle:
88 GL-10 STi
silver

Default

I did that once on my EJ20G TDO5 16G.

just got a new boost controler, set it wrong, did a pull getting on the freeway. it hit 2.1 bar. (boost controler stores peek boost)

all was well. now if you did that more than once or twice, i dont think it would like it much...

-=Suberdave=-
www.suberdave.com
suberdave is offline   Reply With Quote
Old 02-13-2012, 01:39 PM   #3
Aphex28
Scooby Specialist
 
Member#: 11506
Join Date: Oct 2001
Chapter/Region: NESIC
Location: Manchester, NH
Vehicle:
2015 WRX
World Rally Blue+TE37-TA

Default

you must have bumped the turbo button by mistake!
Aphex28 is offline   Reply With Quote
Old 02-14-2012, 01:00 PM   #4
dangerousatom
Scooby Specialist
 
Member#: 70710
Join Date: Sep 2004
Chapter/Region: Tri-State
Location: Quakertown/AREA1320 391whp
Vehicle:
2002 04STi Swaped RS
w/PPGS & 02 Wagon w/PPGs

Default

Like dave said I would not worry on it too much if you have things fixed now and the boost spike was only momentary.
When I first go my car tuned the tuner was having a weird boost issue and the easiest way of sourcing the problem was to run the turbo with a locked WG just to see if it was the turbos lack of making boost or other issues. I hit 32psi from the reading on the Utec for maybe 1/4 of a second. I asked him if it was bad to do this and he said ....not for that one time and on a throttle blip as it was. He also said since I didn't have colder plugs at the time the spark blew out more than likely well under 30psi. I tend to believe that because of the huge back fire that shot out the back after I put my foot back on the gas. The car has run fine and strong since then "2006" with a vf39. Now its been retuned with a FP Green for the past 3 years at 20psi with zero issues.

Take all that for what you will
dangerousatom is offline   Reply With Quote
Old 02-14-2012, 02:20 PM   #5
eg33GC
Scooby Specialist
 
Member#: 206851
Join Date: Mar 2009
Chapter/Region: MWSOC
Vehicle:
99 V4
EJ20K RS

Default

I'm really not concerned, I've got faith in these older engines.

It's begging for a nice v7/8 block anyway.
eg33GC is offline   Reply With Quote
Old 02-14-2012, 03:36 PM   #6
dangerousatom
Scooby Specialist
 
Member#: 70710
Join Date: Sep 2004
Chapter/Region: Tri-State
Location: Quakertown/AREA1320 391whp
Vehicle:
2002 04STi Swaped RS
w/PPGS & 02 Wagon w/PPGs

Default

Quote:
Originally Posted by eg33GC View Post
I'm really not concerned, I've got faith in these older engines.

It's begging for a nice v7/8 block anyway.
Keep searching the forums and ebay......

I just picked up a V8 long block motor and big port heads only from a member in UT with under 10k for $1500 shipped! That is a redonkulous deal mind you but under $2000 is a good price fora V7-8 long block
dangerousatom is offline   Reply With Quote
Old 02-14-2012, 04:43 PM   #7
eg33GC
Scooby Specialist
 
Member#: 206851
Join Date: Mar 2009
Chapter/Region: MWSOC
Vehicle:
99 V4
EJ20K RS

Default

That is an impossibly awesome deal.

I wish to keep the G ecu,heads, and especially intake.
eg33GC is offline   Reply With Quote
Old 02-14-2012, 05:42 PM   #8
Aphex28
Scooby Specialist
 
Member#: 11506
Join Date: Oct 2001
Chapter/Region: NESIC
Location: Manchester, NH
Vehicle:
2015 WRX
World Rally Blue+TE37-TA

Default

I may have already brough this up, but I have a version 7 ej207 that spun a bearing available for sale.

I've decided to go back to usdm sti.
Aphex28 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS : Apexi noir, Td05 16g, bunch of EJ20G parts, Sti fuelrails, etc. Socal_WOB_LFDY 1993 - 2001 Impreza Specific Parts 11 05-22-2011 10:59 AM
WTB: ej20g td05 16g or other turbo with 90 degree inlet slava from goshen Private 'Wanted' Classifieds 1 03-31-2008 11:00 AM
WTB: ej20g td05 16g or other turbo with 90 degree inlet slava from goshen Private 'Wanted' Classifieds 0 03-01-2008 10:53 AM
td05 16g off a ej20g, or vf28 turbo spoonfedb18a1 Pre-2002 Factory Turbo Powertrain 39 09-10-2007 04:33 AM


All times are GMT -4. The time now is 01:02 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.