Welcome to the North American Subaru Impreza Owners Club Wednesday November 26, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Texas Impreza Club
Texas Impreza Club Forum sponsored by Gillman Subaru Houston
and Gillman Subaru San Antonio
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Texas Impreza Club Forum -- TXIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Closed Thread
 
Thread Tools Display Modes
Old 02-28-2012, 07:30 AM   #51
m_clark54
Scooby Specialist
 
Member#: 224322
Join Date: Sep 2009
Chapter/Region: TXIC
Location: South TXIC
Vehicle:
2013 WRX Spec Ed
Tangerine Orange

Default

Had maint done yesterday and was, told power steering pump bracket was broken and air filter tabs broken. Told battery needed replaced and needs new tires soon.

So this morning I opened my hood to see. Air filter is sealed correctly, no visible issues. Power steering appears to be fine, but fluid reservoir was loose. Clipped it back into its bracket and everything is fine... now.

Battery was disconnected all weekend so it just needed a little charge. Works fine. Tires had good tread.

I'm glad I told them to hold off on that other stuff. Anything for a dollar.
* Registered users of the site do not see these ads.

Last edited by m_clark54; 02-28-2012 at 12:50 PM.
m_clark54 is offline  
Old 02-28-2012, 11:45 AM   #52
Jester808
Scooby Guru
 
Member#: 166085
Join Date: Dec 2007
Chapter/Region: TXIC
Location: Houston, TX
Vehicle:
2010 STI OBP S.E.
05 FXT Stg.3

Default

^ Sounds about right
Jester808 is offline  
Old 02-28-2012, 06:01 PM   #53
TOI
Scooby Specialist
 
Member#: 238230
Join Date: Feb 2010
Chapter/Region: TXIC
Location: Sherman, Texas
Vehicle:
98 impreza sedan

Default

made a new EGR block off plate, the old one was warped and causing my no idle issues. so now my car does idle, still idles rough and low, and still dies alot.
TOI is online now  
Old 02-29-2012, 06:44 PM   #54
Davenow
Scooby Guru
 
Member#: 23676
Join Date: Aug 2002
Chapter/Region: NESIC
Location: de_dust and Orgrimar
Vehicle:
.

Default

Relocated my battery to the trunk.

I need to flip the battery around to make the wire cleaner and tucked. This is just quickly put in for a test drive to make sure its solid.

It is. I am very happy with it.


And no, I wont have any problems at the drag strip. San Antonio raceway could give a flying ****.

Its also in there ROCK solid, there are 4 Grade8 bolts holding it down with 1" washers under and over. You would rip the floor out of the trunk before you would dislodge that battery tray.

I put it on the drivers side because I wanted to keep my shaker1000 sub. I put it sideways because, well **** it why not.

I used this kit
http://www.summitracing.com/parts/TAY-48000/
Which I got from the local speed shop.


Impressions
Well, dont expect the world. But, the nose definitely seems to come up a bit more freely, and again, wheelspin is a touch better. At least more easily modulated off the line. For 90 bucks I am extremely happy.


I am going to put a fuse on that battery line here as soon as I figure out what I want.
Davenow is offline  
Old 03-01-2012, 06:43 PM   #55
Davenow
Scooby Guru
 
Member#: 23676
Join Date: Aug 2002
Chapter/Region: NESIC
Location: de_dust and Orgrimar
Vehicle:
.

Default

Just washed it real good, and did a light detail under the hood for Cobb austin first thursday.


Its also misting out. If its raining I am staying home with my nice clean dry car.
Davenow is offline  
Old 03-01-2012, 07:14 PM   #56
oakcliff
Scooby Specialist
 
Member#: 273767
Join Date: Feb 2011
Chapter/Region: TXIC
Location: Dallas Texas
Vehicle:
2011 WRX
Red

Default

Had it towed to Sewell Subaru because my clutch went out 40 miles from home. Just in time for the Hill Country Cruise.

Now its time for warranty roulette!

FML
oakcliff is offline  
Old 03-01-2012, 08:14 PM   #57
Davenow
Scooby Guru
 
Member#: 23676
Join Date: Aug 2002
Chapter/Region: NESIC
Location: de_dust and Orgrimar
Vehicle:
.

Default

Quote:
Originally Posted by oakcliff View Post
Had it towed to Sewell Subaru because my clutch went out 40 miles from home. Just in time for the Hill Country Cruise.

Now its time for warranty roulette!

FML

SURVEY SAYS!!???
























DENIED!!!
Davenow is offline  
Old 03-01-2012, 08:26 PM   #58
oakcliff
Scooby Specialist
 
Member#: 273767
Join Date: Feb 2011
Chapter/Region: TXIC
Location: Dallas Texas
Vehicle:
2011 WRX
Red

Default

Quote:
Originally Posted by Davenow

SURVEY SAYS!!???

DENIED!!!
Most likely outcome
oakcliff is offline  
Old 03-01-2012, 08:48 PM   #59
TOI
Scooby Specialist
 
Member#: 238230
Join Date: Feb 2010
Chapter/Region: TXIC
Location: Sherman, Texas
Vehicle:
98 impreza sedan

Default

remembered i drive a front wheel drive subaru....
TOI is online now  
Old 03-01-2012, 10:25 PM   #60
TOI
Scooby Specialist
 
Member#: 238230
Join Date: Feb 2010
Chapter/Region: TXIC
Location: Sherman, Texas
Vehicle:
98 impreza sedan

Default

oh and i tried driving up a hill and my check engine light came on again. it seems to do that alot when i'm under a load
TOI is online now  
Old 03-02-2012, 02:20 PM   #61
oakcliff
Scooby Specialist
 
Member#: 273767
Join Date: Feb 2011
Chapter/Region: TXIC
Location: Dallas Texas
Vehicle:
2011 WRX
Red

Default

Quote:
Originally Posted by oakcliff
Had it towed to Sewell Subaru because my clutch went out 40 miles from home. Just in time for the Hill Country Cruise.

Now its time for warranty roulette!

FML
They are covering under warranty

Big thanks to Bryan at Sewell!!
oakcliff is offline  
Old 03-02-2012, 07:58 PM   #62
Davenow
Scooby Guru
 
Member#: 23676
Join Date: Aug 2002
Chapter/Region: NESIC
Location: de_dust and Orgrimar
Vehicle:
.

Default

Nice!
Davenow is offline  
Old 03-02-2012, 11:01 PM   #63
8thWonder
Scooby Specialist
 
Member#: 230366
Join Date: Nov 2009
Chapter/Region: TXIC
Location: Nashville, TN
Vehicle:
2005 STi
it's motor buildin' time!

Default

finalllly got it washed. about to go vacuum the interior and remove the front lip to prepare for the Hill Country cruise tomorrow
8thWonder is offline  
Old 03-03-2012, 05:26 AM   #64
8thWonder
Scooby Specialist
 
Member#: 230366
Join Date: Nov 2009
Chapter/Region: TXIC
Location: Nashville, TN
Vehicle:
2005 STi
it's motor buildin' time!

Default

wired up the wideband gauge and installed it into the blank Subtle Solutions ashtray bezel, further growing the nest of wires in my dash.
8thWonder is offline  
Old 03-03-2012, 06:14 PM   #65
TheTallOne
Scooby Newbie
 
Member#: 302855
Join Date: Dec 2011
Chapter/Region: TXIC
Location: TNA Performance Houston
Vehicle:
2008 WRX
DGM/CF

Default

New toys, cosworth tgv deletes. Can't wait for the intake manifold to get here so I can start polishing.

TheTallOne is offline  
Old 03-04-2012, 01:33 AM   #66
aznburn210
Scooby Specialist
 
Member#: 84062
Join Date: Mar 2005
Chapter/Region: TXIC
Location: South Austin
Vehicle:
2005 WRX
CGM on obnoxious Greennnn

Default

Installed my clutchmasters fx300 clutch and act flywheel. Feels good! Let the break-in begin
aznburn210 is offline  
Old 03-04-2012, 02:04 AM   #67
RustyHinge
Scooby Specialist
 
Member#: 299742
Join Date: Nov 2011
Chapter/Region: TXIC
Location: Houston, Texas
Vehicle:
2007 STI Limited#382
07 WRB STI sold 9/28/12

Default

Added my first decal.... I'm from Washington state, now living in Houston.

RustyHinge is offline  
Old 03-04-2012, 02:05 AM   #68
RustyHinge
Scooby Specialist
 
Member#: 299742
Join Date: Nov 2011
Chapter/Region: TXIC
Location: Houston, Texas
Vehicle:
2007 STI Limited#382
07 WRB STI sold 9/28/12

Default

Quote:
Originally Posted by TheTallOne
New toys, cosworth tgv deletes. Can't wait for the intake manifold to get here so I can start polishing.
I want these!
RustyHinge is offline  
Old 03-04-2012, 02:29 AM   #69
Dka67
Scooby Specialist
 
Member#: 296721
Join Date: Oct 2011
Chapter/Region: SCIC
Location: Montebello
Vehicle:
11 5door
SWP

Default

Not today, but yesterday! Installed Perrin front 25 and rear 22 sway bars, and KartBoy Endlinks. Also installed KartBoy front and rear shifter bushings. Great upgrades!!!
Dka67 is offline  
Old 03-04-2012, 03:48 AM   #70
Jester808
Scooby Guru
 
Member#: 166085
Join Date: Dec 2007
Chapter/Region: TXIC
Location: Houston, TX
Vehicle:
2010 STI OBP S.E.
05 FXT Stg.3

Default

Flushed and replaced the fluid in the power steering, transmission, and diff on the FXT.
Jester808 is offline  
Old 03-04-2012, 10:46 AM   #71
2_fast
Scooby Newbie
 
Member#: 237523
Join Date: Feb 2010
Chapter/Region: TXIC
Location: Joshua, TX
Vehicle:
2008 WRX Wagon
OBP

Default

Installed some new Eibach sways, Centric blank rotors, Hawk HPS pads, Goodridge stainless braided brake lines and flushed the brake fluid with some synthetic. Now need to flush remaining fluids with synthetics and find me some struts (08 WRX anyone???) to install my new Eibach springs as well.
2_fast is offline  
Old 03-04-2012, 11:19 AM   #72
JbibWrx
Scooby Specialist
 
Member#: 203162
Join Date: Feb 2009
Chapter/Region: TXIC
Location: Carrollton
Vehicle:
2005 Wrx
CGM

Default

Quote:
Originally Posted by 2_fast
Installed some new Eibach sways, Centric blank rotors, Hawk HPS pads, Goodridge stainless braided brake lines and flushed the brake fluid with some synthetic. Now need to flush remaining fluids with synthetics and find me some struts (08 WRX anyone???) to install my new Eibach springs as well.
Íhlin is the only way to go on struts. I think that spelling is correct?
JbibWrx is offline  
Old 03-04-2012, 11:31 AM   #73
5lipstream
*** Banned ***
 
Member#: 124663
Join Date: Sep 2006
Chapter/Region: South East
Location: Nashville
Vehicle:
2003 AW WRX
2008 GG Evo X MR

Default

Oops. Wrong thread.

Last edited by 5lipstream; 03-04-2012 at 04:13 PM.
5lipstream is offline  
Old 03-04-2012, 06:39 PM   #74
Damned_Yankee
Scooby Newbie
 
Member#: 278251
Join Date: Mar 2011
Chapter/Region: TXIC
Vehicle:
2008 WRX

Default

Washed and waxed her although she's probably going to get caked in pollen overnight.
Damned_Yankee is offline  
Old 03-04-2012, 07:36 PM   #75
TheTallOne
Scooby Newbie
 
Member#: 302855
Join Date: Dec 2011
Chapter/Region: TXIC
Location: TNA Performance Houston
Vehicle:
2008 WRX
DGM/CF

Default

Raised it 1/2" to keep my new tires from rubbing.
TheTallOne is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
what did you do to your car today? Schrecken Bay Area Impreza Club Forum -- BAIC 11 09-25-2012 04:08 AM
What did you do to your subie today?! 07imprezadrifter General Community 277 06-15-2009 12:42 AM
What did you do to your Scoob today? Sheehan North West Impreza Club Forum -- NWIC 27 11-23-2007 01:02 PM


All times are GMT -4. The time now is 09:14 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.