Welcome to the North American Subaru Impreza Owners Club Friday December 19, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Texas Impreza Club
Texas Impreza Club Forum sponsored by Gillman Subaru Houston
and Gillman Subaru San Antonio
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Texas Impreza Club Forum -- TXIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Closed Thread
 
Thread Tools Display Modes
Old 09-07-2012, 10:44 PM   #1201
MKT_WRX
Scooby Newbie
 
Member#: 326798
Join Date: Jul 2012
Chapter/Region: TXIC
Location: Katy TEXAS
Vehicle:
2012 WRX
SWP

Default

Installed el cheapo fmic
* Registered users of the site do not see these ads.
MKT_WRX is offline  
Old 09-07-2012, 10:59 PM   #1202
atartol
Scooby Newbie
 
Member#: 321926
Join Date: Jun 2012
Chapter/Region: TXIC
Location: League City, Texas
Vehicle:
2007 STI Limited #22
UGM

Default

^^ looks juicy
atartol is offline  
Old 09-08-2012, 02:02 AM   #1203
TOI
Scooby Specialist
 
Member#: 238230
Join Date: Feb 2010
Chapter/Region: TXIC
Location: Sherman, Texas
Vehicle:
98 impreza sedan

Default

Pulled my interior, everything but the headliner, front carpet and front seats. Would have got it all out, but I sliced my finger open and called it a night.
TOI is offline  
Old 09-08-2012, 02:57 AM   #1204
iconone
Scooby Specialist
 
Member#: 174883
Join Date: Mar 2008
Chapter/Region: TXIC
Location: Clear Lake Texas
Vehicle:
2005 CGM WRX
2006 Yamaha R1

Default

-^ why?
iconone is offline  
Old 09-08-2012, 03:19 AM   #1205
Pencils
Scooby Specialist
 
Member#: 152726
Join Date: Jun 2007
Chapter/Region: SCIC
Location: 626/Houston
Vehicle:
The 2003 pwrFAP
thing

Default



i made a mess in the garage
Pencils is offline  
Old 09-08-2012, 03:29 AM   #1206
iconone
Scooby Specialist
 
Member#: 174883
Join Date: Mar 2008
Chapter/Region: TXIC
Location: Clear Lake Texas
Vehicle:
2005 CGM WRX
2006 Yamaha R1

Default

^ Change the oil?
iconone is offline  
Old 09-08-2012, 03:30 AM   #1207
Jester808
Scooby Guru
 
Member#: 166085
Join Date: Dec 2007
Chapter/Region: TXIC
Location: Houston, TX
Vehicle:
2010 STI OBP S.E.
05 FXT Stg.3

Default

Finished up dialing in the Coilovers and installed the wheels and tires...

Jester808 is offline  
Old 09-08-2012, 03:54 AM   #1208
Pencils
Scooby Specialist
 
Member#: 152726
Join Date: Jun 2007
Chapter/Region: SCIC
Location: 626/Houston
Vehicle:
The 2003 pwrFAP
thing

Default

Quote:
Originally Posted by iconone View Post
^ Change the oil?
i snagged my oil lines from the oil cooler
Pencils is offline  
Old 09-08-2012, 04:02 AM   #1209
MKT_WRX
Scooby Newbie
 
Member#: 326798
Join Date: Jul 2012
Chapter/Region: TXIC
Location: Katy TEXAS
Vehicle:
2012 WRX
SWP

Default

Quote:
Originally Posted by Jester808 View Post
Quoted because its worth seeing twice!
MKT_WRX is offline  
Old 09-08-2012, 04:05 AM   #1210
Jester808
Scooby Guru
 
Member#: 166085
Join Date: Dec 2007
Chapter/Region: TXIC
Location: Houston, TX
Vehicle:
2010 STI OBP S.E.
05 FXT Stg.3

Default

Jester808 is offline  
Old 09-08-2012, 10:59 PM   #1211
8thWonder
Scooby Specialist
 
Member#: 230366
Join Date: Nov 2009
Chapter/Region: TXIC
Location: Nashville, TN
Vehicle:
2005 STi
it's motor buildin' time!

Default

Replaced the power steering pump. Thought I was all set, but the ****ing banjo bolt won't seat down properly, so it's spewing fluid everywhere. So frustrated. Gonna try again when it's light outside. Hopefully it just needs a new crush washer.

Last edited by 8thWonder; 09-08-2012 at 11:07 PM.
8thWonder is offline  
Old 09-08-2012, 11:29 PM   #1212
iconone
Scooby Specialist
 
Member#: 174883
Join Date: Mar 2008
Chapter/Region: TXIC
Location: Clear Lake Texas
Vehicle:
2005 CGM WRX
2006 Yamaha R1

Default

^ I bet you are missing the one pice washer.
iconone is offline  
Old 09-08-2012, 11:39 PM   #1213
8thWonder
Scooby Specialist
 
Member#: 230366
Join Date: Nov 2009
Chapter/Region: TXIC
Location: Nashville, TN
Vehicle:
2005 STi
it's motor buildin' time!

Default

Quote:
Originally Posted by iconone
^ I bet you are missing the one pice washer.
I have the washer, if you're talking about the black one that covers both the top and the bottom of the hard line where it meets the banjo bolt.
8thWonder is offline  
Old 09-09-2012, 01:10 PM   #1214
tito sti
Scooby Newbie
 
Member#: 247648
Join Date: May 2010
Default

polished ic pipes
tito sti is offline  
Old 09-09-2012, 01:21 PM   #1215
8thWonder
Scooby Specialist
 
Member#: 230366
Join Date: Nov 2009
Chapter/Region: TXIC
Location: Nashville, TN
Vehicle:
2005 STi
it's motor buildin' time!

Default

^^looks good. interesting placement of the Hella horn, haha.
8thWonder is offline  
Old 09-09-2012, 08:38 PM   #1216
m0nkey
Scooby Newbie
 
Member#: 142325
Join Date: Mar 2007
Chapter/Region: TXIC
Location: Houston
Vehicle:
2002 WRX Wagon
MBP

Default

Finally had time to wash my baby <3


Last edited by m0nkey; 09-09-2012 at 08:44 PM.
m0nkey is offline  
Old 09-10-2012, 01:55 AM   #1217
TOI
Scooby Specialist
 
Member#: 238230
Join Date: Feb 2010
Chapter/Region: TXIC
Location: Sherman, Texas
Vehicle:
98 impreza sedan

Default

Quote:
Originally Posted by iconone
-^ why?
It's heavy, and I need to get too all the cancer on the strut towers, and the dents in the roof for my auto body classes.
TOI is offline  
Old 09-10-2012, 08:22 PM   #1218
gizmotron2030
Scooby Specialist
 
Member#: 145183
Join Date: Apr 2007
Chapter/Region: International
Location: Graf
Vehicle:
2011 BMW M3
Blue

Default

Drove in from NC wednesday night, and I finally gave it a day off today...
gizmotron2030 is offline  
Old 09-10-2012, 08:29 PM   #1219
05subysti
Scooby Specialist
 
Member#: 268190
Join Date: Dec 2010
Chapter/Region: TXIC
Location: central tx
Vehicle:
2005 STi
RWD, 18x10.5/12.5s

Default

Remove tial bov and sold it. Selling my engine setup to build another engine and setup

FP green 8cm 2.4inlet
5-O 1200cc injectors
Ssac fmic
Gimmick inlet
Perrin big maf
05subysti is offline  
Old 09-10-2012, 09:40 PM   #1220
aggie113
Scooby Specialist
 
Member#: 146311
Join Date: Apr 2007
Chapter/Region: TXIC
Location: San Antonio, TX
Vehicle:
Saab '05 HTA68 Built
2.5L E85 6MT > STI :)

Default

Washed it, noticed that the car has at some recent point eating the lower section of fender liner so now my intake is open to all from below
aggie113 is offline  
Old 09-10-2012, 11:15 PM   #1221
TOI
Scooby Specialist
 
Member#: 238230
Join Date: Feb 2010
Chapter/Region: TXIC
Location: Sherman, Texas
Vehicle:
98 impreza sedan

Default

installed my off brand seat in my car. its tight and low, i love the feel.
TOI is offline  
Old 09-11-2012, 07:01 PM   #1222
Kastley85891
Scooby Specialist
 
Member#: 127704
Join Date: Oct 2006
Chapter/Region: TXIC
Location: TX/Austin
Vehicle:
2013 Hybrid
Needs an 05STI

Default

BOSCH icon wiper blade time
New decal LOL and refined my timing curve.
Kastley85891 is offline  
Old 09-11-2012, 08:18 PM   #1223
8thWonder
Scooby Specialist
 
Member#: 230366
Join Date: Nov 2009
Chapter/Region: TXIC
Location: Nashville, TN
Vehicle:
2005 STi
it's motor buildin' time!

Default

Fixed my power steering issues I almost forgot how nice it drives with PS, haha
8thWonder is offline  
Old 09-11-2012, 08:40 PM   #1224
iconone
Scooby Specialist
 
Member#: 174883
Join Date: Mar 2008
Chapter/Region: TXIC
Location: Clear Lake Texas
Vehicle:
2005 CGM WRX
2006 Yamaha R1

Default

^ What was the issue and how did you fix it? I'm having mine wine lightly at a cold start.
iconone is offline  
Old 09-11-2012, 08:53 PM   #1225
8thWonder
Scooby Specialist
 
Member#: 230366
Join Date: Nov 2009
Chapter/Region: TXIC
Location: Nashville, TN
Vehicle:
2005 STi
it's motor buildin' time!

Default

Well my original pump was on its way out, so I found one here on the forums, but then I couldn't get the banjo bolt to seal correctly. Turns out the banjo bolt "receiver" on the pump was stripped out a little bit, so I removed that part from my original pump and put it in the new one. Getting that piece out of the original pump was insanely difficult though. I really needed an industrial vise to hold the pump so I could get the proper torque/leverage, but my manly physique and an hour of cussing got the job done =P
8thWonder is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
what did you do to your car today? Schrecken Bay Area Impreza Club Forum -- BAIC 11 09-25-2012 04:08 AM
What did you do to your subie today?! 07imprezadrifter General Community 277 06-15-2009 12:42 AM
What did you do to your Scoob today? Sheehan North West Impreza Club Forum -- NWIC 27 11-23-2007 01:02 PM


All times are GMT -4. The time now is 11:59 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.