Welcome to the North American Subaru Impreza Owners Club Tuesday September 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Texas Impreza Club
Texas Impreza Club Forum sponsored by Gillman Subaru Houston
and Gillman Subaru San Antonio
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Texas Impreza Club Forum -- TXIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Closed Thread
 
Thread Tools Display Modes
Old 03-31-2012, 08:45 PM   #151
DumbstixLars
Scooby Newbie
 
Member#: 205942
Join Date: Mar 2009
Chapter/Region: TXIC
Location: ATX
Vehicle:
2003 WRX
AW with a ricey hood

Default

Tried to do all four of my rotors and pads today. Unfortunately the front pads that Brakelabs sent me don't fit the car. I did do this though:

* Registered users of the site do not see these ads.
DumbstixLars is offline  
Old 03-31-2012, 10:05 PM   #152
blakkboxer
Scooby Guru
 
Member#: 167244
Join Date: Dec 2007
Chapter/Region: TXIC
Location: DFW, Tx
Vehicle:
2k3 WRX MBP
black & gold is pimpin'

Default

rotella t6 oil change @ 160k
blakkboxer is offline  
Old 03-31-2012, 10:48 PM   #153
oakcliff
Scooby Specialist
 
Member#: 273767
Join Date: Feb 2011
Chapter/Region: TXIC
Location: Dallas Texas
Vehicle:
2011 WRX
Red

Default

Totally didn't race a Maserati Quadraporte
oakcliff is offline  
Old 04-01-2012, 05:56 AM   #154
Jester808
Scooby Guru
 
Member#: 166085
Join Date: Dec 2007
Chapter/Region: TXIC
Location: Houston, TX
Vehicle:
2010 STI OBP S.E.
05 FXT Stg.3|06 LGT Stg.2

Default

Quote:
Originally Posted by DumbstixLars View Post
Tried to do all four of my rotors and pads today. Unfortunately the front pads that Brakelabs sent me don't fit the car. I did do this though:
Damn, overkill much?
Jester808 is offline  
Old 04-01-2012, 01:38 PM   #155
fox_stowe
Scooby Newbie
 
Member#: 300482
Join Date: Nov 2011
Chapter/Region: TXIC
Location: Arlington ,TX
Vehicle:
2007 wrx
Swp

Default

trouble shooting my lack of boost!!
8psi max.
checked bcs with 12v..works/opens and shuts.
bypast wastegate... easily built boost.
car into test mode.. cant feel or hear it clicking.
checked harness. 12volts across both and 12v hot side to ground.

also noticed the bcs lines have been replaced and i am missing the restrictor pill from the compressor to the T fitting.

sucks.
fox_stowe is offline  
Old 04-01-2012, 01:51 PM   #156
blakkboxer
Scooby Guru
 
Member#: 167244
Join Date: Dec 2007
Chapter/Region: TXIC
Location: DFW, Tx
Vehicle:
2k3 WRX MBP
black & gold is pimpin'

Default

Quote:
Originally Posted by fox_stowe
trouble shooting my lack of boost!!
8psi max.
checked bcs with 12v..works/opens and shuts.
bypast wastegate... easily built boost.
car into test mode.. cant feel or hear it clicking.
checked harness. 12volts across both and 12v hot side to ground.

also noticed the bcs lines have been replaced and i am missing the restrictor pill from the compressor to the T fitting.

sucks.
Check your vacuum lines and anything else pre turbo like your y-pipe behind tmic
blakkboxer is offline  
Old 04-01-2012, 02:55 PM   #157
mightymints
Scooby Specialist
 
Member#: 252858
Join Date: Jul 2010
Chapter/Region: TXIC
Location: Pflugerville, Tx
Vehicle:
2015 STi WRB/Gold LE
2013 WRB STi 5dr Stage1AP

Default

Quote:
Originally Posted by oakcliff View Post
Totally didn't race a Maserati Quadraporte
Maserati Quattroporte

Nice cars though!
mightymints is offline  
Old 04-01-2012, 03:03 PM   #158
DumbstixLars
Scooby Newbie
 
Member#: 205942
Join Date: Mar 2009
Chapter/Region: TXIC
Location: ATX
Vehicle:
2003 WRX
AW with a ricey hood

Default

Quote:
Originally Posted by Jester808 View Post
Damn, overkill much?
I just used it to put slight tension on the rotor while I popped it with a hammer and a block of wood. Suckers were seized pretty good to the hubs.
DumbstixLars is offline  
Old 04-01-2012, 03:42 PM   #159
oakcliff
Scooby Specialist
 
Member#: 273767
Join Date: Feb 2011
Chapter/Region: TXIC
Location: Dallas Texas
Vehicle:
2011 WRX
Red

Default

Quote:
Originally Posted by mightymints
Maserati Quattroporte

Nice cars though!
Guilty, made that post several beers after the not race
oakcliff is offline  
Old 04-01-2012, 03:55 PM   #160
TheTallOne
Scooby Newbie
 
Member#: 302855
Join Date: Dec 2011
Chapter/Region: TXIC
Location: TNA Performance Houston
Vehicle:
2008 WRX
DGM/CF

Default

Quote:
Originally Posted by DumbstixLars
Tried to do all four of my rotors and pads today. Unfortunately the front pads that Brakelabs sent me don't fit the car. I did do this though:
2 bolts threaded in the rotors, pb blaster done in 45 secs.
TheTallOne is offline  
Old 04-02-2012, 02:19 PM   #161
DumbstixLars
Scooby Newbie
 
Member#: 205942
Join Date: Mar 2009
Chapter/Region: TXIC
Location: ATX
Vehicle:
2003 WRX
AW with a ricey hood

Default

Quote:
Originally Posted by TheTallOne View Post
2 bolts threaded in the rotors, pb blaster done in 45 secs.
Didn't have any PB blaster. This got the job done just as fast since I own the tool.
DumbstixLars is offline  
Old 04-02-2012, 03:36 PM   #162
bluesonicboomae86
Scooby Newbie
 
Member#: 284297
Join Date: May 2011
Chapter/Region: TXIC
Location: Houston' TX
Vehicle:
2011 Impreza STi
WR Blue

Default

Got rid of the most annoying rattle on my drivers a pillar
bluesonicboomae86 is offline  
Old 04-03-2012, 09:13 AM   #163
02bugeyedimp
Scooby Newbie
 
Member#: 299328
Join Date: Oct 2011
Chapter/Region: TXIC
Vehicle:
2002 outback sport
Silver

Default

Installed Stoptech SS brake lines. I did a drum/disc conversion a few weeks back and had to use an extra 8" of brake line to make it match up while I was waiting for my stoptech lines to come in....FYI bad idea. Gave me crazy front bias (worse then with the drums) and over heated my front rotors so they warped.
I'm lovin' it now tho.
02bugeyedimp is offline  
Old 04-03-2012, 12:30 PM   #164
iconone
Scooby Specialist
 
Member#: 174883
Join Date: Mar 2008
Chapter/Region: TXIC
Location: Clear Lake Texas
Vehicle:
2005 CGM WRX
2006 Yamaha R1

Default

Installed Sti front spats and side strikes. Just a test fit for the side strikes. Now to get my fogs, hood scoop side strikes, rear spats and wingless trunk painted.

iconone is online now  
Old 04-03-2012, 12:58 PM   #165
JbibWrx
Scooby Specialist
 
Member#: 203162
Join Date: Feb 2009
Chapter/Region: TXIC
Location: Carrollton
Vehicle:
2005 Wrx
CGM

Default

Quote:
Originally Posted by iconone
Installed Sti front spats and side strikes. Just a test fit for the side strikes. Now to get my fogs, hood scoop side strikes, rear spats and wingless trunk painted.
Whys it sitting so high? That pics in your fs thread it's dumped compared to this pic!
JbibWrx is offline  
Old 04-03-2012, 01:02 PM   #166
iconone
Scooby Specialist
 
Member#: 174883
Join Date: Mar 2008
Chapter/Region: TXIC
Location: Clear Lake Texas
Vehicle:
2005 CGM WRX
2006 Yamaha R1

Default

Sold the coilovers and bought tokico struts on Perrin springs and group n top hats. I was sick of the coilovers. I did a turbo swap and couldn't drive it the way I wanted too on coilovers.
iconone is online now  
Old 04-03-2012, 01:04 PM   #167
future_subaru_owner
Scooby Specialist
 
Member#: 172939
Join Date: Feb 2008
Chapter/Region: TXIC
Location: Kingwood, TX
Vehicle:
2011 Dodge Ram 3500
2003 Subaru Legacy L..ame

Default

Now your not hardcore. Plain jane
future_subaru_owner is offline  
Old 04-03-2012, 01:17 PM   #168
iconone
Scooby Specialist
 
Member#: 174883
Join Date: Mar 2008
Chapter/Region: TXIC
Location: Clear Lake Texas
Vehicle:
2005 CGM WRX
2006 Yamaha R1

Default

Yep..
iconone is online now  
Old 04-04-2012, 08:20 PM   #169
m0nkey
Scooby Newbie
 
Member#: 142325
Join Date: Mar 2007
Chapter/Region: TXIC
Location: Houston
Vehicle:
2002 WRX Wagon
MBP

Default

I got a surprise from blouch







Rebuilt evo 3 16g I got to excited and I already lost the E clip for the wastegate arm fml.
m0nkey is offline  
Old 04-04-2012, 08:47 PM   #170
TheTallOne
Scooby Newbie
 
Member#: 302855
Join Date: Dec 2011
Chapter/Region: TXIC
Location: TNA Performance Houston
Vehicle:
2008 WRX
DGM/CF

Default

That should be fun.
TheTallOne is offline  
Old 04-04-2012, 10:38 PM   #171
TOI
Scooby Specialist
 
Member#: 238230
Join Date: Feb 2010
Chapter/Region: TXIC
Location: Sherman, Texas
Vehicle:
93 impreza L wagon
mostly black now

Default

put some oil in it... cause i forgot it was a subaru and marked it territory
TOI is offline  
Old 04-05-2012, 03:23 AM   #172
Jester808
Scooby Guru
 
Member#: 166085
Join Date: Dec 2007
Chapter/Region: TXIC
Location: Houston, TX
Vehicle:
2010 STI OBP S.E.
05 FXT Stg.3|06 LGT Stg.2

Default

Sent my AP to COBB to get relicensed.
Jester808 is offline  
Old 04-05-2012, 10:18 AM   #173
aggie113
Scooby Specialist
 
Member#: 146311
Join Date: Apr 2007
Chapter/Region: TXIC
Location: San Antonio, TX
Vehicle:
Saab '05 HTA68 Built
2.5L E85 6MT > STI :)

Default

Put in some e85 this morning, and got the damn brass tip stuck in the gas tank sleve
Had to rip it off the gas can and then dig it out with needle nose plyers
aggie113 is offline  
Old 04-05-2012, 10:39 AM   #174
gian-carlo
Scooby Specialist
 
Member#: 124498
Join Date: Aug 2006
Chapter/Region: TXIC
Location: Houston Tx
Vehicle:
2002 WRB WRX

Default

Stored the engineless 02 WRX till I can get money and time to rebuild it.
gian-carlo is offline  
Old 04-05-2012, 03:52 PM   #175
m0nkey
Scooby Newbie
 
Member#: 142325
Join Date: Mar 2007
Chapter/Region: TXIC
Location: Houston
Vehicle:
2002 WRX Wagon
MBP

Default

Install my area 1320 evo 3 16g external wastegate bracket.
Note i did have to enlarged one of the 12mm bolt holes inorder to make it fit correctly. Then i painted it flat black with vht flameproof. I also went to go buy a new E clip since i lost mines at homedepot

m0nkey is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
what did you do to your car today? Schrecken Bay Area Impreza Club Forum -- BAIC 11 09-25-2012 03:08 AM
What did you do to your subie today?! 07imprezadrifter General Community 277 06-14-2009 11:42 PM
What did you do to your Scoob today? Sheehan North West Impreza Club Forum -- NWIC 27 11-23-2007 12:02 PM


All times are GMT -4. The time now is 12:58 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.