Welcome to the North American Subaru Impreza Owners Club Monday October 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Texas Impreza Club
Texas Impreza Club Forum sponsored by Gillman Subaru Houston
and Gillman Subaru San Antonio
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Texas Impreza Club Forum -- TXIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Closed Thread
 
Thread Tools Display Modes
Old 01-20-2013, 04:40 PM   #2001
05subysti
Scooby Specialist
 
Member#: 268190
Join Date: Dec 2010
Chapter/Region: TXIC
Location: central tx
Vehicle:
2005 STi
RWD, 18x10.5/12.5s

Default

Stripped my Meister faces and wired brushed on face front and back so far.

Mister tanker, be careful with the password jdm o rings they like to crack and become brittle.
* Registered users of the site do not see these ads.

Last edited by 05subysti; 01-20-2013 at 04:47 PM.
05subysti is offline  
Old 01-20-2013, 05:27 PM   #2002
keonigt
Scooby Newbie
 
Member#: 304739
Join Date: Dec 2011
Chapter/Region: HIIC
Location: College student in Portland, O
Vehicle:
2013 WRX premium
DGM

Default

Quote:
Originally Posted by blakkboxer View Post
white LED front parking lights and LED license plate bulbs
What website do you guys normally buy the licence plate bulbs?
keonigt is offline  
Old 01-20-2013, 05:39 PM   #2003
djmoore
Scooby Newbie
 
Member#: 311062
Join Date: Feb 2012
Chapter/Region: TXIC
Location: North Dallas,Texas
Vehicle:
2007 STI
OBP

Default

Installed my walbro fuel pump and replaced the fuel filter. SOA is crazy as **** if they think that filter is going to last the life of the car. Mine was dark brown, and I only have 72,xxxx miles.
djmoore is offline  
Old 01-21-2013, 06:25 AM   #2004
Mister Tanker
Scooby Specialist
 
Member#: 237759
Join Date: Feb 2010
Chapter/Region: TXIC
Location: Houston
Vehicle:
2003 WRX Wagon
Built ej205 478whp 417wtq

Default

Quote:
Originally Posted by 05subysti View Post

Mister tanker, be careful with the password jdm o rings they like to crack and become brittle.
Thanks for the heads up. I was just so tired of those outer bumper clips...
Mister Tanker is offline  
Old 01-21-2013, 12:36 PM   #2005
Smokin' Joe
Scooby Specialist
 
Member#: 219679
Join Date: Aug 2009
Chapter/Region: TXIC
Location: Fort Worth, Texas
Vehicle:
2011 Impreza WRX
WRB

Default

Spark plugs got changed after a friend helped to weld some beefier bolts for the front 2 mounting spots on the skid plate. Redesigned the plate a little as well for better fit/function. Runs strong and confident Fuel filter is going to be this afternoon.
Smokin' Joe is offline  
Old 01-21-2013, 01:06 PM   #2006
SWP is Sexy
Scooby Specialist
 
Member#: 302389
Join Date: Nov 2011
Chapter/Region: TXIC
Location: Houston
Vehicle:
2011 WRX
I'm a stormtrooper pewpew

Default

Was yesterday, but got my aem intake installed and reflashed for stage 2 + aem
SWP is Sexy is offline  
Old 01-21-2013, 07:19 PM   #2007
asianfb10
Scooby Newbie
 
Member#: 338019
Join Date: Nov 2012
Chapter/Region: TXIC
Location: Houston, TX
Vehicle:
2010 Subaru STI
SWP

Default

Today, AEM CAI, Rear Cusco Lateral Links, and Alignment....
asianfb10 is offline  
Old 01-21-2013, 08:25 PM   #2008
8thWonder
Scooby Specialist
 
Member#: 230366
Join Date: Nov 2009
Chapter/Region: TXIC
Location: Nashville, TN
Vehicle:
2005 STi
it's motor buildin' time!

Default

Checked for air leaks, since my AF Correction seems to be all over the place. found a small hole in one of the vacuum lines, a few clamps that weren't quite tight enough, and a lot of air coming out of my Hallman MBC.
I replaced the vacuum line and tightened the clamps, but I'm not sure what to do about the MBC. Has anyone else ever experienced a leak here? There's one o-ring on the controller that keeps air from flowing around the screw top. I guess I'll replace that and hope it's the culprit.
8thWonder is offline  
Old 01-21-2013, 08:49 PM   #2009
Chuck2012
Scooby Newbie
 
Member#: 324568
Join Date: Jun 2012
Chapter/Region: TXIC
Location: San Antonio, tx
Vehicle:
2005 Wrx Sti
OBP

Default

Tried my snap on spray gun out on my sealed subwoofer enclosure.
Chuck2012 is offline  
Old 01-21-2013, 09:14 PM   #2010
TOI
Scooby Specialist
 
Member#: 238230
Join Date: Feb 2010
Chapter/Region: TXIC
Location: Sherman, Texas
Vehicle:
93 impreza L wagon
mostly black now

Default

some kid in a stock honda fit with illest stickers called my wagon cool. does that count?
TOI is offline  
Old 01-21-2013, 09:18 PM   #2011
laxman2001
Scooby Newbie
 
Member#: 268558
Join Date: Dec 2010
Chapter/Region: South East
Location: Charlotte, NC
Vehicle:
2008 STi
OBP

Default

Brake pads arrived. Ordered fog light bulbs.

And made an appointment with Todd.

Last edited by laxman2001; 01-21-2013 at 09:39 PM.
laxman2001 is offline  
Old 01-22-2013, 05:30 PM   #2012
laxman2001
Scooby Newbie
 
Member#: 268558
Join Date: Dec 2010
Chapter/Region: South East
Location: Charlotte, NC
Vehicle:
2008 STi
OBP

Default

Replaced the air filter.

I think it was time:
laxman2001 is offline  
Old 01-22-2013, 07:08 PM   #2013
TOI
Scooby Specialist
 
Member#: 238230
Join Date: Feb 2010
Chapter/Region: TXIC
Location: Sherman, Texas
Vehicle:
93 impreza L wagon
mostly black now

Default

Got rearended in my jeep and did more body work to my wagon.
TOI is offline  
Old 01-22-2013, 07:17 PM   #2014
SilverSpool
Scooby Guru
 
Member#: 55869
Join Date: Feb 2004
Chapter/Region: TXIC
Location: **** Rancid
Vehicle:
BMW / Ducati / Kawa
135i / M796 / ZX6R

Default

Quote:
Originally Posted by TOI View Post
Got rearended in my jeep and did more body work to my wagon.
what you do on your own time...
SilverSpool is offline  
Old 01-22-2013, 10:47 PM   #2015
8thWonder
Scooby Specialist
 
Member#: 230366
Join Date: Nov 2009
Chapter/Region: TXIC
Location: Nashville, TN
Vehicle:
2005 STi
it's motor buildin' time!

Default

^^lol
8thWonder is offline  
Old 01-22-2013, 10:58 PM   #2016
frawlll
Scooby Newbie
 
Member#: 343762
Join Date: Jan 2013
Location: Fort worth
Vehicle:
2011 Subaru WRX STi
Plasma Blue Pearl

Default

I love to go muddin my buddy has 200 acres with some good land to go muddin or just riddin through a BA field
frawlll is offline  
Old 01-22-2013, 11:06 PM   #2017
c_quiasua
Scooby Newbie
 
Member#: 318963
Join Date: May 2012
Chapter/Region: TXIC
Location: Garland, TX
Vehicle:
2008 WRX STi 5-Door
Black

Default

Got my eibach sways installed with Cobb adjustable end links... WOOW!! What a difference
c_quiasua is offline  
Old 01-23-2013, 01:41 AM   #2018
TOI
Scooby Specialist
 
Member#: 238230
Join Date: Feb 2010
Chapter/Region: TXIC
Location: Sherman, Texas
Vehicle:
93 impreza L wagon
mostly black now

Default

Quote:
Originally Posted by SilverSpool View Post
what you do on your own time...
touche!
TOI is offline  
Old 01-23-2013, 06:17 PM   #2019
SGC2CIC
Scooby Specialist
 
Member#: 286908
Join Date: Jun 2011
Chapter/Region: TXIC
Location: Dallas Texas
Vehicle:
2014 EVO X GSR
2000 2.5RS

Default

Got a STi engine in it

SGC2CIC is offline  
Old 01-23-2013, 06:30 PM   #2020
HonduHunter
Scooby Guru
 
Member#: 28408
Join Date: Oct 2002
Chapter/Region: TXIC
Location: San Antonio, Tx
Vehicle:
2002 vf48ed WRX
PSM

Default

Quote:
Originally Posted by SGC2CIC View Post
Got a STi engine in it
Buttseks
HonduHunter is offline  
Old 01-23-2013, 11:18 PM   #2021
laxman2001
Scooby Newbie
 
Member#: 268558
Join Date: Dec 2010
Chapter/Region: South East
Location: Charlotte, NC
Vehicle:
2008 STi
OBP

Default

New brake pads:

laxman2001 is offline  
Old 01-24-2013, 12:14 AM   #2022
Gary Bechtold
Scooby Specialist
 
Member#: 99393
Join Date: Oct 2005
Chapter/Region: TXIC
Location: Katy, Texas
Vehicle:
1997 Supra Turbo
2005 Legacy 2.5 GT Wagon

Default

Quote:
Originally Posted by laxman2001 View Post
New brake pads:

I'm considering these pads for my 2005 Legacy GT Wagon. I have Hawk HP+ right now. I'm going to need brake work soon.
Gary Bechtold is offline  
Old 01-24-2013, 12:42 AM   #2023
laxman2001
Scooby Newbie
 
Member#: 268558
Join Date: Dec 2010
Chapter/Region: South East
Location: Charlotte, NC
Vehicle:
2008 STi
OBP

Default

Quote:
Originally Posted by Gary Bechtold View Post
I'm considering these pads for my 2005 Legacy GT Wagon. I have Hawk HP+ right now. I'm going to need brake work soon.
I'm coming off the stockers. I assume these would be less agressive than HP+, I was gonna get DS2500 but am gonna wait, and probably get all 4 corners and new rotors.
laxman2001 is offline  
Old 01-24-2013, 10:12 AM   #2024
Squidz
Scooby Guru
 
Member#: 142608
Join Date: Mar 2007
Chapter/Region: TXIC
Location: Cute fuzzy cuddly kitten hell.
Vehicle:
2003 Sonic Yellow
Marginally well behaved.

Default

The DS2500 are great pads...they are actually about the same as the HP+ in bite and working temp but seem to be a little less aggressive in the wear on the rotor.

I'm a big fan of the HP+...they work great and are pretty cheap. Havn't tried the Mu pads yet, would love to hear how they work for ya when you get them on.
Squidz is offline  
Old 01-24-2013, 04:13 PM   #2025
laxman2001
Scooby Newbie
 
Member#: 268558
Join Date: Dec 2010
Chapter/Region: South East
Location: Charlotte, NC
Vehicle:
2008 STi
OBP

Default

Quote:
Originally Posted by Squidz View Post
The DS2500 are great pads...they are actually about the same as the HP+ in bite and working temp but seem to be a little less aggressive in the wear on the rotor.

I'm a big fan of the HP+...they work great and are pretty cheap. Havn't tried the Mu pads yet, would love to hear how they work for ya when you get them on.
Got them on yesterday. And immediately bedded them in (8 or so medium stops from 30ish, 5 or so hard ones from 45ish)

Initial results are good. They don't feel too different from stock, which is a good thing. A bit more initial bite (not much), and no squealing of any kind. Supposedly they dust way less, too.
laxman2001 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
what did you do to your car today? Schrecken Bay Area Impreza Club Forum -- BAIC 11 09-25-2012 03:08 AM
What did you do to your subie today?! 07imprezadrifter General Community 277 06-14-2009 11:42 PM
What did you do to your Scoob today? Sheehan North West Impreza Club Forum -- NWIC 27 11-23-2007 12:02 PM


All times are GMT -4. The time now is 09:14 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.