Welcome to the North American Subaru Impreza Owners Club Thursday March 26, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-13-2015, 01:48 PM   #1
dmeiklej
Scooby Newbie
 
Member#: 413419
Join Date: Feb 2015
Location: Baltimore
Vehicle:
2014 Impreza

Default new impreza problems

I bought a 2014 subaru impreza, RES, Standard radio, 8 months ago - and its had some random problems. I was wondering what issues people have been running into.

My list:
CD player would display an error anytime a cd was inserted. The head unit had to be replaced.

Head unit was replaced and I could no longer hear people over the bluetooth (music played fine, and they could hear me fine)

Bluetooth was "fixed" by re-positioning the antenna, but I now have to have the phone placed exactly in one spot to hear callers.

Doors don't unlock if the temperature drops into the teens and its below freezing.

Window Auto-up, Auto-down stopped working for a few days, then randomly started again and hasn't caused a problem since.

Rear window takes forever to defrost.

My coworker got a 14 impreza at the same time.
She can't hear callers over her bluetooth (got a headset - since its a leased car and she just doesn't want to deal with it).

There's an odd 'pause' when you reverse and shift to drive that is probably 3x as long as my car.

Rear window also takes forever to defrost.
* Registered users of the site do not see these ads.
dmeiklej is offline   Reply With Quote
Old 02-13-2015, 02:59 PM   #2
Haunty
Scooby Newbie
 
Member#: 319378
Join Date: May 2012
Chapter/Region: MWSOC
Location: West Central MN
Vehicle:
2012 2.0i Sport Ltd.
Satin White Pearl

Default

The window auto-up/down resets every time the battery is disconnected, some secret handshake enables it again, I think it is in the manual

Shifting to and from reverse delay is normal on the CVT, it uses a solenoid to change direction

I noticed rear window defrost isn't that great also
Haunty is offline   Reply With Quote
Old 02-13-2015, 03:20 PM   #3
Commander Keen
Scooby Specialist
 
Member#: 319157
Join Date: May 2012
Chapter/Region: MAIC
Vehicle:
2012 Impreza 4DR 5MT

Default

You know the bluetooth volume is adjustable, right? Turn the volume knob during the call.

Window auto-up needs to be trained before it can work. Like Haunty said, if the battery was disconnected, it will forget its settings.
Commander Keen is offline   Reply With Quote
Old 02-13-2015, 04:39 PM   #4
foghelmut
Scooby Newbie
 
Member#: 328414
Join Date: Aug 2012
Location: South Jersey
Vehicle:
2012 Impreza SP 5MT
obsidian pearl black

Default

The window up is easy, roll the window halfway down, then roll it up and hold the up button for some amount of time. 5 or 30 seconds or something.
foghelmut is offline   Reply With Quote
Old 02-13-2015, 04:52 PM   #5
millertime359
Scooby Newbie
 
Member#: 393302
Join Date: Jun 2014
Location: Holland, MI
Vehicle:
2014 Impreza Sport

Default

The pause from reverse to drive is normal if your not coming to complete stop before shifting to drive. If you are trying to do a quick 3 point, it doesn't work too well.

If you are coming to complete stop, then shifting, then pushing on the gas after you shifted and it does it, might be a problem.

Not sure on your unlock issues. I don't have a problem and i has been into the negatives a couple of times this winter.
millertime359 is offline   Reply With Quote
Old 02-16-2015, 06:47 PM   #6
Frosty2.2
Scooby Newbie
 
Member#: 413696
Join Date: Feb 2015
Default

Idk about electrical issues but have they fixed the head gasket problem with the 2.5?
Frosty2.2 is offline   Reply With Quote
Old 02-18-2015, 12:39 PM   #7
acrouse
Scooby Newbie
 
Member#: 413835
Join Date: Feb 2015
Vehicle:
2014 Impreza
White

Default

I have a 14 Impreza and have also had a lot of issues, but none that you have! It unlocks fine and the stereo works too. However, I have had my starter replaced and it still has issues starting. I am also on my firth check engine light for the emissions- and no its not the gas cap. Everyone I have talked to with a 14 impreza doesn't have any issues!
acrouse is offline   Reply With Quote
Old 02-18-2015, 03:28 PM   #8
79letour
Scooby Specialist
 
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
Vehicle:
2013 XV
DGM!

Default

Quote:
Originally Posted by acrouse View Post
I have a 14 Impreza and have also had a lot of issues, but none that you have! It unlocks fine and the stereo works too. However, I have had my starter replaced and it still has issues starting. I am also on my firth check engine light for the emissions- and no its not the gas cap. Everyone I have talked to with a 14 impreza doesn't have any issues!
Does it use up oil like a used 70's Chevy Vega? If its burning oil that could cause emmisions systems issues.
79letour is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 08:40 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.