Welcome to the North American Subaru Impreza Owners Club Tuesday September 2, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-20-2012, 11:24 PM   #1
rocklandrfc12
Scooby Newbie
 
Member#: 285650
Join Date: Jun 2011
Location: Tappan, New York
Vehicle:
2008 WRX Hatchback
Black

Default P1071 check engine light. HELP!!

2008 WRX Automatic Transmition with 45,000 miles

Mods:
Tsudo downpipe & exhaust
AP Short Ram intake
Forge BOV
Boost Solenoid
Stage 2 tune

I have a P1071 check engine light (as well as traction control and cruise control light) that comes on repetidly every 200 miles or so at idle or a cruising speed. I've checked all possible lines for a boost leak. I cleaned the MAF sensor in the intake about 1 week 1/2 ago, and deleted the code. Today the light came back on coming home from work while cruising at about 45 mph. Any ideas what the cause can be of the repeated check engine light?
* Registered users of the site do not see these ads.
rocklandrfc12 is offline   Reply With Quote
Old 02-20-2012, 11:25 PM   #2
SubieWRX605
Scooby Newbie
 
Member#: 283537
Join Date: May 2011
Chapter/Region: NESIC
Location: CT
Default

Accidental post
SubieWRX605 is offline   Reply With Quote
Old 02-21-2012, 12:40 AM   #3
dead_eye
Scooby Newbie
 
Member#: 308265
Join Date: Jan 2012
Location: PHL
Vehicle:
2008 WRX

Default

I have the 2008 Subaru factory service manual and I don't see a P1071 in the list.
dead_eye is offline   Reply With Quote
Old 02-21-2012, 09:21 AM   #4
Jayzord
Scooby Newbie
 
Member#: 306170
Join Date: Jan 2012
Chapter/Region: E. Canada
Location: Quebec
Vehicle:
2004 Impreza Wrx STi
Black

Default

Maybe he meant P0171, Running lean. Happend to me as I was cruising sometimes and it was a dirty MAF and a messed up o2 sensor. A lot of person experiment this problem and can help you out in the diagnostic of your problem, but make sure you have the good Code #

Last edited by Jayzord; 02-21-2012 at 09:33 AM.
Jayzord is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Check engine light help WRobX Service & Maintenance 6 12-30-2005 11:46 AM
Check Engine Light Help Topshelf Normally Aspirated Powertrain 6 12-13-2004 12:45 PM
check engine light HELP!!!! subarublu Factory 2.0L Turbo Powertrain 2 08-26-2004 02:27 PM
Check Engine Light Help HpiRally Normally Aspirated Powertrain 1 03-01-2002 12:15 AM
check engine light !!! help! jhoffmann Technical Forum Archive 2 08-13-2000 12:17 AM


All times are GMT -4. The time now is 04:14 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.