Welcome to the North American Subaru Impreza Owners Club Sunday July 13, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-21-2012, 10:28 PM   #1
D0uglassss
Scooby Newbie
 
Member#: 305108
Join Date: Dec 2011
Chapter/Region: Tri-State
Vehicle:
2012 wrx

Default new car check engine light

just picked up my car today and i have a flashing check engine light. its a 2012 wrx limited and the codes are p1518 p0852 p1152 p1153 p0140 and idea on what is the cause of these code?
* Registered users of the site do not see these ads.
D0uglassss is online now   Reply With Quote
Old 02-21-2012, 11:55 PM   #2
Uncle Scotty
Scooby Guru
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK Houston
we have an Uncle

Default

take it back to the dealer

now
Uncle Scotty is offline   Reply With Quote
Old 02-22-2012, 04:44 AM   #3
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 WRX
15 WRX/05 GTO

Default

Sounds like the green test connectors were left plugged in. But yeah, it's brand new take it back.
Mulder is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
P1071 check engine light. HELP!! rocklandrfc12 Factory 2.5L Turbo Powertrain 3 02-21-2012 09:21 AM
NEW EXHAUST...CHECK ENGINE LIGHT (Maybe) TenaciousEJ257 Factory 2.5L Turbo Powertrain 6 12-09-2008 07:48 PM
update on car, check engine light again! Lisa Bay Area Impreza Club Forum -- BAIC 1 11-15-2002 10:48 PM
My check engine light is on but car is running fine. Ripper Normally Aspirated Powertrain 27 09-24-2001 11:59 AM


All times are GMT -4. The time now is 01:38 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.