Welcome to the North American Subaru Impreza Owners Club Wednesday April 16, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Mid Atlantic Impreza Club
Mid Atlantic Impreza Club Forum sponsored by Annapolis Subaru
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Mid Atlantic Impreza Club -- MAIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Closed Thread
 
Thread Tools Display Modes
Old 10-10-2012, 01:32 PM   #3051
DavC825
Scooby Specialist
 
Member#: 201736
Join Date: Feb 2009
Chapter/Region: MAIC
Vehicle:
The 4 door goodluck
Charm

Default

Yesterday the sweet powersteering while came back.
Today power steering noise went away. yes!
And drove it around today. Exciting.
* Registered users of the site do not see these ads.
DavC825 is offline  
Old 10-10-2012, 02:11 PM   #3052
mhoerath
Scooby Specialist
 
Member#: 131379
Join Date: Nov 2006
Chapter/Region: MAIC
Location: richmond, va
Vehicle:
2003 354 ftlb@3k rpm
justablue hatch

Default

Quote:
Originally Posted by tigburns View Post
I missed Seagull this year. Centuries are my favorite event, by far. I did Backroads a few weeks ago, and also Tour deCure. I also started racing this season and am hooked. Have you found a forum for road biking?
my license plate is cyclust...roadie. did centuries and finally learned all those body parts going to sleep around mile 70 was telling your brain something.

there's maybe 500 threads with bicyling as a keyword...mostly in off topic.
mhoerath is offline  
Old 10-10-2012, 04:18 PM   #3053
XERO287
Scooby Specialist
 
Member#: 253541
Join Date: Jul 2010
Chapter/Region: MAIC
Location: Silver Spring, MD
Vehicle:
2011 WRX 5DR Premium
OBP

Default

Drove it. Acceleration makes stitches hurt.
XERO287 is offline  
Old 10-11-2012, 11:34 PM   #3054
ppayer38
Scooby Specialist
 
Member#: 234407
Join Date: Jan 2010
Chapter/Region: MAIC
Location: Smithfield, VA
Vehicle:
04 Self-tooned
STi

Default

Not my car but showing my support

ppayer38 is offline  
Old 10-12-2012, 12:09 AM   #3055
flembud
Scooby Newbie
 
Member#: 334358
Join Date: Oct 2012
Default

Plugged a vaccume leak on my Lincoln to steady out the idle and bring the fuel trim back within range. Finicky a** FORDS.
flembud is offline  
Old 10-12-2012, 06:10 AM   #3056
ppayer38
Scooby Specialist
 
Member#: 234407
Join Date: Jan 2010
Chapter/Region: MAIC
Location: Smithfield, VA
Vehicle:
04 Self-tooned
STi

Default

Received my Gm IAT sense and bung today so I can get that welded on Monday for some real intake temp readings
ppayer38 is offline  
Old 10-12-2012, 08:38 AM   #3057
gaedikus
Scooby Specialist
 
Member#: 310254
Join Date: Feb 2012
Chapter/Region: MAIC
Location: Stafford, VA
Vehicle:
04 Forester XT
Silver

Default

ill be taking my girl in this weekend for the oil change, and then try to figure out what the hell is making that damn noise. almost a metal rubbing sound by the compressor, any ideas? (aside from 'probably the compressor')
gaedikus is offline  
Old 10-12-2012, 10:55 AM   #3058
Lurch33
Scooby Specialist
 
Member#: 261832
Join Date: Oct 2010
Chapter/Region: MAIC
Location: NoVA
Vehicle:
06 WRX TR
WRB

Default

Quote:
Originally Posted by gaedikus
ill be taking my girl in this weekend for the oil change, and then try to figure out what the hell is making that damn noise. almost a metal rubbing sound by the compressor, any ideas? (aside from 'probably the compressor')
You just reminded me, I have been meaning to change my oil for the past three weeks... I guess i will be doing it tomorrow morning.

Vacuumed my car the other day. Oh, so dirty.

Last edited by Lurch33; 10-12-2012 at 11:39 AM.
Lurch33 is offline  
Old 10-12-2012, 11:57 AM   #3059
gaedikus
Scooby Specialist
 
Member#: 310254
Join Date: Feb 2012
Chapter/Region: MAIC
Location: Stafford, VA
Vehicle:
04 Forester XT
Silver

Default

Quote:
Originally Posted by Lurch33 View Post
You just reminded me, I have been meaning to change my oil for the past three weeks... I guess i will be doing it tomorrow morning.

Vacuumed my car the other day. Oh, so dirty.
im changing mine tomorrow, and if it means a dealership looks at the noise issue, then so be it. i hope it isnt expensive
gaedikus is offline  
Old 10-12-2012, 01:05 PM   #3060
mhoerath
Scooby Specialist
 
Member#: 131379
Join Date: Nov 2006
Chapter/Region: MAIC
Location: richmond, va
Vehicle:
2003 354 ftlb@3k rpm
justablue hatch

Default

just klasse and pinacle waxed wife's new outback, washed and cleaned inside windshield in mine. 2 subies now, bye bye highlander. its been a great car.
mhoerath is offline  
Old 10-12-2012, 07:16 PM   #3061
EvileyeZ88
Scooby Specialist
 
Member#: 233501
Join Date: Dec 2009
Chapter/Region: MAIC
Location: Fairfax Va, Henrico Va
Vehicle:
07AD 337/335SAXWAGON
99 outback sport

Default

Quote:
Originally Posted by gaedikus

im changing mine tomorrow, and if it means a dealership looks at the noise issue, then so be it. i hope it isnt expensive
Pinpointed the noise, it was just an angry AC tensioner pulley


Mailed out some LED's to mhoerath

And put up a big FS thread.

Tomorrow maybe I'll work on finishing up my 20G or tgv deletes.

Last edited by EvileyeZ88; 10-12-2012 at 07:24 PM.
EvileyeZ88 is offline  
Old 10-12-2012, 08:25 PM   #3062
S_pauley
Scooby Newbie
 
Member#: 331524
Join Date: Sep 2012
Chapter/Region: MAIC
Location: Morgantown WV
Vehicle:
2013 Sport Premium
WHITE

Default Drove off of the lot!!

Traded in my 2011 Forester Touring for the 2013 Sport Premium in white!!



Picture from Cars101.com
S_pauley is offline  
Old 10-12-2012, 08:43 PM   #3063
SlyWRX
Scooby Newbie
 
Member#: 331851
Join Date: Sep 2012
Chapter/Region: MAIC
Location: Virginia Beach, VA
Vehicle:
2002 Impreza WRX
WRB

Default

Replaced timing belt, pulleys, water pump, radiator and hoses. And everything still works....

And I would like to add, it's really rough trying to do the timing belt on your own.

Last edited by SlyWRX; 10-12-2012 at 09:05 PM. Reason: Adding content
SlyWRX is offline  
Old 10-12-2012, 11:51 PM   #3064
OrbitalEllipses
Scooby Guru
 
Member#: 178811
Join Date: Apr 2008
Chapter/Region: MAIC
Location: MoCo
Vehicle:
2013 WRB BRZ
:banana:

Default

Put down 172whp and 143wtq (SAE) on Mach V's DynoJet.
OrbitalEllipses is offline  
Old 10-13-2012, 06:17 PM   #3065
Smurftastic
Scooby Specialist
 
Member#: 243697
Join Date: Apr 2010
Chapter/Region: MAIC
Location: Virginia
Vehicle:
02 Stg2+ WRX
Top Scoob 031

Default

Contemplated how my car is going to get really ugly before it gets beautiful again to accomplish everything that needs to be done :\
Smurftastic is offline  
Old 10-13-2012, 06:19 PM   #3066
roccer
Scooby Specialist
 
Member#: 113674
Join Date: Apr 2006
Chapter/Region: MAIC
Location: Fairfax, VA
Vehicle:
2006 WRX ltd, 18g'd
WRB, 355whp/365wtq

Default

with the help of Abnormal, swapped out my stock struts for some Tokico D-Specs (reused my Mach V springs currently installed) and the stock front top hats for Group-N's (kept rear top hats stock.
roccer is offline  
Old 10-13-2012, 06:45 PM   #3067
OrbitalEllipses
Scooby Guru
 
Member#: 178811
Join Date: Apr 2008
Chapter/Region: MAIC
Location: MoCo
Vehicle:
2013 WRB BRZ
:banana:

Default

Quote:
Originally Posted by OrbitalEllipses View Post
Put down 172whp and 143wtq (SAE) on Mach V's DynoJet.
OrbitalEllipses is offline  
Old 10-13-2012, 07:07 PM   #3068
lilblue619
NASIOC Supporter
 
Member#: 288292
Join Date: Jul 2011
Chapter/Region: MAIC
Location: arbutus md
Vehicle:
2004 sti
wrb. the blue one.

Default

Bought some wheels today and thought about installing my rear diffuser. Washed the car and the new to me wheels instead
lilblue619 is offline  
Old 10-13-2012, 07:09 PM   #3069
gaedikus
Scooby Specialist
 
Member#: 310254
Join Date: Feb 2012
Chapter/Region: MAIC
Location: Stafford, VA
Vehicle:
04 Forester XT
Silver

Default

got my oil change, and broke a part that stupid plastic ring on my ac belt tensioner -and the nut wasnt even tightened down! so now i gotta wait till monday when subaru opens up, for the $7 part. le fu.
gaedikus is offline  
Old 10-13-2012, 11:02 PM   #3070
DavC825
Scooby Specialist
 
Member#: 201736
Join Date: Feb 2009
Chapter/Region: MAIC
Vehicle:
The 4 door goodluck
Charm

Default

Changed my Power steering fluid today. Accidentally introduced air into the system as I had the return line in a detergent bottle, finger plugging off the return nipple and my sister rotated the wheel. Turned the wheel from lock to lock and got rid of the bubbles...eventually.

Finally, drove it to Modells sporting goods, TJ maxx, Marshallswhole foods in Annapolis and had a wrx bug eye park next to me and Giant.

exciting.
DavC825 is offline  
Old 10-13-2012, 11:13 PM   #3071
Lurch33
Scooby Specialist
 
Member#: 261832
Join Date: Oct 2010
Chapter/Region: MAIC
Location: NoVA
Vehicle:
06 WRX TR
WRB

Default

Just an oil change. Then stared at it.
Lurch33 is offline  
Old 10-14-2012, 01:59 PM   #3072
Purpose_Built
Scooby Newbie
 
Member#: 222879
Join Date: Sep 2009
Chapter/Region: Tri-State
Location: NJ
Vehicle:
2003 WRX
Silver

Default

Quote:
Originally Posted by Patrick Olsen View Post
Installed the brakes from a 2nd gen CTS-V on my 1st gen. I chose to go with the pimpy yellow calipers from the Black Diamond edition. To start out with, I'm using OEM V2 rotors that I redrilled (somewhat ugly) and also had the center bore opened out by a machine shop. (Off the top of my head I don't recall the numbers, but the V2 center bore is a couple millimeters smaller than the V1.) The OEM rotors are non-serviceable 2-piece rotors (at least, that's what I would call them, since they're made of two different materials but you can't disassemble them.) I think I've seen that the newer Audis have something similar? Anyway, drilling a new bolt pattern was pretty easy with just a normal electric drill, since the center section is aluminum, but I didn't have the capability to enlarge the center hole.

In the near future I'll be buying a pair of V2 rotor rings from Racing Brake to put on the RB hats that I've already got, but that can wait for now.

A comparison of the calipers:

(Gold STI calipers turn brown, while silver CTS-V calipers turn gold. Weird.)

And the pads:


Caliper installed (and you can sorta see the 2-piece design of the rotors):


And with a 19" wheel installed:

(A couple of other folks have already verified that the 18" Team Dynamics wheels that I use on track will clear the bigger rotors/calipers.)

I need to wash the car so I can get a good profile shot to show off the yellow calipers on the Stealth Grey car.

No real change in feel with just street pads installed, which is as I expected - the brake torque math works out to ~2.5% shift in bias towards the front. I'm definitely looking forward to seeing how they do on track. With the much bigger pads (~50% larger) and beefier rotors (355x30mm vs 370x34mm) I think they should hold up better to my apparently abusive braking style.

I'm putting these on my Wrx. Trying to get some free hubs so i can fab some brackets
Purpose_Built is offline  
Old 10-14-2012, 02:31 PM   #3073
STIfella
Scooby Newbie
 
Member#: 300326
Join Date: Nov 2011
Chapter/Region: MAIC
Location: Maryland
Vehicle:
2011 Legacy
Blue

Default

Installed a set of knock off Supertones.
STIfella is offline  
Old 10-14-2012, 04:56 PM   #3074
Smurftastic
Scooby Specialist
 
Member#: 243697
Join Date: Apr 2010
Chapter/Region: MAIC
Location: Virginia
Vehicle:
02 Stg2+ WRX
Top Scoob 031

Default

Continued on the engine bay tuck/shave. No pictures til it's all done.. still need to cut metal to fit, looking pretty raw!

But for now... a pic of my trunk setup.

Smurftastic is offline  
Old 10-14-2012, 09:50 PM   #3075
Joslin Rae
Scooby Specialist
 
Member#: 280613
Join Date: Apr 2011
Chapter/Region: MAIC
Location: VA Beach
Vehicle:
2005 FXT Premium 5MT
PSM & Aqua

Default

Installed my TurboXS TBE and went stage 2 on the fozzie

Sound Clip:
http://i1105.photobucket.com/albums/...40E9E7DEEC.mp4

Old:


New:
Joslin Rae is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
What did you do to your car today? Jester808 Texas Impreza Club Forum -- TXIC 3235 08-05-2013 12:55 AM
what did you do to your car today? Schrecken Bay Area Impreza Club Forum -- BAIC 11 09-25-2012 03:08 AM
What did you do to your Scoob today? Sheehan North West Impreza Club Forum -- NWIC 27 11-23-2007 12:02 PM


All times are GMT -4. The time now is 03:29 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.