Welcome to the North American Subaru Impreza Owners Club Wednesday July 9, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Mid Atlantic Impreza Club
Mid Atlantic Impreza Club Forum sponsored by Annapolis Subaru
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Mid Atlantic Impreza Club -- MAIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Closed Thread
 
Thread Tools Display Modes
Old 01-09-2013, 02:53 AM   #4351
808hi
Scooby Newbie
 
Member#: 88726
Join Date: Jun 2005
Chapter/Region: SCIC
Location: san diego CA
Vehicle:
2011 Impreza STi
DGM

Default

Quote:
Originally Posted by Matt_H View Post

What.
Double what?
* Registered users of the site do not see these ads.
808hi is offline  
Old 01-09-2013, 09:04 AM   #4352
gaedikus
Scooby Specialist
 
Member#: 310254
Join Date: Feb 2012
Chapter/Region: MAIC
Location: Stafford, VA
Vehicle:
04 Forester XT
Silver

Default

replaced a headlight, and concluding that air is somehow getting into my coolant lines and making my car overheat.

so... im not happy with my car right now. i had to stop while running late to let air out of my expansion tank
gaedikus is offline  
Old 01-09-2013, 11:45 AM   #4353
DearDiaryJackpot
Scooby Specialist
 
Member#: 343041
Join Date: Jan 2013
Location: riverview
Vehicle:
2013 wrx limited
metallic silver

Default

I never test drove the car. I just knew we were meant to be together
DearDiaryJackpot is offline  
Old 01-09-2013, 12:40 PM   #4354
marios03wrx
Scooby Specialist
 
Member#: 33593
Join Date: Mar 2003
Chapter/Region: MAIC
Location: Chesapeake, VA
Vehicle:
2002 WrX-ShAgNwAgOn
that is 05 WrX Power'd

Default

Quote:
Originally Posted by gaedikus View Post
replaced a headlight, and concluding that air is somehow getting into my coolant lines and making my car overheat.

so... im not happy with my car right now. i had to stop while running late to let air out of my expansion tank
Damn.... Still? :-(
marios03wrx is offline  
Old 01-09-2013, 12:59 PM   #4355
EvileyeZ88
Scooby Specialist
 
Member#: 233501
Join Date: Dec 2009
Chapter/Region: MAIC
Location: Fairfax Va
Vehicle:
07AD 337/335SAXWAGON
99 outback sport

Default

Quote:
Originally Posted by gaedikus View Post
replaced a headlight, and concluding that air is somehow getting into my coolant lines and making my car overheat.

so... im not happy with my car right now. i had to stop while running late to let air out of my expansion tank
Just gonna have to do that ancillary hose kit and replace every pressure clamp with worm gear clamps.

All you coolant lines are "tired" from many heat cycles. Also one final good burping should do it.

A buddy of mine showed me a neat trick the other night how to bleed the air out of these systems fast.

~Evil
EvileyeZ88 is offline  
Old 01-09-2013, 01:05 PM   #4356
DavC825
Scooby Specialist
 
Member#: 201736
Join Date: Feb 2009
Chapter/Region: MAIC
Vehicle:
The 4 door goodluck
Charm

Default

What trick would that be, Evil?


Did my first timing belt. Ever. I'm still surprised I did it right.
DavC825 is offline  
Old 01-09-2013, 01:26 PM   #4357
EvileyeZ88
Scooby Specialist
 
Member#: 233501
Join Date: Dec 2009
Chapter/Region: MAIC
Location: Fairfax Va
Vehicle:
07AD 337/335SAXWAGON
99 outback sport

Default

Both caps open, funnel in the expansion tank with coolant in it. Then just squeeze the hell out of the upper and lower coolant hoses with the motor running till the air all comes out.

~Evil

Last edited by EvileyeZ88; 01-09-2013 at 01:34 PM.
EvileyeZ88 is offline  
Old 01-09-2013, 01:36 PM   #4358
gaedikus
Scooby Specialist
 
Member#: 310254
Join Date: Feb 2012
Chapter/Region: MAIC
Location: Stafford, VA
Vehicle:
04 Forester XT
Silver

Default

Quote:
Originally Posted by marios03wrx View Post
Damn.... Still? :-(
Quote:
Originally Posted by EvileyeZ88 View Post
Just gonna have to do that ancillary hose kit and replace every pressure clamp with worm gear clamps.

All you coolant lines are "tired" from many heat cycles. Also one final good burping should do it.

A buddy of mine showed me a neat trick the other night how to bleed the air out of these systems fast.

~Evil
yeah i got the ancillary hoses ready to go, and as far as clamps go ill have to pick some up. are you free tonight jim?

edit: yeah that light bulb, it was burnt out on the inside. the new one fired up like a champ, so i think the old bulb was just at its end.
gaedikus is offline  
Old 01-09-2013, 01:56 PM   #4359
EvileyeZ88
Scooby Specialist
 
Member#: 233501
Join Date: Dec 2009
Chapter/Region: MAIC
Location: Fairfax Va
Vehicle:
07AD 337/335SAXWAGON
99 outback sport

Default

Yeah I'll be around tonight.
EvileyeZ88 is offline  
Old 01-09-2013, 02:04 PM   #4360
gaedikus
Scooby Specialist
 
Member#: 310254
Join Date: Feb 2012
Chapter/Region: MAIC
Location: Stafford, VA
Vehicle:
04 Forester XT
Silver

Default

nice. ill hit you up if you got time.
gaedikus is offline  
Old 01-09-2013, 07:31 PM   #4361
Very WRXY
Scooby Specialist
 
Member#: 295615
Join Date: Sep 2011
Chapter/Region: MAIC
Location: SmithVEGAS to Las Carrollton
Vehicle:
2010 Sea Tree Hundy
Mars Red

Default

Just gave her a bath and cleaned the interior. Also installed my new grimmspeed license plate relocator. Now I'm waiting on some stuff from Mach V and my new plates from the DMV.
Very WRXY is offline  
Old 01-09-2013, 07:55 PM   #4362
js-tm
Scooby Newbie
 
Member#: 273804
Join Date: Feb 2011
Default

js-tm is offline  
Old 01-09-2013, 08:00 PM   #4363
96accord
Scooby Guru
 
Member#: 145105
Join Date: Apr 2007
Chapter/Region: MAIC
Location: Middle River, Maryland
Vehicle:
2007 WRB WRX Limited

Default

Quote:
Originally Posted by Very WRXY View Post
Just gave her a bath. my new plates from the DMV.
Come clean mine bish! What plates you getting? SLOCAMRY?
96accord is offline  
Old 01-09-2013, 08:17 PM   #4364
Very WRXY
Scooby Specialist
 
Member#: 295615
Join Date: Sep 2011
Chapter/Region: MAIC
Location: SmithVEGAS to Las Carrollton
Vehicle:
2010 Sea Tree Hundy
Mars Red

Default

Quote:
Originally Posted by 96accord View Post

Come clean mine bish! What plates you getting? SLOCAMRY?
1. That's too big for a VA plate
2. It looks like a corolla not a camry
3. No
4. Wut 401k
Very WRXY is offline  
Old 01-09-2013, 09:41 PM   #4365
mynavi
Scooby Newbie
 
Member#: 339220
Join Date: Nov 2012
Chapter/Region: MAIC
Location: MD
Vehicle:
2013 WRX
ISM

Default

Just finished installing some supertones and a cobb cbe. I'm in love with the sound!
mynavi is offline  
Old 01-09-2013, 11:33 PM   #4366
DearDiaryJackpot
Scooby Specialist
 
Member#: 343041
Join Date: Jan 2013
Location: riverview
Vehicle:
2013 wrx limited
metallic silver

Default

Drove it for 90 miles. It die on my 3 times when trying to launch. Can't get use to the clutch yet.
Still looking for protection film installer and film itself. So far 2 business over $400.
If I can't find one... then flat black it is. Car will look like is on primer but I don't care.
I don't. Want to loose my beautiful front.
DearDiaryJackpot is offline  
Old 01-09-2013, 11:52 PM   #4367
Tripwire_RC8
Scooby Newbie
 
Member#: 138968
Join Date: Jan 2007
Chapter/Region: MAIC
Location: Winchester, VA
Vehicle:
2002 WRX
Blaze Yellow

Default

Got her to start for the first time
Tripwire_RC8 is offline  
Old 01-10-2013, 06:37 AM   #4368
DKDunn04
Scooby Specialist
 
Member#: 275640
Join Date: Mar 2011
Chapter/Region: MAIC
Location: Edwardsville, IL
Vehicle:
1968 Corvette-Yellow
2004 STI-Silver

Default

Quote:
Originally Posted by DearDiaryJackpot View Post
Drove it for 90 miles. It die on my 3 times when trying to launch. Can't get use to the clutch yet.
Still looking for protection film installer and film itself. So far 2 business over $400.
If I can't find one... then flat black it is. Car will look like is on primer but I don't care.
I don't. Want to loose my beautiful front.
What's the point in having new paint if you are just going to cover it up?
DKDunn04 is offline  
Old 01-10-2013, 08:18 AM   #4369
gaedikus
Scooby Specialist
 
Member#: 310254
Join Date: Feb 2012
Chapter/Region: MAIC
Location: Stafford, VA
Vehicle:
04 Forester XT
Silver

Default

Quote:
Originally Posted by DKDunn04 View Post
What's the point in having new paint if you are just going to cover it up?
this.

last night jim and i swapped out 5 of 7 ancillary hoses for silicone ones, aaaaand this is the result after i started driving (it was idling at nominal)

gaedikus is offline  
Old 01-10-2013, 08:37 AM   #4370
DearDiaryJackpot
Scooby Specialist
 
Member#: 343041
Join Date: Jan 2013
Location: riverview
Vehicle:
2013 wrx limited
metallic silver

Default

Quote:
Originally Posted by DKDunn04 View Post

What's the point in having new paint if you are just going to cover it up?
I know it's kinda pointless but clear film is ^$400 flat color is like $120. Soo...I'll go with the cheaper version.
DearDiaryJackpot is offline  
Old 01-10-2013, 08:43 AM   #4371
acumenhokie
Scooby Specialist
 
Member#: 271479
Join Date: Jan 2011
Chapter/Region: MAIC
Location: Talleyville, DE
Vehicle:
2010 LGT....2009 FXT

Default

UPS man dropped this off. Is it spring yet?

acumenhokie is offline  
Old 01-10-2013, 08:50 AM   #4372
Lukas_vee23
Scooby Newbie
 
Member#: 342863
Join Date: Jan 2013
Chapter/Region: Tri-State
Location: Bronx, New York
Vehicle:
2002 WRX
PSM

Default

Quote:
Originally Posted by ppayer38 View Post
Replaced the timing belt, water pump, t-stat, and radiator and hoses all today! Drive belts are next along with a new turbo(taking suggestions for my torque monster 2.0L)

Got my 04-05 STI reflectors in the mail so true HID's finally
Wanna do mine for me too?
Lukas_vee23 is offline  
Old 01-10-2013, 11:34 AM   #4373
I WANT AN STI
Scooby Specialist
 
Member#: 79983
Join Date: Jan 2005
Chapter/Region: MAIC
Location: va beach
Vehicle:
2005 STI
Aspen White

Default

Got rid of a bunch of parts and got my garage back to proper to make room for it. A nice clean cave to sleep in.

I WANT AN STI is offline  
Old 01-10-2013, 01:02 PM   #4374
gaedikus
Scooby Specialist
 
Member#: 310254
Join Date: Feb 2012
Chapter/Region: MAIC
Location: Stafford, VA
Vehicle:
04 Forester XT
Silver

Default

^@_@ its so clean
gaedikus is offline  
Old 01-10-2013, 01:52 PM   #4375
EvileyeZ88
Scooby Specialist
 
Member#: 233501
Join Date: Dec 2009
Chapter/Region: MAIC
Location: Fairfax Va
Vehicle:
07AD 337/335SAXWAGON
99 outback sport

Default

Quote:
Originally Posted by I WANT AN STI View Post
Got rid of a bunch of parts and got my garage back to proper to make room for it. A nice clean cave to sleep in.
Holy ish that's clean!!! My garage looks like a bomb made of tools and car parts went off in it.
EvileyeZ88 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
What did you do to your car today? Jester808 Texas Impreza Club Forum -- TXIC 3235 08-05-2013 12:55 AM
what did you do to your car today? Schrecken Bay Area Impreza Club Forum -- BAIC 11 09-25-2012 03:08 AM
What did you do to your Scoob today? Sheehan North West Impreza Club Forum -- NWIC 27 11-23-2007 12:02 PM


All times are GMT -4. The time now is 11:21 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.