Welcome to the North American Subaru Impreza Owners Club Thursday August 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Mid Atlantic Impreza Club
Mid Atlantic Impreza Club Forum sponsored by Annapolis Subaru
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Mid Atlantic Impreza Club -- MAIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Closed Thread
 
Thread Tools Display Modes
Old 01-21-2013, 04:39 PM   #4551
ManualOverAuto
Scooby Specialist
 
Member#: 304662
Join Date: Dec 2011
Chapter/Region: MAIC
Vehicle:
2001 Impreza L coupe
Sedona red Pearl

Default

Installed my RS hood.


Now I can officially start saving up for the repaint and swap (may take some time haha).
* Registered users of the site do not see these ads.

Last edited by ManualOverAuto; 01-21-2013 at 05:26 PM.
ManualOverAuto is offline  
Old 01-21-2013, 08:33 PM   #4552
Smurftastic
Scooby Specialist
 
Member#: 243697
Join Date: Apr 2010
Chapter/Region: MAIC
Location: Virginia
Vehicle:
02 Stg2+ WRX
Top Scoob 031

Default

Hey guess what happens to your project car when you've got kids on the way? You rip out your back seats -- not because you're going to the track but because you need room to bring home a crib mattress!

For those that have been following my tuck/shave engine bay project from this winter, today I finished smoothing out the engine bay today -- all that's left is some pre-paint sanding and it's good for paint
Smurftastic is offline  
Old 01-22-2013, 07:44 AM   #4553
mhoerath
Scooby Specialist
 
Member#: 131379
Join Date: Nov 2006
Chapter/Region: MAIC
Location: richmond, va
Vehicle:
2003 354 ftlb@3k rpm
justablue hatch

Default

trans fluid, rear diff fluid, rotate tires.
mhoerath is offline  
Old 01-22-2013, 09:56 AM   #4554
prescottn6ft7
Scooby Specialist
 
Member#: 268918
Join Date: Jan 2011
Chapter/Region: MAIC
Location: Virginia Beach, Virginia
Vehicle:
2002 WRX Wagon
WRB

Default

Got my windows tinted. Drivers side looks great... passenger side, not so much. Going to give them a chance to fix it before I put them on blast.

prescottn6ft7 is offline  
Old 01-22-2013, 10:11 AM   #4555
I WANT AN STI
Scooby Specialist
 
Member#: 79983
Join Date: Jan 2005
Chapter/Region: MAIC
Location: va beach
Vehicle:
2005 STI
Aspen White

Default

Who did the tint ? If im able to keep my sti I need to get it tinted. I have used east coast window tint for all of my cars and they have done an excellent job. Corner of dam neck and holland.
I WANT AN STI is offline  
Old 01-22-2013, 11:09 AM   #4556
gaedikus
Scooby Specialist
 
Member#: 310254
Join Date: Feb 2012
Chapter/Region: MAIC
Location: Stafford, VA
Vehicle:
04 Forester XT
Silver

Default

Quote:
Originally Posted by prescottn6ft7 View Post
Got my windows tinted. Drivers side looks great... passenger side, not so much. Going to give them a chance to fix it before I put them on blast.
pics of crappy tint requested.

i put air in one of my tires, as it may have developed a slow leak... and still figuring out what to do with my "air in the coolant lines" issue :/
gaedikus is offline  
Old 01-22-2013, 02:09 PM   #4557
prescottn6ft7
Scooby Specialist
 
Member#: 268918
Join Date: Jan 2011
Chapter/Region: MAIC
Location: Virginia Beach, Virginia
Vehicle:
2002 WRX Wagon
WRB

Default

Quote:
Originally Posted by I WANT AN STI View Post
Who did the tint ?
I'd rather wait to see if they're going to fix the shoddy work they did this weekend before I throw their name out there in either a good or bad way. I can say I found them through some posts by a friend in MAIC, and it surprises me I'm even having to deal with this.

Quote:
Originally Posted by gaedikus View Post
pics of crappy tint requested. :/
I'll take some tonight with my camera. Cell phone doesn't do the crappiness justice.

Side note... link to thread describing issues with your coolant issues?
prescottn6ft7 is offline  
Old 01-22-2013, 02:42 PM   #4558
gaedikus
Scooby Specialist
 
Member#: 310254
Join Date: Feb 2012
Chapter/Region: MAIC
Location: Stafford, VA
Vehicle:
04 Forester XT
Silver

Default

Quote:
Originally Posted by prescottn6ft7 View Post
I'd rather wait to see if they're going to fix the shoddy work they did this weekend before I throw their name out there in either a good or bad way. I can say I found them through some posts by a friend in MAIC, and it surprises me I'm even having to deal with this.



I'll take some tonight with my camera. Cell phone doesn't do the crappiness justice.

Side note... link to thread describing issues with your coolant issues?
i think ive posted in this thread before, but here's the jist:

new CX racing aluminum radiator
new ancillary hoses
new grimmspeed 160F thermostat
new hose clamps

somehow the coolant drains out of the expansion tank and goes into the reservoir, but doesn't pump back into the system when the car is running. the tsat runs wide open, and therefore the car runs very cool (water temp stays here -or lower sometimes)

no leaks to my knowledge, no coolant burning off, vents deliver cold air when stopped. after driving if i park and twist the expansion tank cap, itll spew out air under pressure. where it comes from? i dont know when jim and i installed the tstat there were no leaks and the car held it's coolant just fine -even the heaters worked.

the car also has been throwing CEL's for something along the lines of "thermostat activating too cold".
gaedikus is offline  
Old 01-22-2013, 03:46 PM   #4559
STiWanabe
Scooby Guru
 
Member#: 41447
Join Date: Aug 2003
Chapter/Region: MAIC
Location: Baltimore, MD
Vehicle:
---- _________

Default

Quote:
Originally Posted by gaedikus View Post

i think ive posted in this thread before, but here's the jist:

new CX racing aluminum radiator
new ancillary hoses
new grimmspeed 160F thermostat
new hose clamps

somehow the coolant drains out of the expansion tank and goes into the reservoir, but doesn't pump back into the system when the car is running. the tsat runs wide open, and therefore the car runs very cool (water temp stays here -or lower sometimes)

no leaks to my knowledge, no coolant burning off, vents deliver cold air when stopped. after driving if i park and twist the expansion tank cap, itll spew out air under pressure. where it comes from? i dont know when jim and i installed the tstat there were no leaks and the car held it's coolant just fine -even the heaters worked.

the car also has been throwing CEL's for something along the lines of "thermostat activating too cold".
That a p0128? Usually indicates a stuck open thermostat. Cool air at idle usually indicated air bubbles...
STiWanabe is offline  
Old 01-22-2013, 04:58 PM   #4560
Chazual
Scooby Newbie
 
Member#: 338144
Join Date: Nov 2012
Chapter/Region: MAIC
Location: Pennsylvania
Vehicle:
2005 WRX wagon
black

Default

I fixed my passenger side door finally. Now time to start modding
Chazual is offline  
Old 01-22-2013, 06:11 PM   #4561
infinite012
Scooby Specialist
 
Member#: 74392
Join Date: Nov 2004
Chapter/Region: MAIC
Location: Virginia
Vehicle:
2013 BRZ
DGM

Default

Not today, but last night I swapped the LEDs from STI to the BRZ.





I also stole the shift knob from my STI and put it on the BRZ. This isn't going to be on for long - just until I get a new knob with the correct reverse pattern.




Winningest shot of the night:
infinite012 is offline  
Old 01-22-2013, 06:19 PM   #4562
Very WRXY
Scooby Specialist
 
Member#: 295615
Join Date: Sep 2011
Chapter/Region: MAIC
Location: SmithVEGAS to Las Carrollton
Vehicle:
2010 Sea Tree Hundy
Mars Red

Default

Quote:
Originally Posted by infinite012 View Post
Not today, but last night I swapped the LEDs from STI to the BRZ.

I also stole the shift knob from my STI and put it on the BRZ. This isn't going to be on for long - just until I get a new knob with the correct reverse pattern.

Winningest shot of the night:
Looks nice
Very WRXY is offline  
Old 01-22-2013, 06:20 PM   #4563
infinite012
Scooby Specialist
 
Member#: 74392
Join Date: Nov 2004
Chapter/Region: MAIC
Location: Virginia
Vehicle:
2013 BRZ
DGM

Default

Spanks Mike.
infinite012 is offline  
Old 01-22-2013, 06:21 PM   #4564
Very WRXY
Scooby Specialist
 
Member#: 295615
Join Date: Sep 2011
Chapter/Region: MAIC
Location: SmithVEGAS to Las Carrollton
Vehicle:
2010 Sea Tree Hundy
Mars Red

Default

Quote:
Originally Posted by infinite012 View Post
Spanks Mike.
Later. Ill text you my address. Don't tell Kraus, he will get jelly.
Very WRXY is offline  
Old 01-22-2013, 07:15 PM   #4565
Oaf02Z
Scooby Specialist
 
Member#: 263219
Join Date: Nov 2010
Chapter/Region: MAIC
Location: NOVA
Vehicle:
2012 STI sedan
Plasma Blue Pearl

Default

Installed my Cobb SF intake and uploaded the new map.
Oaf02Z is offline  
Old 01-23-2013, 08:20 AM   #4566
gaedikus
Scooby Specialist
 
Member#: 310254
Join Date: Feb 2012
Chapter/Region: MAIC
Location: Stafford, VA
Vehicle:
04 Forester XT
Silver

Default

Quote:
Originally Posted by STiWanabe View Post
That a p0128? Usually indicates a stuck open thermostat. Cool air at idle usually indicated air bubbles...
yeah i think that was the code, i've burped it several times though -and upon initial install. air wide open on a cold start, the whole shebang. somehow air keeps getting in there. the expansion tank just about drains except for a little less than 1" of coolant. and after driving i open the expansion tank cap and air forces out every time.
gaedikus is offline  
Old 01-23-2013, 08:44 AM   #4567
STiWanabe
Scooby Guru
 
Member#: 41447
Join Date: Aug 2003
Chapter/Region: MAIC
Location: Baltimore, MD
Vehicle:
---- _________

Default

Quote:
Originally Posted by gaedikus View Post
yeah i think that was the code, i've burped it several times though -and upon initial install. air wide open on a cold start, the whole shebang. somehow air keeps getting in there. the expansion tank just about drains except for a little less than 1" of coolant. and after driving i open the expansion tank cap and air forces out every time.
airlift tool is your friend

STiWanabe is offline  
Old 01-23-2013, 09:51 AM   #4568
marios03wrx
Scooby Specialist
 
Member#: 33593
Join Date: Mar 2003
Chapter/Region: MAIC
Location: Chesapeake, VA
Vehicle:
2002 WrX-ShAgNwAgOn
that is 05 WrX Power'd

Default

Quote:
Originally Posted by gaedikus View Post

yeah i think that was the code, i've burped it several times though -and upon initial install. air wide open on a cold start, the whole shebang. somehow air keeps getting in there. the expansion tank just about drains except for a little less than 1" of coolant. and after driving i open the expansion tank cap and air forces out every time.
I still think u should get a leakdown or chem test to see if your headgasket has a leak. All your prolonged symptoms ooint to it to me.
marios03wrx is offline  
Old 01-23-2013, 10:30 AM   #4569
gaedikus
Scooby Specialist
 
Member#: 310254
Join Date: Feb 2012
Chapter/Region: MAIC
Location: Stafford, VA
Vehicle:
04 Forester XT
Silver

Default

Quote:
Originally Posted by STiWanabe View Post
airlift tool is your friend

i dont know what this is

Quote:
Originally Posted by marios03wrx View Post
I still think u should get a leakdown or chem test to see if your headgasket has a leak. All your prolonged symptoms ooint to it to me.
head gasket is bad news bears... if it is what it is. wouldnt i get smoke though??? or at least burning coolant?
gaedikus is offline  
Old 01-23-2013, 01:23 PM   #4570
EvileyeZ88
Scooby Specialist
 
Member#: 233501
Join Date: Dec 2009
Chapter/Region: MAIC
Location: Fairfax Va
Vehicle:
07AD 337/335SAXWAGON
99 outback sport

Default

Airlift tool pulls all the air out of the cooling system, then you re-fill the cooling system with non air in it.

I've wanted to get one for a while now, maybe its time I bite the bullet and get it.

I still don't think its a head gasket, I drove around for three months with the same issues about a year ago, not knowing that I had a failed thermostat, I just figured that's what you got when you have a cold thermostat + cold ass weather.

Bring ur car over one day before the sun goes down and we can go over the cooling system once more for leaks, and hopefully burp the bastard for the last time.

~Evil
EvileyeZ88 is offline  
Old 01-23-2013, 03:03 PM   #4571
gaedikus
Scooby Specialist
 
Member#: 310254
Join Date: Feb 2012
Chapter/Region: MAIC
Location: Stafford, VA
Vehicle:
04 Forester XT
Silver

Default

right on dude, i really hope we can get it. picked up another jug of coolant just in casies.
gaedikus is offline  
Old 01-23-2013, 05:04 PM   #4572
marios03wrx
Scooby Specialist
 
Member#: 33593
Join Date: Mar 2003
Chapter/Region: MAIC
Location: Chesapeake, VA
Vehicle:
2002 WrX-ShAgNwAgOn
that is 05 WrX Power'd

Default

Quote:
Originally Posted by gaedikus View Post
head gasket is bad news bears... if it is what it is. wouldn't i get smoke though??? or at least burning coolant?
Not always, i thought the same thing until my 02 motor had the exact same symptoms as yourself. If that super air burp'er tool does not work(I HOPE IT DOES) , Look around for a shop to test/ purchase to use this here---> U-View Hydro Carbon Radiator Leak Cooling System Tester.

Fingers crossed for you. I like to think positive.


Mario
marios03wrx is offline  
Old 01-23-2013, 06:33 PM   #4573
Horner
Scooby Specialist
 
Member#: 324477
Join Date: Jun 2012
Chapter/Region: MAIC
Location: Federalsburg, MD
Vehicle:
2002 2.0 vf43+ meth
6mt wrb sedan

Default

If you have a coolant pressure tester you can hook it up and charge the system. Start the car and see how fast the pressure climbs. Slow increase hg is probably ok. Quick climb in pressure I would look into hg or cracked cyl head. Just went through this same issue with my cousins Pontiac minivan. Turned out cracked cyl head.

Just a thought
Horner is offline  
Old 01-23-2013, 07:06 PM   #4574
Spoolinva
Scooby Specialist
 
Member#: 268071
Join Date: Dec 2010
Chapter/Region: MAIC
Location: NOVA
Vehicle:
2011 STI SWP
09 R6

Default

Put my new BBS on via Matt H. Now I'm ready but monther nature is taking her sweet ass time LOL. And Thank you Browns Subaru of Manassas for putting the lugs on 20x to tight!!!!!!!




Spoolinva is offline  
Old 01-23-2013, 08:01 PM   #4575
subiidude
Scooby Specialist
 
Member#: 141472
Join Date: Feb 2007
Chapter/Region: MAIC
Location: moco
Vehicle:
2008 shagg wgn STI
OG FP20g+e85 corn booze

Default

finally purchased all the parts i need to get my Harbor freight blast cabinet up and running just need my Gun Kote to arrive

subiidude is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
What did you do to your car today? Jester808 Texas Impreza Club Forum -- TXIC 3235 08-05-2013 12:55 AM
what did you do to your car today? Schrecken Bay Area Impreza Club Forum -- BAIC 11 09-25-2012 03:08 AM
What did you do to your Scoob today? Sheehan North West Impreza Club Forum -- NWIC 27 11-23-2007 12:02 PM


All times are GMT -4. The time now is 08:46 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.