Welcome to the North American Subaru Impreza Owners Club Sunday July 13, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Mid Atlantic Impreza Club
Mid Atlantic Impreza Club Forum sponsored by Annapolis Subaru
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Mid Atlantic Impreza Club -- MAIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Closed Thread
 
Thread Tools Display Modes
Old 06-07-2012, 08:00 PM   #1526
DjTrav
Scooby Specialist
 
Member#: 291264
Join Date: Aug 2011
Chapter/Region: MAIC
Location: Pasadena, MD
Vehicle:
2015 WRX Limited
Ice Silver Metallic

Default

Quote:
Originally Posted by ImNOrobo

Maybe buy I cant go anyway. I have to play navy this weekend, stupid duty.
Pay someone to cover your duty, or swap with someone... =)
* Registered users of the site do not see these ads.
DjTrav is offline  
Old 06-07-2012, 08:31 PM   #1527
ImNOrobo
Scooby Specialist
 
Member#: 255716
Join Date: Aug 2010
Chapter/Region: NWIC
Location: Where the simpsons live.
Vehicle:
Oh, It's a JDM STI?
Pretty close.

Default

Our whole duty section is working. I wasn't planning on going anyway. I just want to get my car running before anything.

Today I hooked up the trans plugs, fuel lines, my dual catch can setup and other miscellaneous stuff. I need my downpipe hooked up and all fluids, then I should be able to try and start her up.

Here are the brakes now.




Last edited by ImNOrobo; 06-07-2012 at 09:27 PM. Reason: pic
ImNOrobo is offline  
Old 06-07-2012, 08:32 PM   #1528
Zachfeen
Scooby Specialist
 
Member#: 277479
Join Date: Mar 2011
Chapter/Region: MAIC
Location: Virginia Beach
Vehicle:
2011 WRX
SWP

Default

I have duty this whole weekend too. Weekend duty FTL
Zachfeen is offline  
Old 06-07-2012, 08:33 PM   #1529
Zachfeen
Scooby Specialist
 
Member#: 277479
Join Date: Mar 2011
Chapter/Region: MAIC
Location: Virginia Beach
Vehicle:
2011 WRX
SWP

Default

Quote:
Originally Posted by Hokie-wrx wagon View Post
Nice! I have a similar setup. OEM cross bars, Inno fairing, and 2 Thule Peloton racks (looks like you have the Echelon).
Actually the bike mount is an inno 381, great mount for only 70 bucks.
Zachfeen is offline  
Old 06-07-2012, 09:05 PM   #1530
STiWanabe
Scooby Guru
 
Member#: 41447
Join Date: Aug 2003
Chapter/Region: MAIC
Location: Baltimore, MD
Vehicle:
---- _________

Default

Put my 18s on, ftmfw!!!

STiWanabe is offline  
Old 06-07-2012, 09:28 PM   #1531
EvileyeZ88
Scooby Specialist
 
Member#: 233501
Join Date: Dec 2009
Chapter/Region: MAIC
Location: Fairfax Va
Vehicle:
07AD 337/335SAXWAGON
99 outback sport

Default

Went gold, went to Richmond, got inspected, and came home.


Attached Images
File Type: jpg ForumRunner_20120607_212824.jpg (120.8 KB, 51 views)

Last edited by EvileyeZ88; 06-09-2012 at 12:31 AM.
EvileyeZ88 is offline  
Old 06-07-2012, 09:49 PM   #1532
Uncle Tattoo
Scooby Guru
 
Member#: 139542
Join Date: Feb 2007
Chapter/Region: MAIC
Location: OOPHR (Poquoson, VA)
Vehicle:
2007 Civic Sedan
Daily driver status son

Default

thanks to ppayer38 and hinshawwrx, i was able to swap out my hub/knuckle to solve my busted wheel bearing. the axle nut was siezed on the axle and took a breaker bar with an sti midpipe extender and 260 ft/lb of sexy fat to bust it loose
Uncle Tattoo is offline  
Old 06-08-2012, 07:55 AM   #1533
REDWRX05
Scooby Specialist
 
Member#: 154171
Join Date: Jul 2007
Chapter/Region: MAIC
Location: Chesapeake, VA
Vehicle:
2005 WRX (SRR)
In Need of More Power!!!

Default

^^^ been there before!
I finally got the stars to align and my laptop sync'd with the sun. And flashed my car with the XPT map! I made an attempt to adjust the wastegate acutator arm but just laughed when i seen how rusted it was! So i put the heatshield back over it and called it a night.
REDWRX05 is offline  
Old 06-08-2012, 08:12 AM   #1534
gaedikus
Scooby Specialist
 
Member#: 310254
Join Date: Feb 2012
Chapter/Region: MAIC
Location: Stafford, VA
Vehicle:
04 Forester XT
Silver

Default

Quote:
Originally Posted by EvileyeZ88 View Post
Went gold, went to Richmond, got inspected, and came home.


Attachment 68449
nice wheels bro
gaedikus is offline  
Old 06-08-2012, 08:24 AM   #1535
EvileyeZ88
Scooby Specialist
 
Member#: 233501
Join Date: Dec 2009
Chapter/Region: MAIC
Location: Fairfax Va
Vehicle:
07AD 337/335SAXWAGON
99 outback sport

Default

I know right

Thanks again man
EvileyeZ88 is offline  
Old 06-08-2012, 10:22 AM   #1536
apexhero
Scooby Newbie
 
Member#: 309067
Join Date: Feb 2012
Chapter/Region: South East
Location: Greensboro, NC
Vehicle:
08 WRX STI
Dark Grey Metallic

Default

Quote:
Originally Posted by mangostick
changed my oil.. plasti-dipped the white sport grill I got super cheap (not a huge fan of plasti-dip.. but it'll work for now and I can peel it right off and have it properly painted) ..

installed a nifty new badge on Damaca's car
Agreed on the plasti dip. Thicker the better for ease of removal. But, the fact that you can play around with diff colors/setups is cool. Plus it's cheap
apexhero is offline  
Old 06-08-2012, 12:38 PM   #1537
ppayer38
Scooby Specialist
 
Member#: 234407
Join Date: Jan 2010
Chapter/Region: MAIC
Location: Smithfield, VA
Vehicle:
04 Self-tooned
STi

Default

Fixed my headlight issue so I can drive at night now and did the radioshack buzzer fix so my car has its buzzer back for lock/unlock
ppayer38 is offline  
Old 06-08-2012, 01:12 PM   #1538
prescottn6ft7
Scooby Specialist
 
Member#: 268918
Join Date: Jan 2011
Chapter/Region: MAIC
Location: Virginia Beach, Virginia
Vehicle:
2002 WRX Wagon
WRB

Default

Quote:
Originally Posted by ppayer38 View Post
Fixed my headlight issue so I can drive at night now and did the radioshack buzzer fix so my car has its buzzer back for lock/unlock
My car has never chirped since I bought it... honestly didn't know it was supposed to. Just googled Radio Shack buzzer fix and read up though. Now I know.
prescottn6ft7 is offline  
Old 06-08-2012, 01:28 PM   #1539
ppayer38
Scooby Specialist
 
Member#: 234407
Join Date: Jan 2010
Chapter/Region: MAIC
Location: Smithfield, VA
Vehicle:
04 Self-tooned
STi

Default

Quote:
Originally Posted by prescottn6ft7

My car has never chirped since I bought it... honestly didn't know it was supposed to. Just googled Radio Shack buzzer fix and read up though. Now I know.
Very easy fix and sounds stock haha. I like it cause now I don't have to click the button 3-4 times and hear my Hellas go off haha
ppayer38 is offline  
Old 06-08-2012, 02:21 PM   #1540
ImNOrobo
Scooby Specialist
 
Member#: 255716
Join Date: Aug 2010
Chapter/Region: NWIC
Location: Where the simpsons live.
Vehicle:
Oh, It's a JDM STI?
Pretty close.

Default

You guys do know that you can turn off/on the chirp with the factory stuff right? Mine doesn't chirp unless I hit it three times in a row. I have set it to chirp when it sets but I don't like it.

I am up for the night and it is time to finish this swap!
I need my freaking car back.
ImNOrobo is offline  
Old 06-08-2012, 02:46 PM   #1541
God&Sme
Scooby Specialist
 
Member#: 256567
Join Date: Sep 2010
Chapter/Region: MAIC
Location: Wake Forest, NC/Richmond, VA
Vehicle:
2002 PSM WRX
StiMikey Tuned

Default

finally installed those botox bolts after having them sit in my car for months on end. they didn't line up perfectly the first time so after using a thread chaser and loosening one side at a time, i got em in and WOW, u kats weren't kidding. These joints are a MUST HAVE. haaa, words can't do it justice, u just feel it in yer happy place
God&Sme is offline  
Old 06-08-2012, 07:04 PM   #1542
FakeIt2MakeIt
Scooby Newbie
 
Member#: 240500
Join Date: Mar 2010
Chapter/Region: MAIC
Location: Loudoun, Virginia
Vehicle:
2006 STI
SGM

Default

Put the STI up on jack stands in the garage. Currently painting the BBS's black. Also installed a set of 04-05 tails...looks much better.
FakeIt2MakeIt is offline  
Old 06-08-2012, 07:45 PM   #1543
SlverEJ20
Scooby Specialist
 
Member#: 157158
Join Date: Aug 2007
Chapter/Region: MAIC
Location: Fairfax, Va
Vehicle:
05 WRX stage 2
PSM

Default

Changed the oil, put some coolant in and pulled a nail out of my tire before it really caused some damage.
SlverEJ20 is offline  
Old 06-08-2012, 08:51 PM   #1544
EvileyeZ88
Scooby Specialist
 
Member#: 233501
Join Date: Dec 2009
Chapter/Region: MAIC
Location: Fairfax Va
Vehicle:
07AD 337/335SAXWAGON
99 outback sport

Default

Topped off the brake fluid, changed the rear brakes, and a real nice cleaning of my snazzy new bbs. Thanks again Gaedikus
EvileyeZ88 is offline  
Old 06-08-2012, 08:56 PM   #1545
TV Installer
Scooby Newbie
 
Member#: 322534
Join Date: Jun 2012
Chapter/Region: RMIC
Location: Salt Lake City, Ut
Vehicle:
2008 Subaru WRX
Obsidian Pearl

Default

Installed appradio and amp
TV Installer is offline  
Old 06-08-2012, 10:28 PM   #1546
SlverEJ20
Scooby Specialist
 
Member#: 157158
Join Date: Aug 2007
Chapter/Region: MAIC
Location: Fairfax, Va
Vehicle:
05 WRX stage 2
PSM

Default

Quote:
Originally Posted by ImNOrobo View Post
You guys do know that you can turn off/on the chirp with the factory stuff right? Mine doesn't chirp unless I hit it three times in a row. I have set it to chirp when it sets but I don't like it.

I am up for the night and it is time to finish this swap!
I need my freaking car back.
Yeah but on a lot of cars the chirp stopped working. I've had my car since 07 and I've only heard the chirp a hand full of times. The three clicks thing is the horn. I'm going to look into the radio shack fix and might do it this weekend.
SlverEJ20 is offline  
Old 06-08-2012, 11:08 PM   #1547
Smurftastic
Scooby Specialist
 
Member#: 243697
Join Date: Apr 2010
Chapter/Region: MAIC
Location: Virginia
Vehicle:
02 Stg2+ WRX
Top Scoob 031

Default

Quote:
Originally Posted by SlverEJ20

Yeah but on a lot of cars the chirp stopped working. I've had my car since 07 and I've only heard the chirp a hand full of times. The three clicks thing is the horn. I'm going to look into the radio shack fix and might do it this weekend.
I think it stops chirping if it is in valet mode.
Smurftastic is offline  
Old 06-09-2012, 12:15 AM   #1548
ImNOrobo
Scooby Specialist
 
Member#: 255716
Join Date: Aug 2010
Chapter/Region: NWIC
Location: Where the simpsons live.
Vehicle:
Oh, It's a JDM STI?
Pretty close.

Default

BOOYAH!!!!!!


Nice to hear her running again. This is the stock ecu still and a open downpipe. I just wanted to make sure everything was connected. It is a little after midnight, didn't want to run her for too long.

Now I need to go put the jdm ecu and avcs wiring in. I also need to do the rear diff and hubs as well. & more hours before I have to go to work. Hopefully I can get everything going before then, after work it is tune time baby!!!!!
ImNOrobo is offline  
Old 06-09-2012, 12:29 AM   #1549
EvileyeZ88
Scooby Specialist
 
Member#: 233501
Join Date: Dec 2009
Chapter/Region: MAIC
Location: Fairfax Va
Vehicle:
07AD 337/335SAXWAGON
99 outback sport

Default

Video is private.....and not available on mobile

Glad to see everything is coming along though
EvileyeZ88 is offline  
Old 06-09-2012, 12:31 AM   #1550
ImNOrobo
Scooby Specialist
 
Member#: 255716
Join Date: Aug 2010
Chapter/Region: NWIC
Location: Where the simpsons live.
Vehicle:
Oh, It's a JDM STI?
Pretty close.

Default

HMM, not sure why it did that. I fixed it now.
ImNOrobo is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
What did you do to your car today? Jester808 Texas Impreza Club Forum -- TXIC 3235 08-05-2013 12:55 AM
what did you do to your car today? Schrecken Bay Area Impreza Club Forum -- BAIC 11 09-25-2012 03:08 AM
What did you do to your Scoob today? Sheehan North West Impreza Club Forum -- NWIC 27 11-23-2007 12:02 PM


All times are GMT -4. The time now is 02:42 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.