Welcome to the North American Subaru Impreza Owners Club Thursday July 10, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Mid Atlantic Impreza Club
Mid Atlantic Impreza Club Forum sponsored by Annapolis Subaru
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Mid Atlantic Impreza Club -- MAIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Closed Thread
 
Thread Tools Display Modes
Old 07-01-2012, 01:06 PM   #1901
ThatVAGuy
Scooby Newbie
 
Member#: 272144
Join Date: Jan 2011
Chapter/Region: MAIC
Location: Richmond VA
Vehicle:
2008 Legacy GT Lim

Default

Quote:
Originally Posted by WRX WARRIOR View Post
I have a wrx and sti trunk if it's that bad.
LGT driver here. Thanks for the offer though. Probably going to have to file an ins claim because the trunk is around $500 to fix it.
* Registered users of the site do not see these ads.
ThatVAGuy is offline  
Old 07-01-2012, 01:40 PM   #1902
96accord
Scooby Guru
 
Member#: 145105
Join Date: Apr 2007
Chapter/Region: MAIC
Location: Middle River, Maryland
Vehicle:
2007 WRB WRX Limited

Default

Quote:
Originally Posted by mangostick
hehe.. anyone who actually reads the manual? .. you did buy that car new didn't you Jeff? (pokes with stick) .. didnya? lol

I usually change mine after tree pollen each year. I'm slackin this year, gotta get mine done soon. The car has a funky "well used car" smell to it. lol

Oh, that's anothing thing, you can squirt the new filter with Fabreeze before you throw it in.. just let it dry COMPLETELY first. Then every time you fire up the ac or blower it'll smell nice.
LMAO - your hilarious! People don't read the manual! Come on man. Yes I bought the car brand new. Doesn't mean people who buy a car brand new read the manual. I want to start a poll on here (and maybe ClubWRX) to see how many people actually read their manuals (when they bought the car - not when they had an issue)!

I did spray my new filter with Fabreeze
96accord is offline  
Old 07-01-2012, 01:57 PM   #1903
jozeppi
Scooby Specialist
 
Member#: 247473
Join Date: May 2010
Chapter/Region: MAIC
Location: westminster Md
Vehicle:
2007 wrx
wrb

Default

I didn't buy mine new but no I didn't sit down and read the manual
jozeppi is offline  
Old 07-01-2012, 02:00 PM   #1904
WRX WARRIOR
Scooby Specialist
 
Member#: 267633
Join Date: Dec 2010
Chapter/Region: MAIC
Location: ON THE MOON!!
Vehicle:
It's A Zombie, Bro.
So low my rotors scrape..

Default

Quote:
Originally Posted by ThatVAGuy

LGT driver here. Thanks for the offer though. Probably going to have to file an ins claim because the trunk is around $500 to fix it.
Trade for 04 vf39'd wrx?

I want lgt soooooooo bad!
WRX WARRIOR is offline  
Old 07-01-2012, 03:13 PM   #1905
Joslin Rae
Scooby Specialist
 
Member#: 280613
Join Date: Apr 2011
Chapter/Region: MAIC
Location: VA Beach
Vehicle:
2005 FXT Premium 5MT
PSM & Aqua

Default

Put her up for sale
Joslin Rae is offline  
Old 07-01-2012, 03:15 PM   #1906
WRXinpa
Scooby Specialist
 
Member#: 306708
Join Date: Jan 2012
Chapter/Region: MAIC
Location: Philly
Vehicle:
2012 WRX Hatch SWP
TP Stage 2

Default

Put on Epic springs..
WRXinpa is offline  
Old 07-01-2012, 03:19 PM   #1907
HinshawWRX
Medium Frank
Moderator
 
Member#: 140114
Join Date: Feb 2007
Chapter/Region: MAIC
Location: Common Sense, VA
Vehicle:
2014 Porsche
GT3 (Currently on Fire)

Default

Took off the grimmspeed pulley and got my stuck compression tester fitting out of the spark plug hole.
HinshawWRX is offline  
Old 07-01-2012, 03:29 PM   #1908
mangostick
Scooby Specialist
 
Member#: 256936
Join Date: Sep 2010
Chapter/Region: MAIC
Location: failginia breach
Vehicle:
2013 FRS
pearl white beetches!

Default

Quote:
Originally Posted by 96accord View Post
LMAO - your hilarious! People don't read the manual! Come on man. Yes I bought the car brand new. Doesn't mean people who buy a car brand new read the manual. I want to start a poll on here (and maybe ClubWRX) to see how many people actually read their manuals (when they bought the car - not when they had an issue)!

I did spray my new filter with Fabreeze
I read mine... guess I was the only one. lol I figured I just spent a good chunk of coin on this car I might as well read the stuff that came with it. Did the same with the 07 corolla when I bought that too. Even caught some crap from GF at the time and a buddy for reading the manual on a corolla..

which I might add also has a cabin air filter.
mangostick is offline  
Old 07-01-2012, 05:41 PM   #1909
ImNOrobo
Scooby Specialist
 
Member#: 255716
Join Date: Aug 2010
Chapter/Region: NWIC
Location: Where the simpsons live.
Vehicle:
Oh, It's a JDM STI?
Pretty close.

Default

I read the manual a few months after I bought it. Learned a few things, nothing super exciting though.
ImNOrobo is offline  
Old 07-01-2012, 08:12 PM   #1910
ppayer38
Scooby Specialist
 
Member#: 234407
Join Date: Jan 2010
Chapter/Region: MAIC
Location: Smithfield, VA
Vehicle:
04 Self-tooned
STi

Default

Been doing some MAF tuning today and I'm already onto done quick WOT pulls(thanks to Mikey ! PhatBotti I had a good starting point

Going from my small stock WRX topmount to this HUGE Perrin FMIC I lost 100rpm in spool... So now km only 21psi @ 3600rpm

That is without adjusting timing, boost, or AFR. So by the end of it I should be able to get it back to where it was
ppayer38 is offline  
Old 07-01-2012, 10:16 PM   #1911
metros
Scooby Specialist
 
Member#: 111343
Join Date: Mar 2006
Chapter/Region: MAIC
Location: NoVA
Default

Made a template of my rx7 trunk/hatch outline. When the dibond I ordered arrives I'll be able to apply template, cut, and insert into trunk floor. Then I can mount my accusump to it.

I am going to VIR in October but want to get it out on Summit before then to test everything out.
metros is offline  
Old 07-02-2012, 06:58 AM   #1912
ppayer38
Scooby Specialist
 
Member#: 234407
Join Date: Jan 2010
Chapter/Region: MAIC
Location: Smithfield, VA
Vehicle:
04 Self-tooned
STi

Default

So was doing a little pull to check the MAF again thks morning and popped an IC pipe off :/
That loud POP is scary and even worse I'm in the side of 64 trying to fix it!!
ppayer38 is offline  
Old 07-02-2012, 08:49 AM   #1913
Uncle Tattoo
Scooby Guru
 
Member#: 139542
Join Date: Feb 2007
Chapter/Region: MAIC
Location: OOPHR (Poquoson, VA)
Vehicle:
2007 Civic Sedan
Daily driver status son

Default

^ive done that before. thought i blew the motor til i popped the hood.
Uncle Tattoo is offline  
Old 07-02-2012, 09:31 AM   #1914
FakeIt2MakeIt
Scooby Newbie
 
Member#: 240500
Join Date: Mar 2010
Chapter/Region: MAIC
Location: Loudoun, Virginia
Vehicle:
2006 STI
SGM

Default

^^ I did not that on 95 back when I had my 05 WRX...definitely had me nervous as *****
FakeIt2MakeIt is offline  
Old 07-02-2012, 09:31 AM   #1915
prescottn6ft7
Scooby Specialist
 
Member#: 268918
Join Date: Jan 2011
Chapter/Region: MAIC
Location: Virginia Beach, Virginia
Vehicle:
2002 WRX Wagon
WRB

Default

Quote:
Originally Posted by ppayer38 View Post
So was doing a little pull to check the MAF again thks morning and popped an IC pipe off :/
That loud POP is scary and even worse I'm in the side of 64 trying to fix it!!
Scary.
prescottn6ft7 is offline  
Old 07-02-2012, 09:32 AM   #1916
FakeIt2MakeIt
Scooby Newbie
 
Member#: 240500
Join Date: Mar 2010
Chapter/Region: MAIC
Location: Loudoun, Virginia
Vehicle:
2006 STI
SGM

Default

Was finally able to get STI out of the garage...put in the new axle yesterday.
FakeIt2MakeIt is offline  
Old 07-02-2012, 10:14 AM   #1917
Matt_H
Scooby Guru
 
Member#: 107000
Join Date: Feb 2006
Chapter/Region: MAIC
Location: Bristow, VA
Vehicle:
2008 STI <3 TXS and
2011 F150 Andrewtech

Default

Quote:
Originally Posted by Uncle Tattoo View Post
^ive done that before. thought i blew the motor til i popped the hood.
Same.

Fun fact, you can unplug the maf and limp it.
Matt_H is offline  
Old 07-02-2012, 12:58 PM   #1918
EvileyeZ88
Scooby Specialist
 
Member#: 233501
Join Date: Dec 2009
Chapter/Region: MAIC
Location: Fairfax Va
Vehicle:
07AD 337/335SAXWAGON
99 outback sport

Default

Got really heated because someone did a nice hit and run on me in a parking lot





No note no anything....No one has integrity anymore.

I had literally just finished a 6 hour exterior detail as well
EvileyeZ88 is offline  
Old 07-02-2012, 01:21 PM   #1919
CamaroFS34
Scooby Guru
 
Member#: 6850
Join Date: May 2001
Chapter/Region: MAIC
Location: SoBWI, MD
Vehicle:
Lots of ESP cars
'06 IAG WRX & LT1 Z28s :)

Default

Just packed the car up for a trip to Washington State!
CamaroFS34 is offline  
Old 07-02-2012, 01:46 PM   #1920
ImNOrobo
Scooby Specialist
 
Member#: 255716
Join Date: Aug 2010
Chapter/Region: NWIC
Location: Where the simpsons live.
Vehicle:
Oh, It's a JDM STI?
Pretty close.

Default

Quote:
Originally Posted by ppayer38 View Post
So was doing a little pull to check the MAF again thks morning and popped an IC pipe off :/
That loud POP is scary and even worse I'm in the side of 64 trying to fix it!!
Which connection was that? I never had a problem with it. Sorry to hear that, hopefully you got it fixed ok.
ImNOrobo is offline  
Old 07-02-2012, 02:09 PM   #1921
96accord
Scooby Guru
 
Member#: 145105
Join Date: Apr 2007
Chapter/Region: MAIC
Location: Middle River, Maryland
Vehicle:
2007 WRB WRX Limited

Default

Quote:
Originally Posted by EvileyeZ88 View Post
Got really heated because someone did a nice hit and run on me in a parking lot

No note no anything....No one has integrity anymore.

I had literally just finished a 6 hour exterior detail as well
Ouch! People are so rude! With damage like that they have to know they hit something!!
96accord is offline  
Old 07-02-2012, 02:50 PM   #1922
EvileyeZ88
Scooby Specialist
 
Member#: 233501
Join Date: Dec 2009
Chapter/Region: MAIC
Location: Fairfax Va
Vehicle:
07AD 337/335SAXWAGON
99 outback sport

Default

Yeah it looks like someone just slammed a door into my fender and then pulled out and dragged across my bumper.
EvileyeZ88 is offline  
Old 07-02-2012, 02:57 PM   #1923
ppayer38
Scooby Specialist
 
Member#: 234407
Join Date: Jan 2010
Chapter/Region: MAIC
Location: Smithfield, VA
Vehicle:
04 Self-tooned
STi

Default

Quote:
Originally Posted by ImNOrobo

Which connection was that? I never had a problem with it. Sorry to hear that, hopefully you got it fixed ok.
The charge pipe that goes right into the core... I pulled the foglight cover and stuffed it back on lol

I'm gunna check all of em and retighten before I do anymore pulls
ppayer38 is offline  
Old 07-02-2012, 03:08 PM   #1924
Uncle Tattoo
Scooby Guru
 
Member#: 139542
Join Date: Feb 2007
Chapter/Region: MAIC
Location: OOPHR (Poquoson, VA)
Vehicle:
2007 Civic Sedan
Daily driver status son

Default

jeremy has my leak tester or id say come over and test them lol.
Uncle Tattoo is offline  
Old 07-02-2012, 03:19 PM   #1925
eduSti
Scooby Specialist
 
Member#: 136503
Join Date: Jan 2007
Chapter/Region: MAIC
Location: MD
Vehicle:
08 STI

Default

Quote:
Originally Posted by CamaroFS34 View Post
Just packed the car up for a trip to Washington State!
thats a long way to go for an autox
eduSti is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
What did you do to your car today? Jester808 Texas Impreza Club Forum -- TXIC 3235 08-05-2013 12:55 AM
what did you do to your car today? Schrecken Bay Area Impreza Club Forum -- BAIC 11 09-25-2012 03:08 AM
What did you do to your Scoob today? Sheehan North West Impreza Club Forum -- NWIC 27 11-23-2007 12:02 PM


All times are GMT -4. The time now is 08:45 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.