Welcome to the North American Subaru Impreza Owners Club Sunday July 13, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Mid Atlantic Impreza Club
Mid Atlantic Impreza Club Forum sponsored by Annapolis Subaru
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Mid Atlantic Impreza Club -- MAIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Closed Thread
 
Thread Tools Display Modes
Old 07-07-2012, 01:43 AM   #1976
WRX WARRIOR
Scooby Specialist
 
Member#: 267633
Join Date: Dec 2010
Chapter/Region: MAIC
Location: ON THE MOON!!
Vehicle:
It's A Zombie, Bro.
So low my rotors scrape..

Default

* Registered users of the site do not see these ads.
WRX WARRIOR is offline  
Old 07-07-2012, 02:03 AM   #1977
ppayer38
Scooby Specialist
 
Member#: 234407
Join Date: Jan 2010
Chapter/Region: MAIC
Location: Smithfield, VA
Vehicle:
04 Self-tooned
STi

Default

Sneak peak at the new hood vent while I was building it




It is on the car now but its to dark for any good shots of it so have to wait...

Also wrapped my new GS p&p manifold/crosspipe and will be putting that on tomm as well
ppayer38 is offline  
Old 07-07-2012, 04:55 AM   #1978
ImNOrobo
Scooby Specialist
 
Member#: 255716
Join Date: Aug 2010
Chapter/Region: NWIC
Location: Where the simpsons live.
Vehicle:
Oh, It's a JDM STI?
Pretty close.

Default

Nice man, your taking that piece of lexan to whole new level.

After feeling like **** today I was able to put my Grimmspeed lightweight pulley on and finally got my A/C stuff back on. I also changed my oil and put the splash guard back on, that has been off since the swap. Later today I will purchase some refrigerant and fill up the A/C for the Fam.
ImNOrobo is offline  
Old 07-07-2012, 08:55 AM   #1979
fourdegrees
Scooby Specialist
 
Member#: 49662
Join Date: Dec 2003
Chapter/Region: MAIC
Location: 4.44 WRX gone
Vehicle:
2005 FEALing fine

Default

Got my car aligned at the Firestone in Grafton. Boys didn't do a bad job. Didn't realize how much camber I was going to lose from going back to stock.
fourdegrees is offline  
Old 07-07-2012, 09:11 AM   #1980
96accord
Scooby Guru
 
Member#: 145105
Join Date: Apr 2007
Chapter/Region: MAIC
Location: Middle River, Maryland
Vehicle:
2007 WRB WRX Limited

Default

Quote:
Originally Posted by prashanth View Post
I bought it used for $60.
That's not bad!

Quote:
Originally Posted by WRX WARRIOR View Post
Ewww VA Driven.. That site blows.
96accord is offline  
Old 07-07-2012, 09:58 AM   #1981
WRX WARRIOR
Scooby Specialist
 
Member#: 267633
Join Date: Dec 2010
Chapter/Region: MAIC
Location: ON THE MOON!!
Vehicle:
It's A Zombie, Bro.
So low my rotors scrape..

Default

Quote:
Originally Posted by 96accord

That's not bad!

Ewww VA Driven.. That site blows.
I know but I would rather throw it out there 1st ya know. I just need to get rid of it ASAP.
WRX WARRIOR is offline  
Old 07-07-2012, 10:40 AM   #1982
jozeppi
Scooby Specialist
 
Member#: 247473
Join Date: May 2010
Chapter/Region: MAIC
Location: westminster Md
Vehicle:
2007 wrx
wrb

Default

Just got finished washing
jozeppi is online now  
Old 07-07-2012, 10:41 AM   #1983
ppayer38
Scooby Specialist
 
Member#: 234407
Join Date: Jan 2010
Chapter/Region: MAIC
Location: Smithfield, VA
Vehicle:
04 Self-tooned
STi

Default

Quote:
Originally Posted by ppayer38 View Post
Sneak peak at the new hood vent while I was building it




It is on the car now but its to dark for any good shots of it so have to wait...

Also wrapped my new GS p&p manifold/crosspipe and will be putting that on tomm as well
Quote:
Originally Posted by ImNOrobo View Post
Nice man, your taking that piece of lexan to whole new level.

After feeling like **** today I was able to put my Grimmspeed lightweight pulley on and finally got my A/C stuff back on. I also changed my oil and put the splash guard back on, that has been off since the swap. Later today I will purchase some refrigerant and fill up the A/C for the Fam.
Thanks buddy! and glad to hear your stuff is all back together.

Here's the money shots...


ppayer38 is offline  
Old 07-07-2012, 11:22 AM   #1984
ImNOrobo
Scooby Specialist
 
Member#: 255716
Join Date: Aug 2010
Chapter/Region: NWIC
Location: Where the simpsons live.
Vehicle:
Oh, It's a JDM STI?
Pretty close.

Default

What are the louvres made from, it looks like lexan still? To me they are just a bit too tall but maybe it is the pics. It is unique and no one else has one though
ImNOrobo is offline  
Old 07-07-2012, 11:28 AM   #1985
ppayer38
Scooby Specialist
 
Member#: 234407
Join Date: Jan 2010
Chapter/Region: MAIC
Location: Smithfield, VA
Vehicle:
04 Self-tooned
STi

Default

Quote:
Originally Posted by ImNOrobo
What are the louvres made from, it looks like lexan still? To me they are just a bit too tall but maybe it is the pics. It is unique and no one else has one though
Louvre vent is made from .032 aluminum. Each louvre is just under 2" and has 1" spacing inbetween them with a 2" border all the way around....

Was debating on doing 1" louvres and just make 5-6 1" instead of 3 2"...
ppayer38 is offline  
Old 07-07-2012, 11:47 AM   #1986
ImNOrobo
Scooby Specialist
 
Member#: 255716
Join Date: Aug 2010
Chapter/Region: NWIC
Location: Where the simpsons live.
Vehicle:
Oh, It's a JDM STI?
Pretty close.

Default

If you have any more of that aluminum you should use it for a box around the filter. I need to do that as well.

I can't go back to sleep so I am going to install my new titanium shift knob and charge the A/C now.
ImNOrobo is offline  
Old 07-07-2012, 11:55 AM   #1987
ppayer38
Scooby Specialist
 
Member#: 234407
Join Date: Jan 2010
Chapter/Region: MAIC
Location: Smithfield, VA
Vehicle:
04 Self-tooned
STi

Default

Quote:
Originally Posted by ImNOrobo
If you have any more of that aluminum you should use it for a box around the filter. I need to do that as well.

I can't go back to sleep so I am going to install my new titanium shift knob and charge the A/C now.
I do so let me know how big of a piece you need... I've got some 1/8" plastic I'm gunna use as my heatsheild

Hard to make a box cause there's no room with that huge IC pipe there haha
ppayer38 is offline  
Old 07-07-2012, 01:02 PM   #1988
ImNOrobo
Scooby Specialist
 
Member#: 255716
Join Date: Aug 2010
Chapter/Region: NWIC
Location: Where the simpsons live.
Vehicle:
Oh, It's a JDM STI?
Pretty close.

Default

Man I love wasting money. Refilled the ac only to find a leak at just one connection. It is a bad o-ring. This bad o-ring will end up costing me $100 plus the cost of the ring. Two refrigerant charges is not cheap.
ImNOrobo is offline  
Old 07-07-2012, 01:37 PM   #1989
jozeppi
Scooby Specialist
 
Member#: 247473
Join Date: May 2010
Chapter/Region: MAIC
Location: westminster Md
Vehicle:
2007 wrx
wrb

Default

I know the feeling I went to the shop because my a/c wasn't working all that great and they told me that it was over full on freon and took some out so I paid to have someone take out freon and it didn't make a difference ...sadbanas..
jozeppi is online now  
Old 07-07-2012, 03:20 PM   #1990
Smurftastic
Scooby Specialist
 
Member#: 243697
Join Date: Apr 2010
Chapter/Region: MAIC
Location: Virginia
Vehicle:
02 Stg2+ WRX
Top Scoob 031

Default

I installed the Gimmick Turbo Inlet a few days ago.

As many of you know, fitment is horrible.

Yeah it came off while driving.

That was cool.

Not.
Smurftastic is offline  
Old 07-07-2012, 03:30 PM   #1991
03Rextacy
Scooby Specialist
 
Member#: 239497
Join Date: Feb 2010
Chapter/Region: MAIC
Location: Baltimore
Vehicle:
2003 Impreza WRX
WRB

Default

Quote:
Originally Posted by Smurftastic
I installed the Gimmick Turbo Inlet a few days ago.

As many of you know, fitment is horrible.

Yeah it came off while driving.

That was cool.

Not.
Before I even finished reading this I was already ready to ask how that worked out for ya. I put one on my car when I was doing my build, fitment was so horrible i took it off no sooner than I put it on. I'm always surprised to see some people sporting them. More power to them, and to each their own. In my opinion, I'd think twice even if it was last option.
03Rextacy is offline  
Old 07-07-2012, 03:42 PM   #1992
SneakySh0rty
Scooby Specialist
 
Member#: 280516
Join Date: Apr 2011
Chapter/Region: MAIC
Location: Lake Shore, MD
Vehicle:
03 WRX v9 trans
WRB

Default

Some of you guys are troopers for going out in this heat. Just received my GS pnp/coated exhaust manifold/cross over pipe and a few days ago got my jdm hoodscoop,splitter,tmic.

I was gonna install all of that and change my oil today. But, working in direct sunlight (garage is full of crap) with 106 degree weather is no bueno. sigh
SneakySh0rty is online now  
Old 07-07-2012, 03:43 PM   #1993
Uncle Tattoo
Scooby Guru
 
Member#: 139542
Join Date: Feb 2007
Chapter/Region: MAIC
Location: OOPHR (Poquoson, VA)
Vehicle:
2007 Civic Sedan
Daily driver status son

Default

Quote:
Originally Posted by Smurftastic View Post
I installed the Gimmick Turbo Inlet a few days ago.

As many of you know, fitment is horrible.

Yeah it came off while driving.

That was cool.

Not.
i told you i didnt like that thing! hope you can get it to work right.
Uncle Tattoo is offline  
Old 07-07-2012, 04:03 PM   #1994
Smurftastic
Scooby Specialist
 
Member#: 243697
Join Date: Apr 2010
Chapter/Region: MAIC
Location: Virginia
Vehicle:
02 Stg2+ WRX
Top Scoob 031

Default

Realistically I could have spent more time making the fitment work on the actual turbo. It started getting hot and I got in a rush to finish up. I anticipate spending another two hours working on this.. whereas another hard inlet or Samco silicone inlet would have fit right the first time. I can easily see installing a Samco inlet in less than an hour. This thing is stupid.

I plan to take the TMIC back off, and clean the inside of the inlet and the turbo inlet itself - I believe residue from lubricant used to push the inlet through the manifold could be messing up the craptastic fitment actually staying on. I am TEMPTED to try to use a very wide worm clamp instead of the normal ones. Maybe this will help.
Smurftastic is offline  
Old 07-07-2012, 04:27 PM   #1995
ppayer38
Scooby Specialist
 
Member#: 234407
Join Date: Jan 2010
Chapter/Region: MAIC
Location: Smithfield, VA
Vehicle:
04 Self-tooned
STi

Default

Finally done with car work until the turbo and inlet go on in a few weeks...

Installed the new Grimmspeed p&p mani/crosspipe combo that I wrapped, got my DP wrapped, and made a heat shield for the short ram intake... Will be testing all of these mods tomm to see if they helped at all haha
ppayer38 is offline  
Old 07-07-2012, 04:38 PM   #1996
Smurftastic
Scooby Specialist
 
Member#: 243697
Join Date: Apr 2010
Chapter/Region: MAIC
Location: Virginia
Vehicle:
02 Stg2+ WRX
Top Scoob 031

Default

As long as we are hotter than the seventh layer of hell then I don't know!
Smurftastic is offline  
Old 07-07-2012, 05:56 PM   #1997
ThatVAGuy
Scooby Newbie
 
Member#: 272144
Join Date: Jan 2011
Chapter/Region: MAIC
Location: Richmond VA
Vehicle:
2008 Legacy GT Lim

Default

I washed and AutoScrubbed the car.
ThatVAGuy is offline  
Old 07-07-2012, 06:39 PM   #1998
96accord
Scooby Guru
 
Member#: 145105
Join Date: Apr 2007
Chapter/Region: MAIC
Location: Middle River, Maryland
Vehicle:
2007 WRB WRX Limited

Default

Quote:
Originally Posted by ThatVAGuy View Post
I washed and AutoScrubbed the car.
It's going to rain now that you washed it...
96accord is offline  
Old 07-07-2012, 08:56 PM   #1999
02wrxcruiser
Scooby Newbie
 
Member#: 150277
Join Date: May 2007
Chapter/Region: NWIC
Location: Seattle
Vehicle:
2004 SWP WRX Hatch
WRB

Default

finally got my accessport v1 to plug into my computer and connect (plus or minus 4 hours of my day), updated the firmware from 2004 to 2005, and uploaded some maps to it with no problem. got all excited to finally hook it up to my car and stage 1 91 tune and it turns out my diagport cable is faulty and has a lose connection so it cuts in and out and im missing the white initialization thing. anyone have a diagport cable for a V1 accessport i can use? its 100.00 from cobb if they even have one left. Fail.
02wrxcruiser is offline  
Old 07-07-2012, 09:04 PM   #2000
RUCERUS
Scooby Newbie
 
Member#: 244271
Join Date: Apr 2010
Chapter/Region: MAIC
Location: pa
Vehicle:
2007 built sti
silver

Default

Drove my car 900 miles from Pittsburgh,pa on my way to Vegas in 105+ temps and just happen to play with a XK R jaguare along the way.
RUCERUS is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
What did you do to your car today? Jester808 Texas Impreza Club Forum -- TXIC 3235 08-05-2013 12:55 AM
what did you do to your car today? Schrecken Bay Area Impreza Club Forum -- BAIC 11 09-25-2012 03:08 AM
What did you do to your Scoob today? Sheehan North West Impreza Club Forum -- NWIC 27 11-23-2007 12:02 PM


All times are GMT -4. The time now is 06:59 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.