Welcome to the North American Subaru Impreza Owners Club Wednesday June 3, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-27-2012, 07:43 AM   #1
MDRSK
Scooby Newbie
 
Member#: 226510
Join Date: Oct 2009
Chapter/Region: MAIC
Location: Maryland
Vehicle:
2001 Legacy GT
Black

Default Brake pedal grounding issue?

Have a little problem. I thought I posted it here before and received good advice that it was a bad alternator so I replaced with new (rebuilt) one from AutoZone. I just cannot find that post. Maybe someone else posted it and I just read it, but I still cannot find it.

Problem went away but has since returned. Checked volt reading at off (~12.3) and then charging (~13.5) so all seems good with battery and alternator.

The problem is that when I press the brake pedal, the interior dash lights (including radio) go off.. actually they are very dim. I release the brake pedal and the lights are fine again. If the headlight switch is turned on (i.e. not just DRL), the issue is non-existent.

I suspect it has something to do with a bad ground connected to the brake pedal but wanted to ask you guys if you ever experienced this before. If so, is there a simple fix?

BTW, my 2001 went over 200K miles last week. Actually that momentous event occurred when I was completing the 60 hours of practice driving required in Maryland for new drivers for my 17 year old son. Hard to imagine that he was only 7 when I bought the car from the dealer, and here he is driving it for the past year. Car runs great, but for minor issues such as: this lighting one, a rear speaker that does not work, and the rear differential thud I posted about previously.

I really like my Legacy.

Thanks!
* Registered users of the site do not see these ads.
MDRSK is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 09-20-2012, 10:28 PM   #2
Onewordman
Scooby Newbie
 
Member#: 332827
Join Date: Sep 2012
Default

I have the same problem now. Did you find out what is wrong? I've been searching online for weeks now. Car is dead on the driveway. I've had it towed 3 times in 2 weeks. Whatever it is killed my starter and battery, but alternator is ok.
Onewordman is offline   Reply With Quote
Old 12-11-2012, 10:04 PM   #3
MDRSK
Scooby Newbie
 
Member#: 226510
Join Date: Oct 2009
Chapter/Region: MAIC
Location: Maryland
Vehicle:
2001 Legacy GT
Black

Default

In case you are still interested I sent you a PM. For the rest who may read this, problem ended up being a bad connection located in the trunk area where the rear lights are. Shop I took it to figured it out.

Also had the thud issue fixed as well with rear differential mount. Also ended up getting H&R lowering springs and KYB struts and shocks for my son so he would not be embarrassed driving it. Kids are so silly.
MDRSK is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS:STi complete gas pedal & clutch/brake pedal covers. joe r Interior/Dressup/Audio & Security 11 12-27-2009 08:08 PM
04 manual shift boot piece. Gas pedal, auto brake pedal and auto shifter assembly scOOtNsOOby Interior/Dressup/Audio & Security 0 10-12-2009 10:05 AM
Clicking Sound When Turning and Brake Pedal Pressure Issue WebMasterP Brakes, Steering & Suspension 14 10-11-2008 05:38 AM
Brake Pedal Issue Bearkat Brakes, Steering & Suspension 7 04-03-2006 04:56 PM
Pedal to the floor! Brake pedal that is. elcorazon01 Subaru Conversions 5 06-21-2005 01:48 PM


All times are GMT -4. The time now is 02:59 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.