Welcome to the North American Subaru Impreza Owners Club Tuesday July 29, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Rocky Mountains Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Rocky Mountains Impreza Club Forum -- RMIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-28-2012, 12:58 AM   #1
down2earthsubie
Scooby Specialist
 
Member#: 171448
Join Date: Feb 2008
Chapter/Region: RMIC
Location: west haven utah
Vehicle:
2003 wrx
psm

Default Brake problem on a 02 wrx

So my buddy has a 02 WRX with rs non ABS front brakes. We cannot get it to maintain brake pedal pressure. We replaced the master cylinder. Didn't fix it. Bench bled it too. No leaks anywhere. We cycled the ABS to try to work out bubbles in the ABS system. Nothing. It will build pressure for about 10 seconds then go straight to the floor. The whole system has new fluid we bled it so much. Gone through a 4 bottles. Anyone have any ideas? I think it has to do with the calipers. Anyone have any stock WRX calipers and rotors laying around? Or have an idea for us to test. Thanks.
* Registered users of the site do not see these ads.
down2earthsubie is offline   Reply With Quote
Old 02-28-2012, 01:13 AM   #2
MattTHEpainter
Scooby Specialist
 
Member#: 284046
Join Date: May 2011
Chapter/Region: NESIC
Location: CT
Vehicle:
2000 Impreza w/ WRX

Default

Did you make sure that the calipers are on the correct side. They should be marked "L" for drivers side and "R" for passenger.
MattTHEpainter is offline   Reply With Quote
Old 02-28-2012, 01:39 AM   #3
bhhamblin
n00b Moderator
Moderator
 
Member#: 99397
Join Date: Oct 2005
Chapter/Region: RMIC
Location: Clinton, UT
Vehicle:
13 STI, 83 DR30
93 R32 GTS-T, 93 R32 GTR

Default

^^ Bleeders need to be facing upwards.
bhhamblin is online now   Reply With Quote
Old 02-28-2012, 01:53 AM   #4
08WhiteRex
Scooby Specialist
 
Member#: 187453
Join Date: Aug 2008
Chapter/Region: RMIC
Location: Denver, CO
Vehicle:
2012 Mulletmobile

Default

I've seen and heard of the proportioning valve messing up when a whole lot of air gets in the system.
08WhiteRex is offline   Reply With Quote
Old 02-28-2012, 02:44 AM   #5
azn2nr
Scooby Specialist
 
Member#: 35276
Join Date: Apr 2003
Chapter/Region: RMIC
Location: Salt Lake City, UT
Vehicle:
2006 2.5i clone
438/420 whp

Default

maybe the abs is confused by the non abs brakes? though i dont imagine that would be the case as the abs sensors are on teh axles
azn2nr is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hand brake problem on 02 wrx sedan millerlite1204 Factory 2.0L Turbo Powertrain 7 12-01-2011 07:19 PM
LGT Brakes on an 02 WRX problem Tut4u2 Brakes, Steering & Suspension 1 03-15-2010 07:51 PM
Oil problem on a 02 wrx 02vfWRX Factory 2.0L Turbo Powertrain 11 01-19-2008 05:42 PM
MAJOR problem on my 02 WRX - Power Stearing and Alt nick robinson Factory 2.0L Turbo Powertrain 8 01-08-2007 08:52 PM
Turbo problem on a 02 wrx HotDrifter9 Factory 2.0L Turbo Powertrain 17 06-13-2006 09:55 PM


All times are GMT -4. The time now is 08:42 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.