Welcome to the North American Subaru Impreza Owners Club Saturday July 12, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Alaskan Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Alaskan Impreza Club Forum -- AKIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-04-2012, 10:36 PM   #1
cosseywrx
Scooby Specialist
 
Member#: 276443
Join Date: Mar 2011
Chapter/Region: TXIC
Location: Abilene, TX
Vehicle:
2005 2.1 stroker WRX
OBP

Default 1 and 3 cyl misfires...only when filling up gas tank

so when i left the car running while getn gas today i was getting 1 an 3 cyl misfires...****n weird, gonna check my evap **** and pull the FP prolly


when i turn the car off and fill the tank the car will struggle to start after.

any ideas?

this happens every time i get gas. whether the car is on or off. one or the other happens
* Registered users of the site do not see these ads.
cosseywrx is offline   Reply With Quote
Old 03-04-2012, 10:44 PM   #2
insane_one
Scooby Specialist
 
Member#: 301431
Join Date: Nov 2011
Chapter/Region: AKIC
Location: Anchorage, AK
Vehicle:
2010 Subaru WRX
OBP Hatch

Default

i always thought it was bad to leave the car on anyway when getting gas
insane_one is offline   Reply With Quote
Old 03-04-2012, 10:44 PM   #3
cosseywrx
Scooby Specialist
 
Member#: 276443
Join Date: Mar 2011
Chapter/Region: TXIC
Location: Abilene, TX
Vehicle:
2005 2.1 stroker WRX
OBP

Default

i did that cuz when i fill up the car wont want to start afterwards.
cosseywrx is offline   Reply With Quote
Old 03-04-2012, 11:18 PM   #4
anthonyss
Scooby Newbie
 
Member#: 246879
Join Date: May 2010
Location: skankorage
Vehicle:
1999 audi
blue

Default

Bad fuel pump maybe fuel filter?
anthonyss is offline   Reply With Quote
Old 03-04-2012, 11:33 PM   #5
cosseywrx
Scooby Specialist
 
Member#: 276443
Join Date: Mar 2011
Chapter/Region: TXIC
Location: Abilene, TX
Vehicle:
2005 2.1 stroker WRX
OBP

Default

all is good when im driving...255 FP has like 5k on it
cosseywrx is offline   Reply With Quote
Old 03-04-2012, 11:51 PM   #6
coldfiremx
Scooby Specialist
 
Member#: 285848
Join Date: Jun 2011
Chapter/Region: AKIC
Location: Butte/Palmer
Vehicle:
2002 WRX
Black

Default

Sounds like you may possibly be overfilling your gas tank and saturating your vapor (carbon) canister.
coldfiremx is offline   Reply With Quote
Old 03-05-2012, 12:07 AM   #7
White_Rice
Scooby Specialist
 
Member#: 160049
Join Date: Sep 2007
Chapter/Region: AKIC
Location: Anchorage, AK
Default

Quote:
Originally Posted by coldfiremx View Post
Sounds like you may possibly be overfilling your gas tank and saturating your vapor (carbon) canister.
+1
Never fill to the top.
White_Rice is offline   Reply With Quote
Old 03-05-2012, 12:10 AM   #8
07_STi
Scooby Specialist
 
Member#: 290953
Join Date: Aug 2011
Vehicle:
'12 STi Ltd.

Default

you filling up more after the gas pump automatically cuts out?
07_STi is offline   Reply With Quote
Old 03-05-2012, 12:16 AM   #9
cosseywrx
Scooby Specialist
 
Member#: 276443
Join Date: Mar 2011
Chapter/Region: TXIC
Location: Abilene, TX
Vehicle:
2005 2.1 stroker WRX
OBP

Default

It does not matter how much i put in. Could be 1 gallon or 15. its as soon as i squeeze the handle till i let it go. No i dont over fill
cosseywrx is offline   Reply With Quote
Old 03-05-2012, 12:22 AM   #10
coldfiremx
Scooby Specialist
 
Member#: 285848
Join Date: Jun 2011
Chapter/Region: AKIC
Location: Butte/Palmer
Vehicle:
2002 WRX
Black

Default

Quote:
Originally Posted by cosseywrx
It does not matter how much i put in. Could be 1 gallon or 15. its as soon as i squeeze the handle till i let it go. No i dont over fill
If your car is still equiped with a vapor purge solenoid, disconnect and plug or pinch off the vacuum line going to the solenoid or at the manifold and see if the problem persists.
coldfiremx is offline   Reply With Quote
Old 03-05-2012, 12:23 AM   #11
retrac
Scooby Specialist
 
Member#: 217208
Join Date: Jul 2009
Chapter/Region: AKIC
Location: Alaska
Vehicle:
2001 Porsche 911
Seal Gray

Default

Check the purge solenoid on the intake, if it's failed or not plugged in (vac lines) properly the vapors from the tank will enter the manifold versus the charcoal canister.
retrac is offline   Reply With Quote
Old 03-05-2012, 12:26 AM   #12
cosseywrx
Scooby Specialist
 
Member#: 276443
Join Date: Mar 2011
Chapter/Region: TXIC
Location: Abilene, TX
Vehicle:
2005 2.1 stroker WRX
OBP

Default

Im takn it to a buddies shop tonight and were gonna do that
cosseywrx is offline   Reply With Quote
Old 03-05-2012, 12:27 AM   #13
cosseywrx
Scooby Specialist
 
Member#: 276443
Join Date: Mar 2011
Chapter/Region: TXIC
Location: Abilene, TX
Vehicle:
2005 2.1 stroker WRX
OBP

Default

Wheres the charcoal canister on a 05
cosseywrx is offline   Reply With Quote
Old 03-05-2012, 12:32 AM   #14
retrac
Scooby Specialist
 
Member#: 217208
Join Date: Jul 2009
Chapter/Region: AKIC
Location: Alaska
Vehicle:
2001 Porsche 911
Seal Gray

Default

Quote:
Originally Posted by cosseywrx View Post
Wheres the charcoal canister on a 05
Right rear quarter, underneath the car, aft of the fuel filler.
retrac is offline   Reply With Quote
Old 03-05-2012, 08:40 PM   #15
cosseywrx
Scooby Specialist
 
Member#: 276443
Join Date: Mar 2011
Chapter/Region: TXIC
Location: Abilene, TX
Vehicle:
2005 2.1 stroker WRX
OBP

Default

read this and see if yall make some sense of it...better explanation of what's goin on

http://forums.nasioc.com/forums/show...4#post36552024
cosseywrx is offline   Reply With Quote
Old 03-05-2012, 08:41 PM   #16
cosseywrx
Scooby Specialist
 
Member#: 276443
Join Date: Mar 2011
Chapter/Region: TXIC
Location: Abilene, TX
Vehicle:
2005 2.1 stroker WRX
OBP

Default

read this and see if yall make some sense of it...better explanation of what's goin on

http://forums.nasioc.com/forums/show...4#post36552024
cosseywrx is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
misfire cyl 1 and 3..fuel or electrical? v7 motor fliped wrx Subaru Conversions 10 08-17-2009 07:52 PM
Car Idling Problem When i fill up Gas wrxphantom Factory 2.0L Turbo Powertrain 14 02-03-2007 07:48 PM
I just paid $40 to fill my gas tank fatray Mid Atlantic Impreza Club -- MAIC 27 08-31-2005 12:42 PM
having problems filling up gas tank Benjamin Tang Legacy Forum 12 01-01-2003 11:06 PM
Problem when filling up gas!! Santo Domingo 2.5 RS Normally Aspirated Powertrain 8 04-09-2002 01:12 PM


All times are GMT -4. The time now is 04:21 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.