Welcome to the North American Subaru Impreza Owners Club Tuesday August 4, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Pre-2002 Factory Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-09-2012, 04:02 PM   #1
steveomiami
Scooby Newbie
 
Member#: 309883
Join Date: Feb 2012
Default Weird Idle and running problem

My 1992 wrx idles and seems to run ok with the maf unplugged. I have only driven it in a parking lot so far. If the mac is plugged in the car almost dies then revs to 1500-2000, surging back and forth. When i apply throttle it bogs and when i release the throttle it surges to 2000 rpm again after almost dying. Also where is the iacv? What is the other electronic thing on the top of the engine that is held by 2 screws?
* Registered users of the site do not see these ads.
steveomiami is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 03-10-2012, 01:37 PM   #2
pmugabi
Scooby Newbie
 
Member#: 280926
Join Date: Apr 2011
Default

The IACV is the electronic bit you just described. Did you check for CELs? To get accurate codes you might want to reset the ECU first since you will have a MAF code from running the car with MAF unplugged.
pmugabi is offline   Reply With Quote
Old 03-10-2012, 04:10 PM   #3
steveomiami
Scooby Newbie
 
Member#: 309883
Join Date: Feb 2012
Default

are you sure that is the iacv? when I pull the two screws out and take it out there is a circular magnetic thing that looks like it may spin. I was thinking that the iacv is more near the throttle body. The thing I'm asking about is more to the right.
steveomiami is offline   Reply With Quote
Old 03-10-2012, 10:20 PM   #4
pmugabi
Scooby Newbie
 
Member#: 280926
Join Date: Apr 2011
Default

It is the IACV. That spindle that you see turns a mini 'throttle' that is connected to the air intake by a hose. It was in 99 that the IACV was moved to the throttle body.
pmugabi is offline   Reply With Quote
Old 03-11-2012, 06:21 AM   #5
steveomiami
Scooby Newbie
 
Member#: 309883
Join Date: Feb 2012
Default

Oh ok, when i took it apart that spindle looks a little rough and there are some metal particles in there. Do you think that is my problem or is it the maf since it runs a little better with the maf unplugged?
steveomiami is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Shaking at idle and running lean - was just tuned yesterday.. fourseasonsandles Built Motor Discussion 56 10-07-2010 04:22 PM
Weird Hit and Run Incident Last Night St3fan Off-Topic 62 11-17-2008 03:14 PM
help, weird idling and shifter problems yeng Normally Aspirated Powertrain 0 07-26-2008 05:47 AM
Weird idle and car pulsing mogrl840 Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 18 03-05-2006 12:24 PM
Help: weird idling and no throttle response Freeskier General Forum Archive 1 02-22-2001 10:47 PM


All times are GMT -4. The time now is 08:24 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.