Welcome to the North American Subaru Impreza Owners Club Thursday September 18, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-12-2012, 08:20 PM   #1
Grieby54
Scooby Newbie
 
Member#: 244643
Join Date: Apr 2010
Chapter/Region: RMIC
Location: Golden, CO
Vehicle:
2005 WRX Stage 2
CGM

Default 2005 WRX Air Conditioning Stopped Working

The title pretty well says it all. It's been winter up here in Colorado and I haven't had much need to use the A/C, but now that it's warming up it doesn't seem to be working. I grabbed one of those charge systems from Auto Zone with the the gauge on it, dumped pretty much the entire can in there, and with the A/C on the gauge didn't climb much. However, when I turn the A/C off the pressure jumps up to ~45 psi (I know it should be around ~35 psi). After putting half a can in, it seemed to work just fine. Then, the next day (I filled it, parked it, and left it all night) it was back to not working. Used the rest of the can, and repeated. Still not working.

I checked the door that's behind the glove box and it appears to be working, so I'm not sure what to do. The air is still hot regardless of whether or not I have the A/C on or recirculation on. I have the climate control model. There is no belt squeal, no chirping when I turn the A/C on, or any of that.

Any thoughts would be appreciated.
* Registered users of the site do not see these ads.
Grieby54 is offline   Reply With Quote
Old 03-12-2012, 10:42 PM   #2
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 WRX
15 WRX/05 GTO

Default

The system has a leak, take it to a shop and have it diagnosed and repaired properly. Once the leak is repaired it will have to be evacuated with a vacuum pump and recharged to the correct pressures with manifold gauges.
Mulder is offline   Reply With Quote
Old 03-14-2012, 03:18 PM   #3
workinprogress
Scooby Newbie
 
Member#: 310341
Join Date: Feb 2012
Chapter/Region: South East
Location: Clayton, NC
Vehicle:
08 WRX Sedan
Silver

Default

^ sums it up. With a leak that fast you probably had something hit the condenser or one of the lines and cause a serious seal leak. Some UV dye and light should find the location. Then you're probably looking at receiver/dryer and an evac/recharge.
workinprogress is offline   Reply With Quote
Old 03-28-2012, 10:45 AM   #4
Grieby54
Scooby Newbie
 
Member#: 244643
Join Date: Apr 2010
Chapter/Region: RMIC
Location: Golden, CO
Vehicle:
2005 WRX Stage 2
CGM

Default

Quote:
Originally Posted by workinprogress View Post
^ sums it up. With a leak that fast you probably had something hit the condenser or one of the lines and cause a serious seal leak. Some UV dye and light should find the location. Then you're probably looking at receiver/dryer and an evac/recharge.
Any idea how much this is going to cost me?
Grieby54 is offline   Reply With Quote
Old 03-28-2012, 04:47 PM   #5
Unabomber
Big Ron
Moderator
 
Member#: 18062
Join Date: Apr 2002
Chapter/Region: MAIC
Location: I can save you a ton of cash
Vehicle:
on car parts so PM
me b4 j00 buy

Default

We don't guess costs here as we have no way of knowing. My last AC leak was diagnosed for $0 because I brought in a box of Duncan Donuts for the shop. See what I mean?
Unabomber is offline   Reply With Quote
Old 04-01-2012, 11:01 PM   #6
easterbran
Scooby Specialist
 
Member#: 307359
Join Date: Jan 2012
Chapter/Region: South East
Location: Tyrone,GA
Vehicle:
'05 STi Stage II
OBP

Default

Quote:
Originally Posted by Unabomber
We don't guess costs here as we have no way of knowing. My last AC leak was diagnosed for $0 because I brought in a box of Duncan Donuts for the shop. See what I mean?
Haha "Duncan" Donuts
easterbran is online now   Reply With Quote
Old 04-01-2012, 11:02 PM   #7
easterbran
Scooby Specialist
 
Member#: 307359
Join Date: Jan 2012
Chapter/Region: South East
Location: Tyrone,GA
Vehicle:
'05 STi Stage II
OBP

Default

Oh, and I've got the same issue as you. Winter just ended and AC is blowing nothing but hot air. Gonna take it to the dealer. 05 sti btw
easterbran is online now   Reply With Quote
Old 05-05-2012, 02:32 PM   #8
easterbran
Scooby Specialist
 
Member#: 307359
Join Date: Jan 2012
Chapter/Region: South East
Location: Tyrone,GA
Vehicle:
'05 STi Stage II
OBP

Default

My A/C is fixed... 2 O rings failed and had to be replaced.
easterbran is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Air conditioning wont work! ramrod Texas Impreza Club Forum -- TXIC 8 02-16-2010 04:10 PM
NJ: WRX air conditioning compressor Cosworth Private 'For Sale' Classifieds 5 09-26-2005 04:37 PM
'04 WRX Air Conditioning Not Working aearnhardt Warranty Issues & SOA Problems 4 05-19-2005 07:48 PM
Rear lights out... air condition not working?? Impreza2.5RSTi Normally Aspirated Powertrain 2 11-06-2002 10:23 AM


All times are GMT -4. The time now is 08:32 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.