Welcome to the North American Subaru Impreza Owners Club Friday July 11, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Car Audio, Video & Security

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-04-2014, 05:26 PM   #1
SJSharks
Scooby Newbie
 
Member#: 384157
Join Date: Mar 2014
Chapter/Region: BAIC
Location: San Jose, CA
Vehicle:
2014 WRX Hatch
DGM

Default Spotify and Bluetooth Audio

Anyone else having issues with Spotify and Bluetooth Audio? I have to go to my phone every time I start up the car and press play. It used to play automatically before the new update from Google Play.
* Registered users of the site do not see these ads.
SJSharks is offline   Reply With Quote
Old 06-04-2014, 08:46 PM   #2
lawstSon
Scooby Newbie
 
Member#: 387672
Join Date: Apr 2014
Chapter/Region: AKIC
Location: Ketchikan, AK
Vehicle:
2014 WRX Limited
SWP

Default

I have to do that for all my bluetooth audio apps (Pandora, Spotify, and Google play) Spotify doesn't even display on the screen when I use it. Also I can't have my phone connected for both media and voice call, for some reason when I disconnect the voice call media works and vise versa.

I use my
Samsung Galaxy S4 Active, Android ver 4.2.2
lawstSon is offline   Reply With Quote
Old 06-05-2014, 12:44 PM   #3
SJSharks
Scooby Newbie
 
Member#: 384157
Join Date: Mar 2014
Chapter/Region: BAIC
Location: San Jose, CA
Vehicle:
2014 WRX Hatch
DGM

Default

Quote:
Originally Posted by lawstSon View Post
I have to do that for all my bluetooth audio apps (Pandora, Spotify, and Google play) Spotify doesn't even display on the screen when I use it. Also I can't have my phone connected for both media and voice call, for some reason when I disconnect the voice call media works and vise versa.

I use my
Samsung Galaxy S4 Active, Android ver 4.2.2
Hmm.. that's a shame. I don't think I have the issue with the media/voice though, but we have different phones so that could be the issue as there could be different bluetooth software. Do Iphone users experience this as well? BTW I am on a Moto X
SJSharks is offline   Reply With Quote
Old 06-08-2014, 08:15 PM   #4
goleee33
Scooby Newbie
 
Member#: 301701
Join Date: Nov 2011
Chapter/Region: SCIC
Location: Orange County, CA
Vehicle:
2012 WRX 5-Door
SWP

Default

with my Iphone 5 its about 50/50 playing automatically. I think it depends on how long i wait before getting back in the car. If its the next day, then usually it won't play. If its 20-30 minutes, it will play.
goleee33 is offline   Reply With Quote
Old 06-09-2014, 07:34 PM   #5
socalwrxx
Scooby Newbie
 
Member#: 243484
Join Date: Apr 2010
Chapter/Region: SCIC
Location: Orange County
Vehicle:
2008 WRX

Default

If you have android you can use an app called tasker.

Create a task that launches spotify and plays when connected to car bluetooth
socalwrxx is offline   Reply With Quote
Old 06-09-2014, 08:36 PM   #6
SJSharks
Scooby Newbie
 
Member#: 384157
Join Date: Mar 2014
Chapter/Region: BAIC
Location: San Jose, CA
Vehicle:
2014 WRX Hatch
DGM

Default

Quote:
Originally Posted by socalwrxx View Post
If you have android you can use an app called tasker.

Create a task that launches spotify and plays when connected to car bluetooth
Interesting.. I will have to give that a shot.

Echoing goleee33, I notice now that it plays automatically when I return to the car within 30 min or so too.
SJSharks is offline   Reply With Quote
Old 06-09-2014, 09:03 PM   #7
carlos.danger
Scooby Newbie
 
Member#: 363268
Join Date: Jul 2013
Location: California
Vehicle:
2015 WRX STi
WRB

Default

im having the same danged problem. I keep thinking its my slightly antiquated android phone but now im not so sure. maybe ill try tasker.....
carlos.danger is offline   Reply With Quote
Old 06-10-2014, 01:04 PM   #8
sc00ter
Scooby Guru
 
Member#: 117767
Join Date: Jun 2006
Chapter/Region: RMIC
Location: Denver, CO
Vehicle:
2011 STI Sedan
DGM

Default

I always had this issue with Spotify. I switched to Google Play Music and it resolved the auto play issue.

I recommend giving Google Music a try for a month. I did that and after going back and forth between that and Spotify I've been much happier with Google Music. The auto play fix was just an extra bonus.
sc00ter is offline   Reply With Quote
Old 06-10-2014, 04:56 PM   #9
socalwrxx
Scooby Newbie
 
Member#: 243484
Join Date: Apr 2010
Chapter/Region: SCIC
Location: Orange County
Vehicle:
2008 WRX

Default

Quote:
Originally Posted by carlos.danger View Post
im having the same danged problem. I keep thinking its my slightly antiquated android phone but now im not so sure. maybe ill try tasker.....
Its not a stereo problem its a caching/RAM issue where spotify loses priority. It happens with my sony bluetooth stereo also. Give tasker a try!
socalwrxx is offline   Reply With Quote
Old 06-10-2014, 06:06 PM   #10
carlos.danger
Scooby Newbie
 
Member#: 363268
Join Date: Jul 2013
Location: California
Vehicle:
2015 WRX STi
WRB

Default

Quote:
Originally Posted by socalwrxx View Post
Its not a stereo problem its a caching/RAM issue where spotify loses priority. It happens with my sony bluetooth stereo also. Give tasker a try!
but tasker costs. 2.99 and I just spent $35k on this car.....grrrrrrrr
carlos.danger is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 10:38 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.