Welcome to the North American Subaru Impreza Owners Club Wednesday October 26, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Go Back   NASIOC > NASIOC General > General Community

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Thread Tools Display Modes
Old 03-15-2012, 02:35 PM   #1
Scooby Newbie
Member#: 310131
Join Date: Feb 2012
Location: Los Angeles
2013 Impreza Limited
Satin White Hatchback

Unhappy Bluetooth problem on 2012 Impreza Limited

I have my phone paired with the car system. The phone is on the compatibility list. When I'm driving and a phone call comes in I can't answer the call from the "off hook" button on the steering wheel. The screen shows the phone # for a second and then goes back to the radio while the actual phone is still ringing.
When I open my flip phone then the call goes through the car audio system.

I tried to duplicate this problem in my driveway by calling my cell from the house phone. It worked properly every time. I even started the engine to see if that made a difference but the system worked flawlessly.

Why is this only happening on the road?? I am getting a good signal because the BT works when I answer the call on the cell itself. Subaru said to re-initialize the system or take to the dealer but then I loose all my contact info.

* Registered users of the site do not see these ads.
bruuster is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 03-15-2012, 02:38 PM   #2
*** Banned ***
Member#: 302570
Join Date: Nov 2011
Location: dear old dixie
2013 XV


I've tried getting my bluetooth to work with any amount of ease and give up. Its glitchy and imo very poorly executed. Sometimes mine works and sometimes it just wont.
79letour is offline   Reply With Quote
Old 03-15-2012, 02:39 PM   #3
Scooby Guru
Member#: 159474
Join Date: Sep 2007
Chapter/Region: Tri-State
Location: Mahwah, New Jersey
2013 BRZ Ltd 6MT CBS


This is all news to me.

Seriously, you should post this in the Technical forums or Impreza forums. It would be much faster.
chanomatik is offline   Reply With Quote
Old 03-15-2012, 02:44 PM   #4
Scooby Specialist
Member#: 88288
Join Date: Jun 2005
Chapter/Region: NESIC
Location: Central MA
.... At this point,
even I have lost track.


Way wrong section.........try the Car Audio, Video, and Security section of the NASIOC General first page. Or maybe Newbie or Impreza Model section way down at the bottom of the main forums page, under the specific models section.
SilverSubaab is offline   Reply With Quote
Old 03-15-2012, 08:01 PM   #5
Scooby Newbie
Member#: 258846
Join Date: Sep 2010
Chapter/Region: MAIC
Location: Chesapeake, VA
2011 Impreza WRX
Blue Pearl


I have an iPhone and the system works flawlessly for me. In my opinion the flip phone maybe cuts it off because it's closed?? you might need the change the settings on your phone to get it to work properly. Or the problem may be you need a smart phone for it to work flawlessly. It might even say it in the manual. Take a look.
fbjr2003 is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
('11-'14) OC interval and the first oil change on 2012 Impreza 2.0 Oceanguy Impreza Forum 80 11-18-2012 12:56 PM
Help with JBL MS-8 install on 2012 impreza sport premium gobells12785 Car Audio, Video & Security 9 03-23-2012 09:56 PM
Need Advice on 2012 Impreza Aftermarket Nav/Satellite Radio options kendor Car Audio, Video & Security 3 03-04-2012 04:47 PM
Need Advice on 2012 Impreza Aftermarket Nav/Satellite Radio options kendor Newbies & FAQs 4 03-04-2012 10:57 AM
Oxygen Sensor problems on 2000 Impreza 2.5 RS knoffer Normally Aspirated Powertrain 11 12-03-2001 01:42 AM

All times are GMT -4. The time now is 10:44 AM.

Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.