Welcome to the North American Subaru Impreza Owners Club Friday August 1, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-27-2012, 07:10 AM   #1
lolol
Scooby Newbie
 
Member#: 311801
Join Date: Feb 2012
Chapter/Region: NWIC
Location: Portland OR
Default Loud knocking from A/C compressor.. 1990 Legacy

So, the A/C was completely dead on this thing. It wouldn't even come on, then I found the charge was completely gone.

I pulled a vacuum, found that it was leaking at schrader valves. Replaced shrader.

Pulled a vacuum again, charged with 850g of refrigerant 12 (spec calls 800-900g)

Now the compressor comes on but the input and output are both hot and neither pipe is getting cold. It also makes a horrendous knocking sound, like an MRI machine.

I need to hookup gauges, but I don't have the high side fitting for R12, but even then something is seriously screwed. What a freaking waste of two pounds of R12.
* Registered users of the site do not see these ads.
lolol is offline   Reply With Quote
Old 03-27-2012, 10:22 AM   #2
CRAZYHAWK
Scooby Specialist
 
Member#: 198067
Join Date: Dec 2008
Chapter/Region: Tri-State
Location: RAMSEY, NJ
Vehicle:
2009 IMPREZA 2.5i 4d
WHITE Premium

Default

If your going to do major work on the A/C system, change to R143a.
CRAZYHAWK is offline   Reply With Quote
Old 03-27-2012, 11:10 AM   #3
SilverBOXER4
Scooby Specialist
 
Member#: 119934
Join Date: Jul 2006
Chapter/Region: TXIC
Location: DFW
Vehicle:
2013 Legacy Sport
SWP

Default

^ He meant 134a
SilverBOXER4 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ridiculously loud knock from motor 22psiSTI Southern California Impreza Club Forum -- SCIC 9 01-18-2010 07:58 PM
Power Loss and loud knock from under the hood. STIdreamer17 Factory 2.0L Turbo Powertrain 6 10-05-2009 06:34 PM
loud knock from block, all rpm range, all the time. Quix Service & Maintenance 6 07-16-2007 08:08 PM
1990 Legacy wagon with a loud, obnoxious rear end the_legacy Legacy Forum 3 11-14-2005 01:51 AM
burning oil and loud knocking sound coming from cyl. 3 ? RS2000 Normally Aspirated with bolt-on Forced Induction Powertrain 15 04-16-2002 03:07 AM


All times are GMT -4. The time now is 06:18 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.